Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2016-11-21 08:13:34 GMT <bhagyas> Good morning all

2016-11-21 08:15:47 GMT <fcorti> morning

2016-11-21 08:19:03 GMT <yreg> Morning !

2016-11-21 08:25:45 GMT <bhagyas> Is anyone watching Black Mirror on Netflix

2016-11-21 08:43:23 GMT <AxelFaust> bhagyas: Only showed up on my start screen this weekend - alongside Designated Survivor, which I started to binge (the few episodes that are actually available)

2016-11-21 08:44:02 GMT <bhagyas> AxelFaust: Loftux also recommended me to watch Designated Survivor

2016-11-21 08:45:36 GMT <AxelFaust> Yeah - I had no idea what it was going to be about (don't really follow any new show announcements) and just wanted to scan the first few minutes, because I had something else planned for Saturday evening. Worked out quite differently...

2016-11-21 08:46:02 GMT <DarkStar1> Morning everyone

2016-11-21 08:47:27 GMT <bhagyas> Since all the hype, I tried Black Mirror

2016-11-21 08:47:55 GMT <bhagyas> episode 1 is basically about a gamified community where people are ranked based on how they behave :P

2016-11-21 08:48:02 GMT <bhagyas> felt a lot similar to Alfresco Community Community

2016-11-21 08:48:13 GMT <bhagyas> or gamification and social in general

2016-11-21 08:48:22 GMT <bhagyas> and then realised it was more of a horror

2016-11-21 08:51:10 GMT <Hiten> Hi Guys, I want to hide the download version link for users with Consumers permission in a site

2016-11-21 08:52:11 GMT <Hiten> I was thinking on the lines of site creation permission

2016-11-21 08:52:11 GMT <Hiten> http://docs.alfresco.com/5.0/tasks/site-creation-permission.html

2016-11-21 08:52:13 GMT <alfbot> Title: Controlling site creation permissions | Alfresco Documentation (at docs.alfresco.com)

2016-11-21 08:52:50 GMT <Hiten> but I can't find any bean in the public-services-security-context.xml related to version security

2016-11-21 08:53:27 GMT <Hiten> please let me know how can I hide the link

2016-11-21 08:53:30 GMT <bhagyas> Hiten: Interesting part is download is treated the same as View

2016-11-21 08:53:32 GMT <DarkStar1> Morning everyone

2016-11-21 08:53:38 GMT <bhagyas> DarkStar1: Morning :p

2016-11-21 08:53:58 GMT <DarkStar1> bhagyas: How are you up there in the east? :)

2016-11-21 08:54:15 GMT <bhagyas> Much better

2016-11-21 08:54:22 GMT <bhagyas> Was sunny yesterday and day before

2016-11-21 08:54:54 GMT <DarkStar1> same down here south. Although the temperature really dropped the second the clouds came up

2016-11-21 08:55:16 GMT <bhagyas> yeah, there is a good reason to hate clouds in Nordics ;p

2016-11-21 08:56:46 GMT <Hiten> <bhagyas>: Sorry, not able to get what you said. What should be the next step ??

2016-11-21 08:57:15 GMT <bhagyas> Hiten: You would need to remove the button with a custom javascript instead - because Alfresco treats View and Download as the same

2016-11-21 08:58:14 GMT <bhagyas> Which actually makes sense technically

2016-11-21 08:58:26 GMT <bhagyas> Hard part is explaining to the users that they are the same

2016-11-21 08:58:29 GMT <bhagyas> :D

2016-11-21 09:07:15 GMT <Hiten> @bhagyas: So, I should override document-version.js and in function getDocumentVersionMarkup: function DocumentVersions_getDocumentVersionMarkup(doc) I should have a if that will check the group of the user

2016-11-21 09:07:31 GMT <Hiten> ??

2016-11-21 09:08:33 GMT <bhagyas> Hiten: Can't remember exact place, but wherever that renders the Download button should have the check

2016-11-21 09:08:34 GMT <bhagyas> :)

2016-11-21 09:08:57 GMT <Hiten> cool

2016-11-21 09:09:27 GMT <bhagyas> Maybe take off the download button completely and add a Document action instead

2016-11-21 09:09:58 GMT <bhagyas> so you won't get people asking why I don't see a download button like the other user

2016-11-21 09:09:59 GMT <bhagyas> :p

2016-11-21 09:12:32 GMT <Hiten> an action for each version that will download the versioned files

2016-11-21 09:12:33 GMT <Hiten> ??

2016-11-21 09:12:43 GMT <DarkStar1> Anyone who's tried records management before know which version is 5.0.d compatible?

2016-11-21 09:19:21 GMT <bhagyas> Hiten: Ah, just realised you mentioned the version download, not the big download button

2016-11-21 09:19:33 GMT <bhagyas> ignore early comment

2016-11-21 09:24:27 GMT * AxelFaust slams his head into the next available wall. (stupid bug in "Create Site" dialog can cause RM Site to be 100% non-functional)

2016-11-21 09:25:17 GMT <AxelFaust> ... or better yet, stupid hard-coding of the site short name in some RM module admin console tools might be considered the bug.

2016-11-21 09:25:40 GMT <DarkStar1> I've never used RM before but that doesn't instil confidence in instaling this product

2016-11-21 09:26:09 GMT <AxelFaust> I am using 4.2.b right now.

2016-11-21 09:26:22 GMT <AxelFaust> Haven't checked if 2.5 will fix this

2016-11-21 09:26:35 GMT <DarkStar1> I've just been asked to look into this on friday

2016-11-21 09:26:52 GMT <AxelFaust> They have adapted the Create Site dialog so that when you pick the preset "Records Management", the site name and URL name are prefilled.

2016-11-21 09:27:27 GMT <DarkStar1> AxelFaust: so the RM version does have a wide alfresco compatibility range?

2016-11-21 09:27:31 GMT <AxelFaust> BUT: When you - for some reason - click into the read-only site name field, its default behaviour is triggered and recalculated the URL name based on the site name.

2016-11-21 09:27:46 GMT <AxelFaust> Unfortunately, the RM module requires the URL name to be "rm" but the recalculated URL name is "records-maangement"

2016-11-21 09:28:03 GMT <AxelFaust> And BAM - nothing works anymore

2016-11-21 09:28:41 GMT <AxelFaust> As a user you don't notice it at first and can't do anything to correct it after the behavior got triggered.

2016-11-21 09:29:05 GMT <DarkStar1> AxelFaust: maybe it was supposed to be a surprise or an easter egg bug hunt, and now you've ruined it :)

2016-11-21 09:29:06 GMT <AxelFaust> Only chance is to restart the dialog / unselect+reselect the preset

2016-11-21 09:29:20 GMT <AxelFaust> DarkStar1: They only specify the minimum Repository version in their module.

2016-11-21 09:29:32 GMT <AxelFaust> But I haven't checked if they have indicated an upper version bound.

2016-11-21 09:29:52 GMT <AxelFaust> Needless to say I am using the RM version that is listed in the same file listing as the base Alfresco version I am using...

2016-11-21 09:31:54 GMT <aviriel> hi all!

2016-11-21 09:32:25 GMT <AxelFaust> Look who's back!

2016-11-21 09:32:27 GMT <AxelFaust> Hi aviriel

2016-11-21 09:32:37 GMT <aviriel> heh, I'm here to ask a question :)

2016-11-21 09:32:38 GMT *** AxelFaust is now known as AFaust

2016-11-21 09:33:52 GMT <aviriel> small Aikau question: can I apply css class to the cell (or property inside it) in the AlfList/AlfListView, if classname is inside the object that I render? I try to use `additionalCssClasses: "mediumpad {css}",` but it does not render {css} as expected

2016-11-21 09:34:36 GMT <aviriel> I want to complete this project quicker and start working on BeeCon, but it's so difficult :(

2016-11-21 09:35:20 GMT <yreg> is {css} a tocken that need to be processed ?

2016-11-21 09:35:50 GMT <aviriel> yreg: yes. I'll share it via gist, 1 sec

2016-11-21 09:37:29 GMT <aviriel> https://gist.github.com/aviriel/4642a64a2eab95896bc88b8d90fa6d94

2016-11-21 09:37:30 GMT <alfbot> Title: alflis and custom css · GitHub (at gist.github.com)

2016-11-21 09:37:39 GMT * DarkStar1 greets aviriel

2016-11-21 09:37:46 GMT <aviriel> DarkStar1: hi!

2016-11-21 09:38:52 GMT <yreg> aviriel, is css a property in each and every item ?

2016-11-21 09:38:59 GMT <aviriel> yreg: yes

2016-11-21 09:39:41 GMT <aviriel> when I want to use data in payload, I use processCurrentItemTokens and then "{nodeRef}. And it works. If I want to render and show a property, then it's propertyToRender: "...". What can I do with css?:)

2016-11-21 09:41:05 GMT <DarkStar1> hey yreg. How goes <insert your current country here> ?

2016-11-21 09:41:08 GMT <yreg> publishPayloadModifiers only modifies tokens in your publish payload

2016-11-21 09:41:27 GMT <yreg> not in the full object definition

2016-11-21 09:41:53 GMT <aviriel> yreg: I understand :( then how to do it?

2016-11-21 09:44:46 GMT <yreg> aviriel, have you gone through this : https://github.com/Alfresco/Aikau/blob/develop/tutorial/chapters/Tutorial5.md

2016-11-21 09:44:47 GMT <alfbot> Title: Aikau/Tutorial5.md at develop · Alfresco/Aikau · GitHub (at github.com)

2016-11-21 09:44:51 GMT <yreg> Hey DarkStar1 !

2016-11-21 09:44:55 GMT <yreg> how it goes ?

2016-11-21 09:46:51 GMT <aviriel> yreg: yes, but I'm not sure how it works if I don't want to create new widget, I just want to use AlfList/AlfListView on the page.. If the only way is to do it in a custom widget, then ok

2016-11-21 09:47:22 GMT <yreg> aviriel, it has been a while since I played with aikau, but you will probably need to extend the row widget

2016-11-21 09:48:06 GMT <aviriel> ok, got it :(

2016-11-21 09:48:16 GMT <AFaust> aviriel: yreg is right in as far you cannot use tokens outside of the default processing scope (the publishPayload) and would need to extend the widget for custom class handling.

2016-11-21 09:48:25 GMT <AFaust> I have done this recently for ootbee-support-tools

2016-11-21 09:49:24 GMT <aviriel> AFaust: how do you find time to work on this too?!

2016-11-21 09:49:26 GMT <AFaust> See https://github.com/AFaust/ootbee-support-tools/tree/master/share/src/main/amp/web/ootbee-support-tools/list for an example of dynamic "additionalCssClasses" in a row and cell widget (based on a mixin)

2016-11-21 09:49:28 GMT <alfbot> Title: ootbee-support-tools/share/src/main/amp/web/ootbee-support-tools/list at master · AFaust/ootbee-support-tools · GitHub (at github.com)

2016-11-21 09:49:35 GMT <aviriel> thanks a lot

2016-11-21 09:49:42 GMT <AFaust> Having "no life" helps... ;)

2016-11-21 09:50:45 GMT <bhagyas> AFaust:

2016-11-21 09:51:05 GMT <bhagyas> maybe you're having two :p

2016-11-21 09:52:04 GMT <AFaust> At PRODYNA I had created a custom "base widget" that most of our custom widgets extended from, which supported dynamic CSS classes out of the box via configurable rules (e.g. if condition A matches apply class X and Y)

2016-11-21 09:52:54 GMT <aviriel> AFaust: we need your new fork of Aikau. Or at least an addon with a number of custom services and widgets

2016-11-21 09:52:57 GMT <AFaust> I'll have to see if I can use the new "aikau" collaboration package inside of project "Aikau" to get that feature integrated

2016-11-21 09:56:38 GMT <DarkStar1> yreg: Not bad. Although dealing with the onset of a cold today.

2016-11-21 09:57:42 GMT <DarkStar1> AFaust: I just installed RM and came across your bug. That's quite an >:/ annoying bug

2016-11-21 10:16:58 GMT <AFaust> DarkStar1: Also seeing some minor UI funkyness where RM folks apparently haven't bothered (yet) to file an issue with Aikau project (e.g. in "Add Relationship" dialog there are some fields without a label but still they have the :* and an offset, which just looks wonky)

2016-11-21 10:18:23 GMT <DarkStar1> AFaust: I haven't used RM before so this is new territory, I got around the issue by removing the applied disabled property on the site name field and it worked

2016-11-21 10:18:46 GMT <AFaust> Ah - it is "slightly" better when I install the most recent Aikau version instead of the one RM ships with, so they actually may have reported some of it.

2016-11-21 10:19:38 GMT <AFaust> DarkStar1: Sure as technically savvy people "we" can work around that...

2016-11-21 10:19:57 GMT <DarkStar1> (Since I only need it for testing purposes this is sufficient for now) I should say it seems to work because no errors were reported in the logs but admin can't access RM Admin tools on the site I created

2016-11-21 10:20:30 GMT <DarkStar1> Don't know whether that's standard behaviour or another hooky.

2016-11-21 10:21:19 GMT <DarkStar1> I've benched my testing for now, last thing I want is stress when one has a heavy head with cold :)

2016-11-21 10:22:43 GMT <AFaust> "admin can't access RM Admin Tools" was the symptom I had for having the wrong URL name...

2016-11-21 10:25:07 GMT <AFaust> DarkStar1: Last time I used RM was with an Enterprise customer on 4.2.x a year and a half ago - so it is definitely interesting to see the small issues / differences on full CE mode now (can't remember those issues from back then)

2016-11-21 10:27:54 GMT <DarkStar1> AFaust: Does it just load the page and shows the "You need additional permissions to access this page." toolbar message?

2016-11-21 10:28:36 GMT <AFaust> With the bug, yes it did

2016-11-21 11:00:53 GMT <iwkse> AFaust: did you extend the widget like in this? https://community.alfresco.com/thread/215244-customizing-the-aikau-search-placeholder

2016-11-21 11:00:54 GMT <alfbot> Title: Customizing the aikau search placeholder | Alfresco Community (at community.alfresco.com)

2016-11-21 11:00:59 GMT <iwkse> I tried that way and it didn't work

2016-11-21 11:01:06 GMT <iwkse> I'm curious to know how you did it

2016-11-21 11:01:55 GMT <AFaust> The basic approach is the same, yes - though I am not playing around with i18n bundles

2016-11-21 11:02:10 GMT <iwkse> I see

2016-11-21 11:02:20 GMT <iwkse> I've also sent an example to Dave but still didn't watch it

2016-11-21 11:02:26 GMT <iwkse> that way..it does't work

2016-11-21 11:14:55 GMT <bhagyas> If anyone else is having so much fun with SDK and Unit Tests, ping me.

2016-11-21 11:57:29 GMT <douglascrp> good morning

2016-11-21 11:58:52 GMT <bhagyas> good morning douglascrp

2016-11-21 12:00:26 GMT <Loftux> When you move a node to a new folder, it is not the onCreateNode that gets triggered for the new location. What behaviour to use for that?

2016-11-21 12:01:12 GMT <AFaust> OnMoveNode

2016-11-21 12:01:34 GMT <AFaust> for the node being move

2016-11-21 12:01:45 GMT <AFaust> and onCreateChildAssociation for the target folder

2016-11-21 12:02:08 GMT <Loftux> ok thanks, I'll look into what to use.

2016-11-21 12:02:13 GMT <AFaust> ^^ check for primary = true on the association

2016-11-21 12:02:46 GMT <AFaust> Beware: This may potentially also trigger on renames

2016-11-21 12:02:59 GMT <Hiten> Hi Guys, I am trying to call membership webscript from document-versions.js but I am getting the following error

2016-11-21 12:03:14 GMT <Hiten> Uncaught ReferenceError: remote is not defined

2016-11-21 12:03:32 GMT <Hiten> This is how I am trying to call the webscript

2016-11-21 12:03:41 GMT <Hiten> remote.call("/api/sites/" + page.url.templateArgs.site + "/memberships/" + encodeURIComponent(user.name));

2016-11-21 12:03:43 GMT <AFaust> Alfresco code should update the association name in place but other (3rd party) code may "virtually move" a node to ensure a specific association child name is set

2016-11-21 12:04:01 GMT <AFaust> docuemnt-versions.js is client side code - it cannot use "remote"

2016-11-21 12:04:49 GMT <AFaust> client side YUI code needs to use Alfresco.util.Ajax.* operations for doing remote calls

2016-11-21 12:10:53 GMT <angelborroy> someone using a System76 laptop? I’m planning to replace my MBP...

2016-11-21 12:12:04 GMT <bhagyas> angelborroy: why?

2016-11-21 12:12:21 GMT <angelborroy> it’s 5 years old and I need 32 GB RAM

2016-11-21 12:12:22 GMT <bhagyas> also whats teh config u have right now?

2016-11-21 12:12:54 GMT <angelborroy> I’m using 16 GB RAM and 512 SSD

2016-11-21 12:13:04 GMT <bhagyas> and still not enough O_O

2016-11-21 12:13:11 GMT <angelborroy> not for some projects

2016-11-21 12:13:34 GMT <angelborroy> maybe I can re-think that projects and use intermmediate servers…

2016-11-21 12:13:39 GMT <douglascrp> angelborroy, |o?

2016-11-21 12:13:43 GMT <bhagyas> I spent last Friday learning emacs so I can keep coding on the new Macbook Pro ;)

2016-11-21 12:13:44 GMT <douglascrp> \o/

2016-11-21 12:13:51 GMT <angelborroy> hehe

2016-11-21 12:14:02 GMT <bhagyas> angelborroy: yeah, intermediate servers would actually be a better idea

2016-11-21 12:14:09 GMT <douglascrp> I'm taking mine to be fixed tomorrow

2016-11-21 12:14:22 GMT <bhagyas> douglascrp: I thought yours was already in the repairs

2016-11-21 12:15:27 GMT <angelborroy> bhagyas my screen is broken in some open angles and today my charger has died

2016-11-21 12:15:38 GMT <bhagyas> angelborroy: oh noes :/

2016-11-21 12:15:49 GMT <bhagyas> still 5 years is a pretty good lifetime for any laptop

2016-11-21 12:15:55 GMT <angelborroy> sure

2016-11-21 12:16:00 GMT <douglascrp> bhagyas, nope... I had no time to take it

2016-11-21 12:16:09 GMT <douglascrp> I was traveling abroad

2016-11-21 12:16:18 GMT <angelborroy> but I have no “real” reason to buy a new MBP

2016-11-21 12:16:35 GMT <bhagyas> angelborroy: you can wait until they come with the 32GB model in 2017

2016-11-21 12:16:57 GMT <bhagyas> most people recommend buying the current one and selling it when the new one comes out xD

2016-11-21 12:17:03 GMT <Hiten> @AFaust: I have changed the remote call to ajax call but now I am getting "ReferenceError: page is not defined" error

2016-11-21 12:17:16 GMT <bhagyas> since the value doesn't lose over time much for MBPs

2016-11-21 12:17:23 GMT <AFaust> page is also a server-side only object

2016-11-21 12:17:49 GMT <angelborroy> bhagyas that was my initial idea, but 90 € for a charger… It hurts!

2016-11-21 12:18:08 GMT <bhagyas> yeah

2016-11-21 12:18:18 GMT <AFaust> Hiten: The site can typically be referenced by Alfresco.constants.SITE in YUI code

2016-11-21 12:18:25 GMT <AFaust> (current site of the page)

2016-11-21 12:18:30 GMT <bhagyas> me and Loftux both use maxed out MBAs and connect to LED Cinema Displays

2016-11-21 12:18:41 GMT <bhagyas> so we don't have to use chargers all the time

2016-11-21 12:19:15 GMT <Hiten> OK, where I can get list of constant defined for Alfresco ??

2016-11-21 12:20:10 GMT <bhagyas> The Cinema display can also power the MBA through thunderbolt connector

2016-11-21 12:20:17 GMT <AFaust> Hiten: https://github.com/Alfresco/share/blob/master/share/src/main/resources/alfresco/site-webscripts/org/alfresco/components/head/resources.get.html.ftl#L42

2016-11-21 12:20:18 GMT <alfbot> Title: share/resources.get.html.ftl at master · Alfresco/share · GitHub (at github.com)

2016-11-21 12:25:34 GMT <Hiten> Thanks AFaust

2016-11-21 12:27:32 GMT <iwkse> douglascrp: o/ welcome back home

2016-11-21 12:36:32 GMT <douglascrp> iwkse, tks dude

2016-11-21 12:55:40 GMT <yoyo_> Hi all

2016-11-21 12:56:03 GMT <yoyo_> I'd like to ask you something

2016-11-21 12:56:11 GMT <yoyo_> if someone could help me

2016-11-21 12:56:11 GMT <yoyo_> ..

2016-11-21 12:56:24 GMT <yoyo_> ?

2016-11-21 12:56:47 GMT <yoyo_> I'm facing lot of problems by upgrading alfresco community

2016-11-21 12:56:57 GMT <yoyo_> from 4.2.f to 5.0.0.d

2016-11-21 13:00:08 GMT <angelborroy> yoyo_ which kind of problems?

2016-11-21 13:00:53 GMT <angelborroy> yoyo_ have you checked this https://angelborroy.wordpress.com/2014/12/09/our-way-from-alfresco-4-2-c-to-alfresco-5-0-c/

2016-11-21 13:00:54 GMT <alfbot> Title: Our way from Alfresco 4.2.c to Alfresco 5.0.c | Programming and So (at angelborroy.wordpress.com)

2016-11-21 13:08:30 GMT <Hiten> Hi, I am trying to call membership webscript from document-version.js

2016-11-21 13:08:50 GMT <Hiten> In the ajax call I can see that I am getting json response

2016-11-21 13:09:25 GMT <Hiten> but in the code I am not able to get it and the object is null

2016-11-21 13:09:27 GMT <Hiten> json = JSON.parse(response.serverResponse.responseText);

2016-11-21 13:09:45 GMT <Hiten> here I am getting null value

2016-11-21 13:12:07 GMT <Hiten> http://pastebin.com/xh7rZ9dT

2016-11-21 13:12:08 GMT <alfbot> Title: Ajax call - Pastebin.com (at pastebin.com)

2016-11-21 13:13:00 GMT <DarkStar1> I also tried upgrading a 5.0.d to the last community version on friday and faced some headaches (narrowed down to solr)

2016-11-21 13:13:35 GMT <DarkStar1> but it was around 19H when I started and I couldn't be arsed to look into it then.

2016-11-21 13:18:40 GMT <DarkStar1> I must dash now.

2016-11-21 13:18:49 GMT * DarkStar1 bids you all a good evening

2016-11-21 13:45:21 GMT <AFaust> What was the most current state with (Kerberos) SSO + mobile app support in Alfresco CE 5.1.g / 201605? I remember a lot of people complaining about broken SSO in general. So far we have not seen issues at this customer using Kerberos SSO, but we have not yet had a chance to test with mobile app...

2016-11-21 13:53:17 GMT <yoyo_> I'm sorry

2016-11-21 13:53:28 GMT <yoyo_> I was on a meeting

2016-11-21 13:53:32 GMT <yoyo_> yes, I've checked it

2016-11-21 13:53:49 GMT <yoyo_> but I'm facing problems with Solr

2016-11-21 13:54:11 GMT <yoyo_> previous installation was using Solr

2016-11-21 13:54:37 GMT <yoyo_> and the new one is using Solr4, so I decided to delete all indexes and recreate again

2016-11-21 13:55:01 GMT <yoyo_> (it's a small environment)

2016-11-21 14:02:16 GMT <AFaust> ok - I think I can answer my question myself. Looking at results of a cURL test, the CMIS endpoints are still incorrectly handled by the Kerberos SSO code. Basic authentication is not accepted and Negotiate is required

2016-11-21 14:41:31 GMT <AFaust> Grr - single use has URL encoding issues with Office 2010 SP2 where Office

2016-11-21 14:41:42 GMT <AFaust> does not decode the double-encoded URL

2016-11-21 14:42:11 GMT <AFaust> (still not sure why double-encoding is necessary at all but it is there in default AOS / Alfresco and 99.9% of clients work with AND without it)

2016-11-21 14:47:13 GMT <Loftux> AFaust: Is this the issue you are thinking of? https://issues.alfresco.com/jira/browse/MNT-15500

2016-11-21 15:01:27 GMT <AFaust> Loftux: No - not that one. I had found MNT-14718 when looking for references, but my tests were so low-level that they may not match any of those use-case based descriptions

2016-11-21 15:03:24 GMT <AFaust> ...and MNT-15819

2016-11-21 15:10:29 GMT <bhagyas> fcorti: Can we get official support for https://github.com/laurentvdl/dynamic-extensions-for-alfresco

2016-11-21 15:10:30 GMT <alfbot> Title: GitHub - laurentvdl/dynamic-extensions-for-alfresco: Rapid development of Alfresco repository extensions in Java. Deploy your code in seconds, not minutes. Life is too short for endless server restarts. (at github.com)

2016-11-21 15:14:43 GMT <AFaust> bhagyas: Do you want that included in core or what is "official support" with regards to the addon?

2016-11-21 15:17:24 GMT <bhagyas> AFaust: I think it should make its way into the core

2016-11-21 15:17:25 GMT <bhagyas> :)_

2016-11-21 15:17:39 GMT <AFaust> Hopefully not...

2016-11-21 15:17:48 GMT <bhagyas> regardless of your hate towards annotations :p

2016-11-21 15:19:21 GMT <AFaust> I repeat, is is only partially because of annotations. Lack of extensibility / adaptability is more critical. I thought someone who is complaining as much as I am about inextensible Alfresco core code could understand the distinction...

2016-11-21 15:19:52 GMT <bhagyas> AFaust: As much as I'm for extensibility and openness, I am in for reuse

2016-11-21 15:19:58 GMT <bhagyas> and simplification whenever possible

2016-11-21 15:20:41 GMT <AFaust> Let me remind you of that statement when someday you complain about an extension using that dynamic extension framework that cannot be extended / adapted...

2016-11-21 15:21:32 GMT <bhagyas> It's already on Github and can be forked ;)

2016-11-21 15:21:52 GMT <bhagyas> but yes, surely remind if I do complain

2016-11-21 15:21:56 GMT <bhagyas> :)

2016-11-21 15:21:58 GMT <AFaust> As long as there is an opt-out for people that absolutely do not want to use that, I am apathetic to the issue of including it in core.

2016-11-21 15:22:32 GMT <AFaust> It is the same way I approach my addons / extensions (i.e. Nashorn) - they must be opt-out-able

2016-11-21 15:23:04 GMT <AFaust> Even sub-sets of the features they provide

2016-11-21 15:24:01 GMT <bhagyas> I wish there was an opt out for something that begins with A

2016-11-21 15:24:20 GMT <AFaust> at least you said "something" not "someone", so thank you...

2016-11-21 15:25:22 GMT <bhagyas> ;)

2016-11-21 15:27:34 GMT <AFaust> And "A*" is too ambigious in this channel since half a dozen things (and more) we work with start with an A

2016-11-21 15:31:23 GMT <bhagyas> and A is definitely not Alfresco

2016-11-21 15:32:21 GMT <AFaust> for me the A-list begins with "Apache Commons Logging (inside of Alfresco)"

2016-11-21 15:32:53 GMT <AFaust> Hate it even more than bytecode-based wiring with annotations. And you know what that means...

2016-11-21 15:35:16 GMT <bhagyas> ¯\_(ツ)_/¯

2016-11-21 16:02:45 GMT <AFaust> Looks like that Office 2010 / URL encoding issue the one user had might be specific to using AOS from Edge in his case. In Chrome it works fine. Does anyone know if there are some specific registry / general settings that might affect the ms-word/ms-excel/ms-powerpoint URI schemes and how they are passed from browser to Office?

2016-11-21 16:03:04 GMT <AFaust> Microsoft documentation is useless - as always

2016-11-21 17:52:13 GMT <fcorti> bhagyas: you are not the first asking me this

2016-11-21 22:03:30 GMT <qwebirc84351> Hey guys, i am having a problem with alfresco java heap space. This happens every week, at the same time, in different days. I don't know why. Someone can help?

2016-11-21 22:26:06 GMT <nachopants> hi guys

2016-11-21 22:26:24 GMT <nachopants> we are having some major performance issues with Alfresco at the moment

2016-11-21 22:26:37 GMT <nachopants> Alfresco Prod - /apiServlet 2 46,100 ms

2016-11-21 22:26:44 GMT <nachopants> . /share/page/dologin

2016-11-21 22:26:46 GMT <nachopants> .....

2016-11-21 22:26:49 GMT <nachopants> nearly a full minute to login

2016-11-21 22:27:05 GMT <nachopants> yet the CPU on the box is < 55

2016-11-21 22:27:08 GMT <nachopants> yet the CPU on the box is < 5%

2016-11-21 22:27:20 GMT <nachopants> can anyone shed any light on /apiServlet and what might be causing that issue?

2016-11-21 22:28:19 GMT <AFaust> apiServlet is very generic and broadly used

2016-11-21 22:28:35 GMT <AFaust> also, it would be a good idea to provide configuration details about your authentication chain

2016-11-21 22:28:46 GMT <AFaust> before starting to guess on potential issues

2016-11-21 22:30:14 GMT <AFaust> i.e. it is very easy to achieve a login that takes almost a minute by configuring LDAP authentication as the first member of the chain when LDAP server is unreachable for some reason

2016-11-21 23:02:46 GMT <nachopants> right I see thank you

2016-11-21 23:02:54 GMT <nachopants> # This authentication chain is set up to use first 'native' user pool, then second ldap user pool.

2016-11-21 23:02:55 GMT <nachopants> #-------------

2016-11-21 23:02:55 GMT <nachopants> ldap.authentication.active=true

2016-11-21 23:02:55 GMT <nachopants> authentication.chain=ldap1:ldap,alfrescoNtlm1:alfrescoNtlm

2016-11-21 23:03:25 GMT <nachopants> I'm also just wondering whether it's a DB issue

2016-11-21 23:03:31 GMT <nachopants> (as things after login are quite slow too)

2016-11-21 23:03:42 GMT <nachopants> I'm looking in AWS RDS and it seems to only ever use 32 connections

2016-11-21 23:03:47 GMT <nachopants> db.url=jdbc:mysql://mysmsf-production.clflngtqxvlg.ap-southeast-2.rds.amazonaws.com/alfresco5a

2016-11-21 23:03:48 GMT <nachopants> db.pool.max=500

2016-11-21 23:03:49 GMT <nachopants> db.pool.initial=32

2016-11-21 23:03:49 GMT <nachopants> db.pool.idle=32

2016-11-21 23:03:51 GMT <nachopants> db.pool.min=32

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco