Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2016-12-19 07:34:26 GMT <twen> 'morning

2016-12-19 07:34:45 GMT <DarkStar1> Morning all

2016-12-19 07:39:34 GMT * twen waves at DarkStar1

2016-12-19 07:39:51 GMT <DarkStar1> twen: Comment va tu?

2016-12-19 07:40:35 GMT <DarkStar1> Can anyone tell me the format of alfresco no-auth endpoint url? I want to expose an unauthenticated webscript

2016-12-19 07:40:37 GMT <DarkStar1> ?

2016-12-19 07:40:42 GMT <twen> DarkStar1 Ca va as as someone looking for a job :p

2016-12-19 08:06:01 GMT <yreg> ~later tell ___Dave the newest Star Wars film, I guess !

2016-12-19 08:06:01 GMT <alfbot> yreg: The operation succeeded.

2016-12-19 08:06:14 GMT <yreg> Good morning every one !

2016-12-19 08:06:38 GMT <yreg> fcorti, I am still havin issues with AAAR 4.5

2016-12-19 08:06:49 GMT <fcorti> good morning yreg

2016-12-19 08:07:16 GMT <fcorti> what, in particular?

2016-12-19 08:07:20 GMT <yreg> now it seems to be installed but when I try to extract data from alfresco

2016-12-19 08:07:32 GMT <fcorti> what the log says?

2016-12-19 08:07:37 GMT <fcorti> catalina.out I mean

2016-12-19 08:07:39 GMT <yreg> it says that it is unable to connect to repository

2016-12-19 08:08:14 GMT <fcorti> please share the stack trace

2016-12-19 08:08:50 GMT <yreg> I will do that during lunch break

2016-12-19 08:18:59 GMT <AFaust> fcorti: For whatever reason Andreas was very vague in his tweet. He is referring to comments on https://community.alfresco.com/docs/DOC-6238-aikau-framework

2016-12-19 08:19:02 GMT <alfbot> Title: Aikau Framework | Alfresco Community (at community.alfresco.com)

2016-12-19 08:19:27 GMT <fcorti> AFaust I say: too vague :-)

2016-12-19 08:19:40 GMT <fcorti> Thank you for the better explanation

2016-12-19 08:20:03 GMT <AFaust> Yeah - some people appear to be more about passive aggressive communication than direct one

2016-12-19 08:21:51 GMT <fcorti> AFaust ehm... I asked him in skype... but no answer. ;-)

2016-12-19 08:23:31 GMT <AFaust> He opened a PR on ootbee-support-tools project the other day to add a patch for an ACE JIRA ticket, and closed it without further comment after I wondered about the relevance / relation to one of the tools the project provides.

2016-12-19 08:24:10 GMT <AFaust> I still don't understand why he wanted that PR to be included in the project or if it was just a mistake and he meant to create an issue in a different project

2016-12-19 08:25:29 GMT <fcorti> Ok, some pain is around...

2016-12-19 08:26:30 GMT <fcorti> I'll try to contact him again to hear and we will define some ations

2016-12-19 08:26:32 GMT <fcorti> actions

2016-12-19 08:35:22 GMT <IanW1> DarkStar1 I believe what happens is that a filter sets the NO_AUTH_REQUIRED request attribute i.e. no difference in the endpoint between auth/noauth webscripts

2016-12-19 08:35:44 GMT <DarkStar1> I need to provide unauthenticated access to a non alfresco app to an unauthenticated webscript.

2016-12-19 08:36:48 GMT <DarkStar1> IanW1: aah so there's a header attribute to be set then. Thanks

2016-12-19 08:36:57 GMT <DarkStar1> I'll test that now

2016-12-19 08:40:10 GMT <IanW1> No header to set - the filter sets the attribute according to the webscript authentication method

2016-12-19 08:46:46 GMT <DarkStar1> IanW1: Ok I think I haven't been clear. I can access the webscript through share just fine using the un-authenticated endpoint. What I'd like to do is allow the 3rd party app to access the same webscript without authentication

2016-12-19 08:48:01 GMT <DarkStar1> so I was just wondering if that had a URL attribute/format (like replacing service with wcservice for webclient auth) etc that needed to be changed

2016-12-19 09:13:37 GMT <alfbot> ___Dave: Sent 1 hour and 7 minutes ago: <yreg> the newest Star Wars film, I guess !

2016-12-19 09:18:23 GMT <AFaust> To be correct, the first of a couple of "a Star Wars story" films

2016-12-19 09:29:26 GMT <___Dave> no... that's not right, there are only 3 Star Wars films

2016-12-19 09:29:29 GMT <___Dave> THREE

2016-12-19 09:29:38 GMT <___Dave> all made in the 80s

2016-12-19 09:29:44 GMT <___Dave> except for the first one

2016-12-19 09:29:48 GMT <___Dave> bugger

2016-12-19 09:29:51 GMT <___Dave> no delete on IRC

2016-12-19 09:32:05 GMT <AFaust> Hehe

2016-12-19 09:32:21 GMT <AFaust> So, what about the Star Wars Holiday Special then

2016-12-19 09:32:24 GMT * AFaust ducks into cover

2016-12-19 09:32:44 GMT <___Dave> In my revisionist version of history I deny the existence of that too

2016-12-19 09:33:43 GMT <AFaust> and the Ewok movie(s)?

2016-12-19 09:34:05 GMT <___Dave> they never happened

2016-12-19 09:34:09 GMT <AFaust> strange that those seldom get mentioned in the media...

2016-12-19 09:34:27 GMT <___Dave> look, basically there were 3 awesome movies made that shaped my childhood... end of discussion

2016-12-19 09:36:23 GMT <AFaust> Lucky you who had a chance to have the childhood shaped by those. I had to wait until my preteens for that. Damn you, Iron Curtain

2016-12-19 09:37:42 GMT <AFaust> Maybe that is why I wasn't that indoctrinated by it to be too upset about the Special Edition, and then those other movies that may or may not have been made around the turn of the century...

2016-12-19 09:39:39 GMT <Hiten> Hi Guys, I would like to know one thing. My alfresco installations will have two repo amps and unfortunately both of them are going to have same behavior(OnVersionCreatePolicy) attached to node

2016-12-19 09:40:01 GMT <Hiten> is this going to affect the working in any way ??

2016-12-19 09:41:38 GMT <Tichodroma> two repo AMPS?

2016-12-19 09:41:59 GMT <yreg> ___Dave, Since you are already here, do you have any idea why this some-share-amp\src\main\amp\web\components\search\search.css does not override .m2\repository\org\alfresco\share\5.1.1\share-5.1.1.war!\components\search\search.css

2016-12-19 09:42:55 GMT <Hiten> Yes, two repo amps from different projects

2016-12-19 09:43:10 GMT <Tichodroma> in the same Tomcat?

2016-12-19 09:43:15 GMT <Tichodroma> forget it

2016-12-19 09:43:46 GMT <___Dave> yreg: erm... no, I'm not sure, but I don't really do a lot of Share stuff with the SDK

2016-12-19 09:43:59 GMT <Tichodroma> You can of course define more than on policy on the same behaviour

2016-12-19 09:44:12 GMT <yreg> ___Dave, not even for testing the SDK ?

2016-12-19 09:44:23 GMT <___Dave> I do almost nothing with the SDK

2016-12-19 09:44:35 GMT <___Dave> the only time I use it is when I need to do some Repository stuff

2016-12-19 09:46:02 GMT <AFaust> yreg: Have you checked the file mapping?

2016-12-19 09:46:46 GMT <yreg> AFaust, will do that right away

2016-12-19 09:47:13 GMT <AFaust> I typically have no problems with such overrides, but then again I do not use the SDK most of the time...

2016-12-19 09:48:31 GMT <AFaust> And - apart from extreme cases - I typically do not put these kinds of overrides in AMP projects. In my definition, AMPs are almost never allowed to override default files - that is reserved for WAR projects.

2016-12-19 09:49:39 GMT <yreg> AFaust, I have include.default=true and /web=/ which sounds right

2016-12-19 09:49:52 GMT <AFaust> yes it does...

2016-12-19 09:51:13 GMT <AFaust> Ah fu** - does anyone know how to circumvent the Rhino special handling for Maps to access a field of the Map instead of a value mapping?

2016-12-19 09:54:04 GMT <yreg> AFaust, Whenever I face such a limitation in alfresco JS-API I usually write a js-extension to do the thing in java... well if it could be generalized to cover more usage-cases I usually do that too

2016-12-19 09:55:17 GMT <yreg> instead of going rogue with complex customizations that would probably break in future upgrades

2016-12-19 09:55:45 GMT <AFaust> The limitation is not in the Script API (remember, JS API is used to refer to that other API), but of the Rhino engine - I try to keep these two separate in conversation so it is clear what/who I blame

2016-12-19 09:55:53 GMT <yreg> AFaust, I think my issue with the SDK is related to virtual classpath

2016-12-19 09:56:14 GMT <AFaust> ah - you are running the AMP via the SDK. You should have mentioned that

2016-12-19 09:57:05 GMT <yreg> I did not suspect that until I peeked at the test server with a former version of the amp deployed

2016-12-19 09:58:15 GMT <yreg> AFaust, do you remember my problem with user listing/search in share admin console from Friday ?

2016-12-19 09:59:00 GMT <AFaust> yep

2016-12-19 10:00:09 GMT <yreg> It turned out to be an issue with replace="true" for a config on search that does not have that entry for max-users-search-results

2016-12-19 10:00:46 GMT <AFaust> replace="true" is such a nasty thing

2016-12-19 10:00:53 GMT <yreg> that config appear to be added somewhere after 4.2.4 and that's why it didn't exist in that section and share was doing fine without it

2016-12-19 10:01:00 GMT <yreg> agreed

2016-12-19 10:01:46 GMT <AFaust> It is only a cludge because Surf configuration model is not too smart about merging multiple sections for the same condition...

2016-12-19 10:02:03 GMT <yreg> I would've liked 3 criteria replace strategy, one to add config not replace anything, one for replacing and one other for merge

2016-12-19 10:21:15 GMT <yreg> ~later tell ohej I think most of the sdk materials in docs are outdated and require some polishing, ping me when you are around

2016-12-19 10:21:15 GMT <alfbot> yreg: The operation succeeded.

2016-12-19 10:29:48 GMT <yreg> ~seen binduwavell

2016-12-19 10:29:48 GMT <alfbot> yreg: binduwavell was last seen in #alfresco 6 weeks, 1 day, 15 hours, 9 minutes, and 42 seconds ago: <binduwavell> Anyone know if Jens Goldhammer is around? Or possibly contact info for him on Skype?

2016-12-19 10:38:21 GMT <AFaust> yreg: There is no difference between adding, replacing and merging really.

2016-12-19 10:39:11 GMT <AFaust> If the key / element path has not been used before, it is adding. If it has it is replacing. Both combined are "merging". The only thing missing would be "removing"

2016-12-19 10:41:51 GMT <yreg> that vitual classpath thing turned out to be a dead end

2016-12-19 10:57:47 GMT <AFaust> WTF - Hazelcast map (cache) statistics are inconsistent af

2016-12-19 10:58:11 GMT <AFaust> Number of Gets: 4 - then how come the counter for Hits is at 7?

2016-12-19 11:00:42 GMT <AFaust> Great - and the number of Hits only reflect the "locally owned records", so if some record was loaded from a remote cluster node it wouldn't show as a hit...

2016-12-19 11:01:06 GMT <yreg> looks like a real mess

2016-12-19 11:02:45 GMT <AFaust> Wonder what the commercial version looks like...

2016-12-19 11:02:54 GMT <AFaust> Maybe that is one of its USPs

2016-12-19 11:03:02 GMT <AFaust> "correct statistics"

2016-12-19 11:03:40 GMT <yreg> fcorti, I noticed that the docs do now keep track of older CE versions, which is really nice

2016-12-19 11:05:03 GMT <AFaust> Hmm - one reason for the different Gets vs Hits count is that Gets are tracked on a different layer than Hits (proxy vs real instance) and thus there could be internal operations that increase Hits without update to Gets

2016-12-19 11:05:10 GMT <yreg> but only previous versions do have the version tag in the url ie:"community5.0" where the the docs for the current version under development is always "community"

2016-12-19 11:05:49 GMT <fcorti> yreg nice, let me ask to the docs team about it...

2016-12-19 11:06:30 GMT <yreg> it would be better to use tags for the current version as well, so that when someone references a piece of doc for the current version, it would always be available for reference

2016-12-19 11:06:52 GMT <fcorti> probably two tags: community and the version in separate tag

2016-12-19 11:06:56 GMT <fcorti> what do you think?

2016-12-19 11:06:57 GMT <yreg> even if the page got moved/removed in newer versions

2016-12-19 11:07:16 GMT <fcorti> the page are copied for the various versions

2016-12-19 11:07:56 GMT <yreg> Yes I am aware of that

2016-12-19 11:09:52 GMT <yreg> What I am suggesting is that You (alfresco) copy the **current version of docs under a new name not for archiving an old version of the docs but for setting a base for a new version of the docs

2016-12-19 11:10:49 GMT <fcorti> They should already do this

2016-12-19 11:10:56 GMT <yreg> and always opt for community<version> for the root context for each version

2016-12-19 11:10:59 GMT <fcorti> (if I understand correclty what you mean)

2016-12-19 11:11:27 GMT <yreg> fcorti they do it for old versions, not for current versions

2016-12-19 11:12:33 GMT <yreg> which results often in broken links when someone try to reference a page from the docs in community forums/stack overflow/ internal wiki/documentation

2016-12-19 11:12:51 GMT <fcorti> ok, now I understand... it's the url that you are talking about

2016-12-19 11:14:36 GMT <yreg> fcorti, exactly !

2016-12-19 11:17:50 GMT <yreg> If I reference this page http://docs.alfresco.com/community/concepts/solr-home.html in a reply for a question on how to configure solr for CE5.2, and in a couple of month alfresco starts working on CE5.3 or 6.0 which defaults to solr 6+ and the content of the page moves to http://docs.alfresco.com/community5.2/concepts/solr-home.html and changes for the current version, any one reading the old response can be easily mis-lead/confused

2016-12-19 11:17:52 GMT <alfbot> Title: Configuring search | Alfresco Documentation (at docs.alfresco.com)

2016-12-19 11:19:04 GMT <yreg> fcorti, this is a concern that I would like to have you pass it on to the docs team :)

2016-12-19 11:21:25 GMT <fcorti> yreg: ok, I wrote to the DOCS Team about it sharing the suggestion. Thank you for submitting it to my/our attention. :-)

2016-12-19 11:22:02 GMT <fcorti> let's have a recap on this in the new year...

2016-12-19 14:14:14 GMT <yreg> any one familiar with Alfresco deployments to Windows environments ?

2016-12-19 14:15:20 GMT <yreg> I am trying to upgrade an alfresco instance from 4.2.4 to 5.1.1 on a test server

2016-12-19 14:15:40 GMT <yreg> and I keep getting this : ContentIOException: 11190000 Failed to create store root: E:\Alfresco\alf_data\contentstore.deleted

2016-12-19 14:15:57 GMT <yreg> even after I created that folder manually

2016-12-19 14:16:28 GMT <yreg> I checked the permissions on that folder, and it seems that everyone has read/write permission on it

2016-12-19 14:17:03 GMT <yreg> and I am running my alfresco as a service (using the services from the OOTB installer)

2016-12-19 14:19:20 GMT <AFaust> yreg: Well - you know I locally run Windows... And I have had a couple of Windows-based customers

2016-12-19 14:19:57 GMT <AFaust> But then again, I NEVER, EVER, EVER use the out-of-the-box installer for anything that matters...

2016-12-19 14:21:05 GMT <AFaust> How did you configure the dir.root property?

2016-12-19 14:21:13 GMT <AFaust> With backslashes or regular slashes?

2016-12-19 14:21:33 GMT <AFaust> ^^ never use backslashes in Java path configurations...

2016-12-19 14:22:23 GMT <AFaust> especially in files where a backslash can have special function, e.g. escaping...

2016-12-19 14:22:52 GMT <yreg> AFaust, here is my dir.root

2016-12-19 14:22:52 GMT <yreg> : dir.root=E:/Alfresco/alf_data

2016-12-19 14:24:09 GMT <yreg> will give E:\\Alfresco\\alf_data a try and keep you posted

2016-12-19 14:25:08 GMT <yreg> AFaust, I thought that by using the ootb installer, I will be faster...

2016-12-19 14:26:46 GMT <AFaust> Well faster - but you end up with a system I'd never recommend as a reference for production. And test instances should always be setup identical to how production will eventually be set up

2016-12-19 14:27:17 GMT <AFaust> And your path is actually correct that way.

2016-12-19 14:27:17 GMT <yreg> well I will have acceptance for that

2016-12-19 14:27:28 GMT <AFaust> Remember what I said: "never use backslashes"

2016-12-19 14:27:32 GMT <yreg> in test we do not even setup clustering

2016-12-19 14:29:32 GMT <AFaust> So you leave yourselves vulnerable to any clustering issues that you will catch only when the customer is doing his final tests?

2016-12-19 14:29:55 GMT <AFaust> Or is that acceptance "before" the customer will see it?

2016-12-19 14:31:04 GMT <qwebirc97456> Hello, where can I find the definition of Alfresco.constants.PROXY_URI in the documentation? Using Alfresco 5.0.

2016-12-19 14:32:38 GMT <AFaust> qwebirc97456: I assume nowhere in particular. At least Google does not seem to have any page indexed in docs.alfresco.com that contains "PROXY_URI"

2016-12-19 14:33:35 GMT <AFaust> Correction - one page: http://docs.alfresco.com/community/tasks/dev-extensions-share-tutorials-add-action-doclib.html

2016-12-19 14:33:36 GMT <alfbot> Title: Adding new actions to the Document Library | Alfresco Documentation (at docs.alfresco.com)

2016-12-19 14:34:02 GMT <yreg> AFaust, Well we work with the customer on both environments

2016-12-19 14:34:07 GMT <AFaust> But here it is only referenced in a snippet

2016-12-19 14:34:56 GMT <yreg> but we only pass acceptance to be tested after we go through our checklist ..

2016-12-19 14:35:58 GMT <qwebirc97456> AFaust: yes, Google was also my friend before I raised the question in this chat. At least I'm looking for a constant to have the Share's host available like http://localhost:8081/share/page

2016-12-19 14:38:15 GMT <yreg> You want that in Client-side / Server-side js ?

2016-12-19 14:40:49 GMT <AFaust> Also - there is never anything like going straight to the source to find other constants: https://github.com/Alfresco/share/blob/master/share/src/main/resources/alfresco/site-webscripts/org/alfresco/components/head/resources.get.html.ftl#L56

2016-12-19 14:40:52 GMT <alfbot> Title: share/resources.get.html.ftl at master · Alfresco/share · GitHub (at github.com)

2016-12-19 14:41:14 GMT <AFaust> (in case you want it in client-side JS)

2016-12-19 14:41:50 GMT <AFaust> yreg: Though I don't understand in what circumstances you'd want that on the server-side...

2016-12-19 14:43:00 GMT <qwebirc97456> yes, client-side thanks.

2016-12-19 14:43:23 GMT <yreg> AFaust, generating links for emails for example ?

2016-12-19 14:43:50 GMT <AFaust> not really

2016-12-19 14:44:35 GMT <AFaust> you only need the host, port, context and protocol for that from sysAdminParams - everything else will typically be hard-coded in the template

2016-12-19 14:45:11 GMT <AFaust> there is just too much that you'd need to provide per model / configuration if you really wanted everything to be consistently dynamic

2016-12-19 14:45:48 GMT <AFaust> you'd never see the end...

2016-12-19 14:46:45 GMT * AFaust wonders why he always has to do things in a way that leads him to discover bugs / limitations. For once, do things the 08/15 way, god damnit...

2016-12-19 14:47:16 GMT <yreg> AFaust, I thought he was looking for an other constant, the one for share base url

2016-12-19 14:48:03 GMT <AFaust> If you have a base aspect with a property and an aspect that inherits from that (via <parent>), and both are applied on a node. If you remove the child aspect the nodeService removes all the properties of it, even those inherited from the base aspect. So while the baseAspect is still applied, all its properties are gone...

2016-12-19 14:50:23 GMT <AFaust> yreg: I have decided to not try and think about what someone could mean instead / in addition if the question is reasonably precise. You might have been right if this was one of those low-brow community.alfresco.com-type of questions...

2016-12-19 15:01:35 GMT <yreg> AFaust, Guess what, a it was a dump Windows Permission error

2016-12-19 15:01:54 GMT <AFaust> I thought you checked?

2016-12-19 15:02:01 GMT <yreg> I made a dummy class to test it out, and when I run it as my user it works

2016-12-19 15:02:12 GMT <yreg> but when I run it with SYSTEM it does not

2016-12-19 15:02:22 GMT <AFaust> So your shot yourself in the foot with that test...

2016-12-19 15:02:47 GMT <yreg> it is probably an issue with network shares since the local folder, while having the same set of permissions work just fine

2016-12-19 15:02:49 GMT <AFaust> At least initially...

2016-12-19 15:03:33 GMT <AFaust> Well - the network share is not aware of any local accounts and I bet SYSTEM is just one

2016-12-19 15:04:10 GMT <AFaust> So even though the permissions look alike, there is actually a difference between "Everyone" and "Everyone" on local vs. remote storage medium

2016-12-19 15:04:45 GMT <yreg> AFaust, that's most probably the case

2016-12-19 15:05:45 GMT <AFaust> The customer I had with Windows systems always use a full AD service account for Alfresco, not a local one. So that it could also be explicitly privileged on storage devices without having to use "Everyone"

2016-12-19 15:09:31 GMT <yreg> AFaust, On the old test server it was working with the local system user

2016-12-19 15:10:40 GMT <yreg> Sh** I was wrong, it still does not work even after I've setup the service with my own AD account

2016-12-19 15:55:17 GMT <yreg> Even when I tried to use some account from AD I couldn't get tomcat to discover the folder, but as soon as I referenced that shared location directly (not the drive mount) worked

2016-12-19 15:55:47 GMT <yreg> AFaust, it looks like I will be using backslashed massively after all :P \\\\netapp1\\Talfresco5$\\Alfresco\\alf_data

2016-12-19 15:57:21 GMT <AFaust> yreg: How is the device mounted? In the user context or on system level?

2016-12-19 15:57:36 GMT <AFaust> Also even in this case you should not need to use backslashes...

2016-12-19 15:58:29 GMT <AFaust> I have a custom using a Snaplock storage device using a UNC path and it works perfectly with slash-based paths

2016-12-19 16:13:13 GMT <yreg> nice catch AFaust, I will probably need to mount that folder as system

2016-12-19 16:14:36 GMT <yreg> Just when I thought things can not go wierder with this project I get this output -_- http://pastebin.com/ZaFvRX7q

2016-12-19 16:14:37 GMT <alfbot> Title: 2016-12-19 16:40:43,678 INFO [repo.admin.ConfigurationChecker] [localhost-star - Pastebin.com (at pastebin.com)

2016-12-19 16:18:43 GMT <AFaust> What is so weird about that?

2016-12-19 16:22:31 GMT <yreg> 130.000+ enteries

2016-12-19 16:23:36 GMT <yreg> the fact that only 10895 have been processed before I got the Completed batch of 130740 entries

2016-12-19 16:24:02 GMT <yreg> and being stuck there for 20 minutes now, without any further sign of life

2016-12-19 16:28:52 GMT <AFaust> Keep in mind that batch processor tasks may "guess" / "estimate" the amount of work to be done, while the actual scope is very different

2016-12-19 16:29:26 GMT <AFaust> This looks like such a case

2016-12-19 16:31:06 GMT <AFaust> And if I look at the effort estimation in that patch it really is just a case of "well, I don't want to do too much work to estimate, so just use the highest node ID we can find"

2016-12-19 16:31:42 GMT <AFaust> 130740 is just that node ID and not really a count of elements to process.

2016-12-19 16:32:22 GMT <AFaust> The alternative estimate is also quite dumb - "take the number of sites and multiply by 12"

2016-12-19 16:32:32 GMT <yreg> Not sure if 130740 is the highest node ID

2016-12-19 16:32:47 GMT <yreg> as the system is guaranteed to have 15.000+ share sites

2016-12-19 16:32:57 GMT <AFaust> yeah - then it is the second estimate

2016-12-19 16:33:40 GMT <AFaust> divided by 12 that number ends up being 10895 - which is actually the total processed count

2016-12-19 16:35:49 GMT <AFaust> Regarding the "being stuck now" => That is what jstack or jvisualvm is for...

2016-12-19 16:36:12 GMT <AFaust> To check what is going on

2016-12-19 16:42:20 GMT <yreg> well it seems that the IO bandwith for that shared folder is around 1-2 Mbps

2016-12-19 16:42:40 GMT <yreg> is behind that super slow processing

2016-12-19 16:53:08 GMT <AFaust> 1-2 Mbps - yeah baby, way to drive up the cost by allowing more hours to be billed

2016-12-19 16:53:38 GMT <AFaust> is it really the bandwith though or a matter of latency?

2016-12-19 16:53:49 GMT <AFaust> or just too many small files

2016-12-19 16:57:32 GMT <AFaust> WTF?

2016-12-19 16:57:57 GMT <AFaust> Why does the Model Manager only provide a simple select with a limited amount of options to select the "Parent Aspect"?

2016-12-19 16:59:16 GMT <AFaust> Or is it just the case that almost all of the default models as well as my current ones aren't being consulted for any potential parent aspects?

2016-12-19 17:28:35 GMT <iwkse> do you know if the file list for 201612 GA has been released? I'm not able to find it

2016-12-19 17:36:09 GMT <fcorti> do you mean this?

2016-12-19 17:36:10 GMT <fcorti> https://community.alfresco.com/docs/DOC-6552-alfresco-community-edition-file-list-201612

2016-12-19 17:36:12 GMT <alfbot> Title: Alfresco Community Edition file list 201612 | Alfresco Community (at community.alfresco.com)

2016-12-19 17:36:46 GMT <iwkse> fcorti: awesome :) where did you find??

2016-12-19 17:36:52 GMT <iwkse> I was searching a lot but nothing

2016-12-19 17:36:55 GMT <iwkse> maybe I can't search

2016-12-19 17:37:26 GMT <fcorti> googling :-)

2016-12-19 17:37:29 GMT <fcorti> https://www.google.it/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=alfresco+201612+GA+file+list

2016-12-19 17:37:30 GMT <alfbot> Title: Google (at www.google.it)

2016-12-19 17:37:41 GMT <iwkse> ^_^

2016-12-19 17:37:45 GMT <fcorti> ;-)

2016-12-19 17:37:56 GMT <iwkse> thank you :)

2016-12-19 17:38:12 GMT <fcorti> you are welcome

2016-12-19 19:25:33 GMT <jpotts> I could swear that in the past, if I wanted to run an action from JavaScript that had nothing to do with a document or a folder, I could pass in null to the execute method

2016-12-19 19:26:07 GMT <jpotts> Now, JavaScript gets upset because the execute method signature is ambiguous.

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco