Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2016-12-21 08:26:34 GMT <qwebirc82712> Sir, good morning.I look to get hostname and port in rule script. window.location.host is not working?

2016-12-21 08:40:56 GMT <AFaust> qwebirc82712: A rule scriot is executed on the server. There is no such thing as a window object on the server - this would be browser-only

2016-12-21 08:42:45 GMT <AFaust> For web scripts there would be an "url" root object that can be used for some information about the current call (like server name used in the call), but a rule script does not have that either.

2016-12-21 08:46:20 GMT <AFaust> The information is there via the SysAdminParams interface but I see no way how to access that via a user-provided rule action script.

2016-12-21 08:50:50 GMT <qwebirc82712> AFaust: thank you. than i have to solve the requirement otherwise

2016-12-21 08:51:26 GMT <AFaust> Question would be what that requirement is / why you need the hostname in a rule script...

2016-12-21 08:55:18 GMT <qwebirc82712> need to store servername for later requirement where rule was executed because share is installed in cluster 4 times on different servers

2016-12-21 08:55:58 GMT <qwebirc82712> need to know where the user has executed rule

2016-12-21 09:01:48 GMT <yreg> Morning

2016-12-21 09:29:40 GMT <AxelFaust> qwebirc82712: You know that the rule is executed on the Repository-side, right? It does not matter where Share is installed in that case...

2016-12-21 09:30:04 GMT <AxelFaust> You will also not be able to find out which Share install the user was making the request from.

2016-12-21 09:30:43 GMT <AxelFaust> The only way you could make such a connection would be if every Share instance has a dedicated Repository instance assigned

2016-12-21 09:32:06 GMT *** marsv024_ is now known as marsv024

2016-12-21 09:38:36 GMT <DarkStar1> Seasons greeting compadres.

2016-12-21 12:57:46 GMT <douglascrp> hello guys

2016-12-21 12:57:54 GMT <douglascrp> anyone here from USA?

2016-12-21 12:58:00 GMT <douglascrp> or working there at least?

2016-12-21 13:20:56 GMT * DarkStar1 greets douglascrp I think it's just you and I today. How may I be of service? :)

2016-12-21 13:27:30 GMT <Loftux> Filed an issue with the Hibernate connection problems I'm seeing with 201612 GA https://issues.alfresco.com/jira/browse/ALF-21811.

2016-12-21 13:29:40 GMT <douglascrp> Loftux, so, not really a GA, right?

2016-12-21 13:29:46 GMT <qwebirc71954> hello , anybody know the addon esign-cert / autofirma for sign pdf ?

2016-12-21 13:31:10 GMT <douglascrp> qwebirc71954, angelborroy is the addon's father

2016-12-21 13:31:23 GMT <douglascrp> and he is out

2016-12-21 13:31:24 GMT <douglascrp> :D

2016-12-21 13:31:33 GMT <douglascrp> qwebirc71954, I know it... what's the matter?

2016-12-21 13:35:09 GMT <Loftux> douglascrp: Seems like a serious error that slipped through. I'm at loss on how to track it down, something not closing/releasing connection properly, but the error happens later in unrelated transactions that try to re-use these connections.

2016-12-21 13:35:51 GMT <qwebirc71954> douglascrp: i have install ver 1.3.1 and the client 1.4.3, but when i want to sign pdf , it just open the logo and nothing append , i have no error in log alfresco , no error in catalina , and in jave consol juste this warning :WARNING: Error en la validacion de los certificados contra el almacen de Java: java.io.EOFException

2016-12-21 13:36:01 GMT <douglascrp> Loftux, that's serious

2016-12-21 13:36:26 GMT <douglascrp> qwebirc71954, that has nothing to do with the addon itself

2016-12-21 13:36:51 GMT <douglascrp> you have to make sure the autofirm works in standalone mode first

2016-12-21 13:37:03 GMT <douglascrp> can you execute it using the shortcut created during the install?

2016-12-21 13:37:07 GMT <qwebirc71954> douglascrp: it works no matters

2016-12-21 13:37:08 GMT <douglascrp> can you sign a pdf using it?

2016-12-21 13:37:13 GMT <qwebirc71954> douglascrp: yes

2016-12-21 13:39:46 GMT <douglascrp> qwebirc71954, I had that problem before

2016-12-21 13:40:21 GMT <douglascrp> when you open it with the shortcut for the first time, it asks you a question about accepting or not any certificate

2016-12-21 13:40:29 GMT <douglascrp> I'm not sure about the text now

2016-12-21 13:40:33 GMT <douglascrp> but you have to accept that

2016-12-21 13:40:49 GMT <yreg> Loftux, does it happens in GA-to-GA upgrade ? or just EA-to-GA ?

2016-12-21 13:43:23 GMT <douglascrp> Loftux, I was planning to perform the upgrade in two servers, but now, I'm not sure if I'm willing to play with that

2016-12-21 13:44:24 GMT <AFaust> Loftux: So far I have not seen this behaviour with my local 5.2 GA instance using PostgreSQL. I will do some more intensive tests when I am back at the office later today...

2016-12-21 13:45:33 GMT <AFaust> If I can not reproduce it then I will setup a separate MariaDB to see if I can reproduce it that way...

2016-12-21 13:51:13 GMT <Loftux> AFaust: I'm not seeing it on any of the servers that has less than 10 (or at least just a small number) of active sessions.

2016-12-21 13:52:52 GMT <Loftux> I have this Alfresco version running for my own servers (customer demo server and internal), but usually very few logged on users.

2016-12-21 13:54:18 GMT <Loftux> yreg: One instance is EA to GA, the other was bigger upgrade (5.0.d)

2016-12-21 14:00:05 GMT <qwebirc71954> douglascrp: i have try to re install but that change nothing , this is my log of java consol if that can help ? http://pastebin.com/VRDriz31

2016-12-21 14:00:07 GMT <alfbot> Title: Java Plug-in 11.111.2.14 x86 Using JRE version 1.8.0_111-b14 Java HotSpot(TM) C - Pastebin.com (at pastebin.com)

2016-12-21 16:44:21 GMT <AFaust> ~later tell Loftux: Well, I tried reproducing it with some extensive parallel uploading and thumbnail generation which at least temporarily has spiked my system to 20 DB sessions. But no Hibernate issues occurred.

2016-12-21 16:44:21 GMT <alfbot> AFaust: The operation succeeded.

2016-12-21 19:10:13 GMT <alfbot> Loftux: Sent 2 hours and 25 minutes ago: <AFaust> Well, I tried reproducing it with some extensive parallel uploading and thumbnail generation which at least temporarily has spiked my system to 20 DB sessions. But no Hibernate issues occurred.

2016-12-21 19:46:16 GMT <Loftux> AFaust: Thanks for testing. Did a similar thing locally creating 12 sessions, and using 2 of them for simultaneous upload. No errors. I have now installed Newrelic to monitor the clients production server. Since after restart the only session active is mine, a new version upload that immediately triggered the error goes without a problem. It is like it works for a while, and then after some runs our of the db connections, even if it doesn

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco