Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-02-15 00:13:54 GMT <alfbot> jpotts: Sent 14 hours and 20 minutes ago: <IanW1> we have a similar use case - first thought was to disable users (MNT-12283/MNT-15038) - in the end we allow them to authenticate(SSO) but send them to a page without any links (and have other restrictions in place on content so safe enough for us) - code available

2017-02-15 03:05:34 GMT *** alfbot` is now known as alfbot

2017-02-15 08:04:01 GMT <yreg> Good morning community

2017-02-15 08:11:35 GMT <Sandy> yreg: Very Good Morning

2017-02-15 08:35:44 GMT <twen> 'morning

2017-02-15 08:38:53 GMT <DarkStar1> Hey twen

2017-02-15 08:38:59 GMT <DarkStar1> Morning everyone

2017-02-15 08:40:30 GMT <twen> DarkStar1 how are you ?

2017-02-15 08:44:27 GMT <Sandy> Hai Everyone, I need to integrate Two Active directories with alfresco, is there any solution. help me out please.

2017-02-15 08:50:19 GMT <DarkStar1> twen: Fine. Now that the weather is on the mend :)

2017-02-15 08:50:49 GMT <DarkStar1> twen: How goes life in mountain country?

2017-02-15 08:58:26 GMT <Dirk23> Hi

2017-02-15 08:58:51 GMT <Dirk23> i trie to install alfresco via alfresco-community-installer-201701-linux-x64.bin on Ubuntu 14.04

2017-02-15 08:59:23 GMT <Dirk23> but when i start the .bin i get a message wich strongly advises me not to install it:

2017-02-15 08:59:29 GMT <Dirk23> Some or all of the libraries needed to support LibreOffice were not found on your system: fontconfig libSM libICE libXrender libXext libcups libGLU libcairo2 libgl1-mesa-glx

2017-02-15 09:00:13 GMT <Dirk23> i installed LibreOffice via "apt-get install libreoffice-core"

2017-02-15 09:00:30 GMT <Dirk23> but still alfresco advises me not to install

2017-02-15 09:01:29 GMT <Dirk23> what did i miss?

2017-02-15 09:02:56 GMT <angelborroy> Dirk23 I was installing yesterday 201701 on Ubuntu 14.04

2017-02-15 09:03:34 GMT <angelborroy> Dirk23 I installed every dependecy for LibreOffice and the installer always complains about dependencies

2017-02-15 09:03:41 GMT <Dirk23> ok

2017-02-15 09:09:23 GMT <IanW1> angelborroy: Dirk23: Didn't notice that on 16.04

2017-02-15 09:09:42 GMT <angelborroy> IanW1 It’s time to upgrade OS! :D

2017-02-15 09:10:18 GMT <IanW1> angelborroy: I don't think 16.04 is officially supported yet

2017-02-15 09:10:29 GMT <Dirk23> ok. so i will first do the upgrade

2017-02-15 09:11:59 GMT <Dirk23> angelborroy: i have a installation wich i want to update. I have a snapshot to get back to the old working installation. Can i just run the installer to update?

2017-02-15 09:12:15 GMT <angelborroy> nope

2017-02-15 09:12:20 GMT <Dirk23> :/

2017-02-15 09:12:29 GMT <angelborroy> I’m writing an upgrade from 5.1.g to 201701 right now

2017-02-15 09:12:34 GMT <angelborroy> basically

2017-02-15 09:12:37 GMT <angelborroy> backup your database

2017-02-15 09:12:43 GMT <angelborroy> backup your “alf_data”

2017-02-15 09:12:47 GMT <angelborroy> identify your customizations

2017-02-15 09:12:51 GMT <angelborroy> use the installer

2017-02-15 09:12:55 GMT <angelborroy> test if it works

2017-02-15 09:12:58 GMT <angelborroy> stop Alfresco

2017-02-15 09:13:00 GMT <angelborroy> restore database

2017-02-15 09:13:03 GMT <angelborroy> restore alf_data

2017-02-15 09:13:07 GMT <angelborroy> apply customizations

2017-02-15 09:13:10 GMT <angelborroy> start again

2017-02-15 09:13:26 GMT <Dirk23> how do i backup a postgreql DB?

2017-02-15 09:13:35 GMT <Dirk23> and how do i restore it?

2017-02-15 09:13:50 GMT <angelborroy> you can wait 1 hour or so or read this one

2017-02-15 09:14:05 GMT <angelborroy> http://www.keensoft.es/en/our-road-from-alfresco-ce-5-0-c-to-alfresco-ce-5-1-g/

2017-02-15 09:14:07 GMT <alfbot> Title: Our road from Alfresco CE 5.0.c to Alfresco CE 5.1.g - keensoft (at www.keensoft.es)

2017-02-15 09:14:30 GMT <Dirk23> 1hour?

2017-02-15 09:14:38 GMT <angelborroy> I’m writing a blog post

2017-02-15 09:14:41 GMT <angelborroy> :)

2017-02-15 09:14:47 GMT <Dirk23> ah

2017-02-15 09:17:54 GMT <Tichodroma> angelborroy: I am curious how you deal with the "Restore production data" step

2017-02-15 09:18:02 GMT <Dirk23> angelborroy> I’m writing an upgrade from 5.1.g to 201701 right now

2017-02-15 09:18:04 GMT <angelborroy> let me see

2017-02-15 09:18:14 GMT <Dirk23> you mean the blogpost?

2017-02-15 09:18:21 GMT <angelborroy> right

2017-02-15 09:18:46 GMT <Dirk23> no "upgrade software wich does everything rigth for you"? ;)

2017-02-15 09:18:49 GMT <angelborroy> cause I upgraded yesterday our internal server

2017-02-15 09:18:55 GMT <angelborroy> hehe

2017-02-15 09:19:01 GMT <angelborroy> no, but IanW1 is working on that

2017-02-15 09:19:09 GMT <Dirk23> ok.

2017-02-15 09:19:28 GMT <angelborroy> Tichodroma sorry, what’s your question?

2017-02-15 09:19:59 GMT <Tichodroma> production data is the DB, the content_store, plus the index

2017-02-15 09:20:09 GMT <Tichodroma> How do you restore all this?

2017-02-15 09:20:45 GMT <angelborroy> just restoring DB and content_store

2017-02-15 09:20:50 GMT <Tichodroma> and Solr?

2017-02-15 09:20:55 GMT <angelborroy> as I’m using SOLR6 and indexes are not valid

2017-02-15 09:20:59 GMT <IanW1> angelborroy: That might be a tad over ambitious...

2017-02-15 09:21:16 GMT <Tichodroma> How do you deal with the reduced functionality while the index may be rebuilding?

2017-02-15 09:21:27 GMT <angelborroy> IanW1 it would be nice to share your findings about that work in the next Beecon ;-)

2017-02-15 09:21:51 GMT <angelborroy> Tichodroma it’s our internal server, complete re-index is performed in about 1 hour

2017-02-15 09:21:58 GMT <angelborroy> Tichodroma so no other actions are required

2017-02-15 09:22:00 GMT <Tichodroma> luckiy you :)

2017-02-15 09:22:36 GMT <angelborroy> Tichodroma if is required, I start Alfresco with SOLR 4 and SOLR 6

2017-02-15 09:22:40 GMT <Dirk23> angelborroy: is there a timeline for that updater?

2017-02-15 09:22:50 GMT <angelborroy> not really

2017-02-15 09:23:11 GMT <angelborroy> as IanW1 says, he is just only “studying” how to deal with this task

2017-02-15 09:23:20 GMT <Dirk23> gnarz..... i would love to go to the newest version, because we use Office2016 in near futur

2017-02-15 09:23:37 GMT <angelborroy> Dirk23 It took me 30 minutes to upgrade our server last night

2017-02-15 09:23:41 GMT <IanW1> angelborroy: Thinking about it - need permission to go first, then what sort of presentation

2017-02-15 09:23:51 GMT <Dirk23> do you have time? ;)

2017-02-15 09:23:56 GMT <angelborroy> hehe

2017-02-15 09:24:10 GMT <Dirk23> i guess for me it will end in a terrible mess

2017-02-15 09:24:21 GMT <Dirk23> and alfresco will not run after 16h

2017-02-15 09:24:41 GMT <Dirk23> ok, i will wait for your Blogpost. Can you trigger me, when you are done?

2017-02-15 09:24:46 GMT <Dirk23> please?

2017-02-15 09:24:55 GMT <IanW1> Dirk23: You're welcome to try https://github.com/wrighting/upgrade-assist - I haven't done anything on 5.2 yet but it has shown useful stuff before

2017-02-15 09:24:56 GMT <alfbot> Title: GitHub - wrighting/upgrade-assist: Help identifying what to do when upgrading a war overlay project (at github.com)

2017-02-15 09:26:09 GMT <IanW1> Dirk23: Don't know if it's relevant but the 5.1 upgrade could take a very long time updating workflows

2017-02-15 09:26:39 GMT <Dirk23> i have 5.1.0 (r127059-b7)

2017-02-15 09:26:51 GMT <Dirk23> do i need to step to 5.2 first?

2017-02-15 09:28:42 GMT <Dirk23> IanW1: sorry, i guess i'm not experienced enought to use that

2017-02-15 09:31:53 GMT <IanW1> Dirk23: No problem

2017-02-15 09:44:57 GMT <clu> Hi everyone.

2017-02-15 09:44:57 GMT <clu> Is it possible to compare the value of “Alfresco nodes in index” from the solr4 SUMMARY-report with any query from the Alfresco Database? We have compared it with the result from:

2017-02-15 09:44:58 GMT <clu> “select count (id) from alf_node where store_id = [id of workspace/SpacesStore]”

2017-02-15 09:45:00 GMT <clu> , but these numbers does not match.

2017-02-15 09:45:02 GMT <clu> We are trying to verify that everything that should be indexed by Solr is actually indexed.

2017-02-15 10:02:32 GMT <Dirk23> angelborroy: can you please let me know when you finished your Blogpost?

2017-02-15 10:02:54 GMT <angelborroy> Dirk23 things are complicating this morning

2017-02-15 10:03:02 GMT <angelborroy> Dirk23 maybe it’s not ready for today

2017-02-15 10:03:28 GMT <angelborroy> Dirk23 but it is essentially the same as this one http://www.keensoft.es/en/our-road-from-alfresco-ce-5-0-c-to-alfresco-ce-5-1-g/

2017-02-15 10:03:29 GMT <alfbot> Title: Our road from Alfresco CE 5.0.c to Alfresco CE 5.1.g - keensoft (at www.keensoft.es)

2017-02-15 10:03:29 GMT <Dirk23> ok :/

2017-02-15 10:08:34 GMT <Dirk23> angelborroy: can i go from 5.1.0 (r127059-b7) directly to the newest Version?

2017-02-15 10:08:42 GMT <angelborroy> sure

2017-02-15 10:08:45 GMT <Dirk23> ok

2017-02-15 10:42:47 GMT <Dirk23> ~later tell angelborroy I have trouble with your Blogpost for updateing alfresco: http://www.keensoft.es/en/our-road-from-alfresco-ce-5-0-c-to-alfresco-ce-5-1-g/ . "sudo mv /opt/alfresco /opt/alfresco-old - cd /opt/alfresco/postgresql/bin/" is not posible because 1. you moved the folder "alfresco" to "alfresco-old" and 2. there ist no postgresql folder inside my alfresco folder!

2017-02-15 10:42:48 GMT <alfbot> Title: Our road from Alfresco CE 5.0.c to Alfresco CE 5.1.g - keensoft (at www.keensoft.es)

2017-02-15 10:44:24 GMT <Dirk23> ~later tell angelborroy I have trouble with your Blogpost for updateing alfresco: http://www.keensoft.es/en/our-road-from-alfresco-ce-5-0-c-to-alfresco-ce-5-1-g/ . "sudo mv /opt/alfresco /opt/alfresco-old - cd /opt/alfresco/postgresql/bin/" is not posible because 1. you moved the folder "alfresco" to "alfresco-old" and 2. there ist no postgresql folder inside my a

2017-02-15 10:44:24 GMT <alfbot> Dirk23: The operation succeeded.

2017-02-15 10:45:22 GMT <Dirk23> ~later tell angelborroy 3. you have some encoding errors in "./pg_dump alfresco &amp;gt; /tmp/exportFile.dmp" i guess "&amp;gt;" should be ">"?

2017-02-15 10:45:22 GMT <alfbot> Dirk23: The operation succeeded.

2017-02-15 10:51:17 GMT <Dirk23> ~later tell angelborroy alfresco-community-installer-201701-linux-x64.bin complains about LibreOffice also on Ubuntu 16.04

2017-02-15 10:51:17 GMT <alfbot> Dirk23: The operation succeeded.

2017-02-15 11:33:20 GMT <Dirk23> ~later tell angelborroy i failed to upgrade Alfresco :/

2017-02-15 11:33:20 GMT <alfbot> Dirk23: The operation succeeded.

2017-02-15 12:35:24 GMT <bhagyas> Has anyone been able to download a file containing linked nodes as a Zip file?

2017-02-15 13:19:45 GMT <Dirk23> ~later tell angelborroy i dont know how anyone can install alfresco with the wizard. I tried ubuntu 16.04 (german) clean isntallation, could get it running. I tried Ubuntu 16.04 (englisch) clean, same as before. I dont know how i ever could update alfresco

2017-02-15 13:19:46 GMT <alfbot> Dirk23: The operation succeeded.

2017-02-15 13:39:04 GMT <Dirk23> Loftux: i try to install latest Alfesco to Ububntu 16.04 LTE (German). Is there any know issue with your installer with a german Ubuntu 16.04 LTE?

2017-02-15 13:41:08 GMT <Loftux> Dirk23: No, I made it so it's perfect ;) I've used it for a couple of 16.04 installs with no issues.

2017-02-15 13:41:26 GMT <Dirk23> Use LXCommunity ECM when installing? [y/n] n

2017-02-15 13:41:26 GMT <Dirk23> Installing Alfresco Community edition from Alfresco Software

2017-02-15 13:41:37 GMT <Dirk23> so i will now get the community Edition?

2017-02-15 13:53:45 GMT <Loftux> Dirk23: Yes that would be the version Alfresco provides.

2017-02-15 13:54:38 GMT <Dirk23> Loftux: Install Alfresco war files??

2017-02-15 13:54:55 GMT <Dirk23> whats that? If i install alfresco from the .bin file

2017-02-15 13:55:02 GMT <Dirk23> do i need to install any war files?

2017-02-15 14:03:02 GMT <Loftux> Dirk23: You do not use the Alfresco bin installer if you use the Ubuntu installer. Use one of them, both will install what you need.

2017-02-15 14:04:23 GMT <Dirk23> so do i need these war files. I dont know

2017-02-15 14:06:01 GMT <alfbot> angelborroy: Sent 3 hours and 21 minutes ago: <Dirk23> I have trouble with your Blogpost for updateing alfresco: http://www.keensoft.es/en/our-road-from-alfresco-ce-5-0-c-to-alfresco-ce-5-1-g/ . sudo mv /opt/alfresco /opt/alfresco-old - cd /opt/alfresco/postgresql/bin/ is not posible because 1. you moved the folder alfresco to alfresco-old and 2. there ist no postgresql folder inside my a

2017-02-15 14:06:02 GMT <alfbot> angelborroy: Sent 3 hours and 20 minutes ago: <Dirk23> 3. you have some encoding errors in ./pg_dump alfresco &amp;gt; /tmp/exportFile.dmp i guess &amp;gt; should be > ?

2017-02-15 14:06:03 GMT <alfbot> angelborroy: Sent 3 hours and 14 minutes ago: <Dirk23> alfresco-community-installer-201701-linux-x64.bin complains about LibreOffice also on Ubuntu 16.04

2017-02-15 14:06:04 GMT <alfbot> angelborroy: Sent 2 hours and 32 minutes ago: <Dirk23> i failed to upgrade Alfresco :/

2017-02-15 14:06:05 GMT <alfbot> angelborroy: Sent 46 minutes ago: <Dirk23> i dont know how anyone can install alfresco with the wizard. I tried ubuntu 16.04 (german) clean isntallation, could get it running. I tried Ubuntu 16.04 (englisch) clean, same as before. I dont know how i ever could update alfresco

2017-02-15 14:06:29 GMT <Dirk23> Loftux: i installed Alfresco 5.1 some time ago, now i want to see if 5.2 is better. do i need these war files for standard install?

2017-02-15 14:10:56 GMT <Loftux> Dirk23: Again, both installers add the necessary files, including war files. If you are looking to upgrade, it is a different story. There should be guides out there on how to do that.

2017-02-15 14:11:58 GMT <Dirk23> no, it can be a clean install

2017-02-15 14:13:12 GMT <Dirk23> Loftux: i dont get it. Do i have a standard Alfresco installation after using your installer?

2017-02-15 14:15:14 GMT <Loftux> Dirk23: Yes if you choose to use the Alfresco Community, it is standard to the part where the alfresco.war, share.war and so on is the same as with their bin installer. But some components such as libreoffice and tomcat are newer.

2017-02-15 14:15:45 GMT <Dirk23> ok

2017-02-15 14:17:32 GMT <Loftux> Cleaning out ACTIVITI: After a botched migration from postgresql to mysql, the Activiti data got messed up. It was mostly used for invites, so can I just clean out all ACT_ tables, restart and it will start Activiti fresh?

2017-02-15 14:20:07 GMT <Dirk23> Loftux: so i installed via your installer, but it seems that alfresco will not load :/

2017-02-15 14:28:25 GMT <Loftux> Dirk23: Did you install a database/create a database?

2017-02-15 14:30:47 GMT <Dirk23> nope.... just read it. But i cant configrue postgres or create a database

2017-02-15 14:38:49 GMT <Dirk23> wow, new login screen in alfresco 5.2?

2017-02-15 14:41:45 GMT <Dirk23> äh.... i set up a Password at installation, but whats the default user?

2017-02-15 14:42:20 GMT <resplin_> admin

2017-02-15 14:42:23 GMT *** resplin_ is now known as resplin

2017-02-15 14:42:54 GMT <Dirk23> hmmm... cant login with that. Darn, maybe i used a different Password

2017-02-15 14:43:03 GMT <Dirk23> is there a way to reset it?

2017-02-15 14:47:16 GMT <resplin> http://docs.alfresco.com/community/concepts/admin-password.html

2017-02-15 14:47:17 GMT <alfbot> Title: Admin password in default authentication | Alfresco Documentation (at docs.alfresco.com)

2017-02-15 14:47:34 GMT <Dirk23> i have no other user, its a clean install :/

2017-02-15 14:50:19 GMT <jpotts> Dirk23: It's faster to reinstall than to reset it.

2017-02-15 14:50:59 GMT <Dirk23> :(

2017-02-15 14:51:01 GMT <Dirk23> ok

2017-02-15 14:51:20 GMT <jpotts> Dirk23: But before you do, make sure that's the issue

2017-02-15 14:51:57 GMT <jpotts> If you are just seeing a login failure on the Share login page it may be masking something else that's going wrong with the alfresco WAR

2017-02-15 14:52:12 GMT <jpotts> Better to hit /alfresco then log in to the admin console

2017-02-15 14:52:38 GMT <jpotts> And check $ALFRESCO_HOME/tomcat/logs/catalina.out for the root cause

2017-02-15 15:14:56 GMT <angelborroy> Dirk23 Only in Spanish by now http://www.keensoft.es/camino-desde-alfresco-ce-5-1-g-alfresco-201701/

2017-02-15 15:14:57 GMT <alfbot> Title: Nuestro camino desde Alfresco CE 5.1.g hasta Alfresco 201701 - keensoft (at www.keensoft.es)

2017-02-15 15:15:10 GMT <angelborroy> Dirk23 5.1.g > 201701 on Ubuntu 14.04 using SOLR 6

2017-02-15 15:18:26 GMT <angelborroy> Dirk23 BTW I can confirm that Alfresco 201701 can be installed in Ubuntu 14.04

2017-02-15 15:18:55 GMT <angelborroy> Dirk23 And that 5.1.g to 201701 data and addons upgrading is succesful

2017-02-15 15:19:30 GMT <Dirk23> nice, but it didnt work for me. Its way to complicated

2017-02-15 15:19:55 GMT <angelborroy> Which are the main problems?

2017-02-15 15:20:00 GMT <angelborroy> LibreOffice dependencies?

2017-02-15 15:20:11 GMT <angelborroy> It is just an issue of the wizard installer

2017-02-15 15:20:13 GMT <angelborroy> What else?

2017-02-15 15:23:03 GMT <Dirk23> alfresco didnt start at all

2017-02-15 15:23:30 GMT <angelborroy> Dirk23 you know about that “catalina.out”, right?

2017-02-15 15:23:38 GMT <angelborroy> Dirk23 which is the error appearing there?

2017-02-15 15:23:41 GMT <Dirk23> i tried to follow your blogpost, but i could not successfully update

2017-02-15 15:24:04 GMT <Dirk23> i dont know, i had to restore the snapshot wich i made of the VM before upgrade

2017-02-15 15:24:23 GMT <angelborroy> Dirk23 It is hard to help you

2017-02-15 15:24:46 GMT <angelborroy> Dirk23 Why don’t you make a copy of your VM and play around upgrading that copy?

2017-02-15 15:25:03 GMT <angelborroy> Dirk23 You can make later your real upgranding once every step is clear

2017-02-15 15:26:23 GMT <Dirk23> angelborroy: i did something similar. I made a fresh VM with new Alfresco, but i event couldnt login in there

2017-02-15 15:26:35 GMT <angelborroy> Dirk23 that is strange

2017-02-15 15:26:46 GMT <angelborroy> Dirk23 I have installed about 10 or 12 times 201701

2017-02-15 15:26:51 GMT <Dirk23> yes, i have no luck with alfresco

2017-02-15 15:26:54 GMT <angelborroy> Dirk23 By using the wizard

2017-02-15 15:27:17 GMT <Dirk23> but there are more steps to do after the wizzard ran?

2017-02-15 15:27:24 GMT <angelborroy> Dirk23 not really

2017-02-15 15:27:35 GMT <Dirk23> creating a Database?

2017-02-15 15:27:54 GMT <angelborroy> if you are using an external PostgreSQL or MySQL, yes

2017-02-15 15:28:01 GMT <angelborroy> If you are using PostgreSQL from the installer, no

2017-02-15 15:28:07 GMT <Dirk23> Postgres on the same server

2017-02-15 15:28:24 GMT <angelborroy> installed by Alfresco wizard or installed by yourself?

2017-02-15 15:28:33 GMT <Dirk23> wizzard

2017-02-15 15:28:52 GMT <angelborroy> no database creation, then

2017-02-15 15:28:58 GMT <Dirk23> ok

2017-02-15 15:29:03 GMT <angelborroy> it’s “automagically” created by the wizard

2017-02-15 15:29:20 GMT <Dirk23> thnx for your patience and help, but need to go now.

2017-02-15 15:29:29 GMT <angelborroy> no problem

2017-02-15 15:29:36 GMT <angelborroy> just trying to help

2017-02-15 15:29:39 GMT <Dirk23> see you tomorrow

2017-02-15 15:29:42 GMT <angelborroy> see you

2017-02-15 21:53:35 GMT *** jpotts1 is now known as jpotts

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco