Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-02-16 07:22:18 GMT <qwebirc22398> Good morning! I'm looking for some advice to create a folder by a CMIS POST request. I'm struggling with the documentation here: http://docs.alfresco.com/5.1/pra/1/concepts/cmis-1.1-browser-binding-post.html - So, what is the exact URL to create i.e. a new folder within the documentLibrary level on a site?

2017-02-16 07:22:20 GMT <alfbot> Title: Creating content | Alfresco Documentation (at docs.alfresco.com)

2017-02-16 07:22:52 GMT <qwebirc22398> and which parameter (names) do I have to provide in the JSON?

2017-02-16 08:03:43 GMT <yreg> Morning guys !

2017-02-16 08:03:56 GMT <Dirk23> good morning

2017-02-16 08:07:51 GMT <twen> 'morning

2017-02-16 08:12:38 GMT <hi-ko> If someone is running ubuntu 16.04: Latest Kernel versions 4.4.0-59-generic to 4.4.0-62-generic has a painful bug which kills (oom-killer) the solr tomcat with Out of Memory complaint although there are gigabites of free mem

2017-02-16 08:13:40 GMT <hi-ko> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1655842 --> manually download and install kernel 4.4.0-63-generic seems to fix it.

2017-02-16 08:13:42 GMT <alfbot> Title: Bug #1655842 ""Out of memory” errors after upgrade to 4.4.0-59” : Bugs : linux package : Ubuntu (at bugs.launchpad.net)

2017-02-16 08:16:49 GMT <yreg> Loftux, If I remember right you asked somewhile ago for the _vti_bin war

2017-02-16 08:17:05 GMT <yreg> is that correct ?

2017-02-16 08:26:44 GMT <Loftux> yreg: Yes but it is available in alfresco artifacts now

2017-02-16 08:27:39 GMT <yreg> Loftux, OK, cool, I asked because I was checking the docs now

2017-02-16 08:28:00 GMT <yreg> which says it is included inside the AOS amp

2017-02-16 08:28:26 GMT <yreg> http://docs.alfresco.com/aos/tasks/aos-install.html

2017-02-16 08:28:27 GMT <alfbot> Title: Installing Alfresco Office Services | Alfresco Documentation (at docs.alfresco.com)

2017-02-16 08:29:01 GMT <Loftux> yreg: That must be wrong, since it is its own war

2017-02-16 08:29:15 GMT <Loftux> It may be part of the distribution zip

2017-02-16 08:29:48 GMT <Loftux> At least it was, I've switched the ubuntu installer to download directly

2017-02-16 08:31:15 GMT <yreg> well tell that to the docs team

2017-02-16 08:36:42 GMT <Loftux> I need to find users that does not have their usename generates as an email adress, used this part for the query: AND NOT cm:userName:"\@"

2017-02-16 08:36:48 GMT <Loftux> but does not work

2017-02-16 08:37:06 GMT <IanW1> Anybody seen a DataIntegrityViolationException in ChainingUserRegistrySynchronizer.notifySyncDirectoryStart?

2017-02-16 08:37:15 GMT <Loftux> Is it possible to search for @?

2017-02-16 08:41:03 GMT <Loftux> I figured it out.I could do -> cm:email:company AND NOT cm:userName:company.com

2017-02-16 08:48:27 GMT <AFaust> IanW1: How should such an integration occur in that operation?

2017-02-16 08:49:32 GMT <IanW1> AFaust: I don't know but it's broken my LDAP sync

2017-02-16 08:49:33 GMT <AFaust> Loftux: I believe @ will be stripped out as a punctuation character just like - _

2017-02-16 08:50:03 GMT <IanW1> Caused by: org.springframework.dao.DataIntegrityViolationException: No property value exists for ID 1590842

2017-02-16 08:50:13 GMT <AFaust> Do you have a call stack?

2017-02-16 08:50:46 GMT <AFaust> Ah - yes, I oversaw the attributeService use there

2017-02-16 08:51:08 GMT <AFaust> IanW1: If you have messed with your alf_prop_* tables while the server was running you could run into problems...

2017-02-16 08:52:10 GMT <IanW1> AFaust: I've never messed with the database directly

2017-02-16 08:52:44 GMT <AFaust> So basically the operation is using the AttributeService to persist some process information on the AttributeService (resetting i.e. the summary and error of the last run)

2017-02-16 08:55:06 GMT <AFaust> What is the specific call stack then? I have only seen this issue before when someone cleared entries from the DB while some cache entry still referenced at least one of them, and an update to one attribute then caused a lookup to go wrong...

2017-02-16 08:55:17 GMT <IanW1> http://pastebin.com/STuQKpYd

2017-02-16 08:55:18 GMT <alfbot> Title: 2017-02-16 08:45:41,067 ERROR [security.sync.CustomChainingUserRegistrySynchron - Pastebin.com (at pastebin.com)

2017-02-16 08:55:27 GMT <AFaust> IanW1: Do you have the property cleanup job enabled?

2017-02-16 08:55:50 GMT <IanW1> AFaust: Don't know about that so probably not

2017-02-16 08:57:50 GMT <IanW1> It is a custom class but that part hasn't changed - I put in a new version last night and that was when I spotted the problem but I can't imagine how that could be a problem

2017-02-16 08:58:06 GMT <AFaust> Ok - looking at the AbstractPropertyValueDAOImpl the integritry exception should clear any cache state that may cause an issue

2017-02-16 08:58:49 GMT <AFaust> The only reason this could occur again-and-again is if the data is inconsistent on the DB to begin with.

2017-02-16 08:58:54 GMT <IanW1> This has run every 15 mins all night

2017-02-16 08:59:05 GMT <AFaust> But this should not happen - all the schema versions I have seen all have proper foreign key constraints

2017-02-16 09:00:02 GMT <IanW1> I have never touched the database and always shutdown tomcat nicely (not killed)

2017-02-16 09:00:10 GMT <IanW1> Using mysql

2017-02-16 09:01:59 GMT <AFaust> Can you execute this SQL to check: select * from alf_prop_unique_ctx where prop1_id = 1590842

2017-02-16 09:02:02 GMT <IanW1> The custom ldap code was to allow people to log in using their email address, not alfresco id, and the problem that was being fixed was that, although the login worked, a second user with the id of email address was being created

2017-02-16 09:03:41 GMT <IanW1> | 9 | 15051 | 754 | 763 | 765 | 1590842 |

2017-02-16 09:04:07 GMT <IanW1> +----+---------+----------------+----------------+----------------+----------+

2017-02-16 09:04:07 GMT <IanW1> | id | version | value1_prop_id | value2_prop_id | value3_prop_id | prop1_id |

2017-02-16 09:04:07 GMT <IanW1> +----+---------+----------------+----------------+----------------+----------+

2017-02-16 09:04:07 GMT <IanW1> | 9 | 15051 | 754 | 763 | 765 | 1590842 |

2017-02-16 09:04:07 GMT <IanW1> +----+---------+----------------+----------------+----------------+----------+

2017-02-16 09:05:11 GMT <angelborroy> IanW1 I have such a customization for some of my customers

2017-02-16 09:05:24 GMT <angelborroy> IanW1 No replicated users are created

2017-02-16 09:05:32 GMT <angelborroy> IanW1 I can share it with you if required

2017-02-16 09:08:11 GMT <IanW1> angelborroy: Thanks - it's OK for normal logging in but the extra user is created when connecting via IMAP - setting create.missing.people=false seems to help

2017-02-16 09:08:50 GMT <IanW1> I wonder if create.missing.people=false could cause problems with the LDAP sync?

2017-02-16 09:09:49 GMT <IanW1> Doing a dump/grep shows: alf_prop_string_value (2154,'No property value exists for ID 1590842','s for id 1590842',313958880);

2017-02-16 09:10:50 GMT <AFaust> IanW1: Sorry for the short drop - quick meeting at the coffee machine and my mobile is my WLAN access point

2017-02-16 09:11:13 GMT <AFaust> / hotspot

2017-02-16 09:11:27 GMT <IanW1> AFaust: No problem - thanks for the help

2017-02-16 09:11:57 GMT <AFaust> IanW1: Ok - that entry should definitely not be there. Can you check your schema? The prop1_id column should have a constraint on it

2017-02-16 09:14:46 GMT <AFaust> ~flushLog

2017-02-16 09:14:46 GMT <alfbot> AFaust: Woooosh, your log has been flushed...

2017-02-16 09:14:48 GMT <IanW1> AFaust: CONSTRAINT `fk_alf_propuctx_p1` FOREIGN KEY (`prop1_id`) REFERENCES `alf_prop_root` (`id`),

2017-02-16 09:15:12 GMT <AFaust> Does the alf_prop_root entry exist?

2017-02-16 09:15:49 GMT <IanW1> yes

2017-02-16 09:16:08 GMT <AFaust> Ahh - I think I see the issue

2017-02-16 09:16:16 GMT <AFaust> check alf_prop_value for a value with that ID

2017-02-16 09:16:23 GMT <AFaust> That must be missing

2017-02-16 09:17:04 GMT <AFaust> And since neither alf_prop_unique_ctx nor alf_prop_root reference that table, there is no immediate integrity check there

2017-02-16 09:17:09 GMT <IanW1> You're right - it is missing

2017-02-16 09:21:12 GMT <IanW1> Dump/grep for id only shows the following:

2017-02-16 09:21:17 GMT <IanW1> alf_prop_root (1590842,0)

2017-02-16 09:21:18 GMT <IanW1> alf_prop_string_value (2154,'No property value exists for ID 1590842','s for id 1590842',313958880);

2017-02-16 09:21:18 GMT <IanW1> alf_prop_unique_ctx (9,15051,754,763,765,1590842)

2017-02-16 09:24:14 GMT <AFaust> check alf_prop_value

2017-02-16 09:24:27 GMT <AFaust> alf_prop_string_value is not related to that prop1_id

2017-02-16 09:24:55 GMT <AFaust> at least not directly (the alf_prop_value table is a big cross-linking table between any prop*_id and the actual values)

2017-02-16 09:25:52 GMT <AFaust> oh - forgot I already asked for alf_prop_value check

2017-02-16 09:26:15 GMT * AFaust curses the interuptions by people coming by for a quick chat at the desk

2017-02-16 09:27:55 GMT <IanW1> So the id is only in alf_prop_root and alf_prop_unique_ctx and there's an error message containing the id in alf_prop_string_value

2017-02-16 09:27:58 GMT <AFaust> IanW1: So somehow, someone / some code deleted the alf_prop_value entry and now the alf_prop_unique_ctx value is useless

2017-02-16 09:28:19 GMT <AFaust> Never realized that this transitive relation is not properly integritry checked on the DB layer

2017-02-16 09:29:42 GMT <AFaust> IanW1: The error message in alf_prop_string_value is "just" a coincidence that you found that. Since the synchronisation uses the AttributeService to store the "last run error", that error message is created as an alf_prop_string_value and referenced by a different alf_prop_unique_ctx

2017-02-16 09:30:19 GMT <IanW1> AFaust: I was assuming something like that

2017-02-16 09:32:15 GMT <AFaust> I think the easiest way to solve this might be to just delete the alf_prop_unique_ctx entry and restart Alfresco

2017-02-16 09:32:54 GMT <AFaust> Luckily the alf_prop_unique_ctx is a root-like entry - no other table should reference it

2017-02-16 09:33:33 GMT <IanW1> What do you think I should do with the alf_prop_root entry?

2017-02-16 09:41:59 GMT <AFaust> IanW1: Check if the root entry is reference by any other alf_prop_unique_ctx - it is very likely not

2017-02-16 09:42:38 GMT <AFaust> Also check references from alf_prop_link

2017-02-16 09:43:44 GMT <IanW1> AFaust: it is not referenced - safer to leave or delete?

2017-02-16 09:43:57 GMT <AFaust> Since this is a very specific use case there is - in my eyes - little chance of these entries being referenced from anywhere else, so it should be perfectly save to delete the affected alf_prop_link entry/entries + alf_prop_root entry

2017-02-16 09:44:10 GMT <AFaust> :%s/save/safe/

2017-02-16 09:44:35 GMT <AFaust> alfbot: You should really learn to understand vim commands

2017-02-16 09:44:35 GMT <alfbot> AFaust: Error: "You" is not a valid command.

2017-02-16 09:45:04 GMT <AFaust> Don't you "Error" me, young man...

2017-02-16 09:46:24 GMT <IanW1> AFaust: Many, many thanks - I'll have to wait until out of hours tonight to try it but sounds hopeful.

2017-02-16 10:09:21 GMT <qwebirc22398> Hi there again! I'm looking for some advice to create a folder by a CMIS POST request. I'm struggling with the documentation here: http://docs.alfresco.com/5.1/pra/1/concepts/cmis-1.1-browser-binding-post.html - So, what is the exact URL to create i.e. a new folder within the documentLibrary level on a site?

2017-02-16 10:13:21 GMT <AFaust> qwebirc22398: We can only give you a generic base URL because the "exact" URL will need to include the ID of the node representing the documentLibrary, which is unique to your system

2017-02-16 10:14:07 GMT <AFaust> Also, you should not need to know the URL if you use a proper CMIS client library...

2017-02-16 10:16:02 GMT <qwebirc22398> AFaust: Thanks, but what is the above URL the correct one? and what is the parameter name to add that contains the ID? I do have the ID, I have at least everything from the current folder but what I dont have yet, is the correct URL and the parameter that I have to pass to the POST request to create a new folder

2017-02-16 10:16:27 GMT <AFaust> i.e. a CMIS library allows you to resolve a path to an object ID for a folder and then simply create a new object in that folder via its abstract programming API

2017-02-16 10:16:45 GMT <qwebirc22398> I don't use a CMIS client library, I just want to create the folder by my created POST request

2017-02-16 10:19:38 GMT <AFaust> I hope you are at least looking in the CMIS specification then to find out what parameters to provide, e.g. http://docs.oasis-open.org/cmis/CMIS/v1.1/errata01/os/CMIS-v1.1-errata01-os-complete.html#x1-2250001

2017-02-16 10:19:39 GMT <alfbot> Title: Content Management Interoperability Services (CMIS) Version 1.1 (at docs.oasis-open.org)

2017-02-16 10:20:04 GMT <AFaust> and http://docs.oasis-open.org/cmis/CMIS/v1.1/errata01/os/CMIS-v1.1-errata01-os-complete.html#x1-2330003

2017-02-16 10:20:05 GMT <alfbot> Title: Content Management Interoperability Services (CMIS) Version 1.1 (at docs.oasis-open.org)

2017-02-16 10:20:16 GMT <AFaust> ^^ 1st is createDocument, 2nd is createFolder

2017-02-16 10:26:29 GMT <AFaust> i.e. via https://cmis.alfresco.com/alfresco/api/-default-/public/cmis/versions/1.1/browser/root/Sites/mySite/documentLibrary?selector=cmisobject you can get the folder ID for the document library

2017-02-16 10:26:57 GMT <AFaust> ^^ just replace the host address according to your protocol + host + port

2017-02-16 10:28:34 GMT <AFaust> minor correction: https://cmis.alfresco.com/alfresco/api/-default-/public/cmis/versions/1.1/browser/root/Sites/mySite/documentLibrary?cmisselector=object

2017-02-16 10:30:36 GMT <AFaust> And the URL to POST to should then be https://cmis.alfresco.com/alfresco/api/-default-/public/cmis/versions/1.1/browser/root?objectId=<yourFolderId>

2017-02-16 11:16:34 GMT <magp> Hi guys I'm having trouble cancelling the checkout of a document. When I try to cancel the checkout it says its locked and when I try to unlock it it says its checked out >_<.

2017-02-16 12:02:40 GMT <koula> for ADF i will need the Activity enterprise edition? community will not do the work>

2017-02-16 12:02:41 GMT <koula> ?

2017-02-16 12:03:45 GMT <angelborroy> koula, right

2017-02-16 12:07:00 GMT <yreg> angelborroy, really ?

2017-02-16 12:07:08 GMT <angelborroy> afaik, yes

2017-02-16 12:07:18 GMT <angelborroy> it’s designed for Activiti Enterprise API REST

2017-02-16 12:07:30 GMT <angelborroy> but it does not understand Activiti Community API REST

2017-02-16 12:07:40 GMT <angelborroy> I tested this 3 o 4 months ago

2017-02-16 12:07:56 GMT <yreg> ok, good to know

2017-02-16 12:08:13 GMT <angelborroy> I’m trying to find a project to test ADF, but no luck for now :(

2017-02-16 12:12:01 GMT <koula> :'(

2017-02-16 12:12:31 GMT <douglascrp> morning guys

2017-02-16 12:12:45 GMT <douglascrp> angelborroy, what do you mean by trying to find a project

2017-02-16 12:13:10 GMT <angelborroy> someone to pay my “learning” :D

2017-02-16 12:13:28 GMT <douglascrp> ahhh

2017-02-16 12:13:32 GMT <douglascrp> good point :D

2017-02-16 12:18:05 GMT <koula> do you happen to know an average pricing?

2017-02-16 12:18:33 GMT <angelborroy> about 25,000 dollars / year

2017-02-16 12:18:42 GMT <angelborroy> but it depends on the users and modules you buy

2017-02-16 12:18:55 GMT <angelborroy> koula better to contact directly Alfresco Sales

2017-02-16 12:19:38 GMT <koula> sure

2017-02-16 12:19:56 GMT <koula> and will be great for workflows? form flows in general ?

2017-02-16 12:20:24 GMT <angelborroy> koula for me it’s far much better than Community release

2017-02-16 12:20:43 GMT <angelborroy> koula you can evaluate Enterprise version for 1 month

2017-02-16 12:22:17 GMT <koula> rigth.

2017-02-16 12:23:50 GMT <koula> by the way, thanks for the afirmaclient, esign-cert suggestion. it works pretty nice.

2017-02-16 12:24:05 GMT <angelborroy> you’re welcome

2017-02-16 12:26:20 GMT <koula> are you planning for extending it for massive signature?

2017-02-16 12:26:45 GMT <koula> and the association to workflow steps?

2017-02-16 12:26:50 GMT <angelborroy> not by now

2017-02-16 12:28:23 GMT <angelborroy> but you can raise an issue in the project and let me know your requirements

2017-02-16 12:31:25 GMT <mrks_js> wow, activiti enterprise for adf? i did not know that. thanks

2017-02-16 12:32:40 GMT <koula> Alfresco content repository is also for alfresco one... not the community edition. right?

2017-02-16 12:33:29 GMT <angelborroy> no, ADF will work with Community and One

2017-02-16 12:33:36 GMT <angelborroy> as it’s using public REST API

2017-02-16 12:34:47 GMT <angelborroy> public REST API based on Swagger, I mean

2017-02-16 12:34:54 GMT <angelborroy> the NEW REST API

2017-02-16 12:35:13 GMT <angelborroy> really, this is starting to be so messed with that Alfresco API names...

2017-02-16 12:39:16 GMT <yreg> guys

2017-02-16 12:39:33 GMT <yreg> is there a way to trace share-config ?

2017-02-16 12:40:00 GMT <yreg> I have few missing actions and I would like to track them down

2017-02-16 12:40:16 GMT <yreg> why aren't they showing

2017-02-16 12:45:30 GMT <AFaust> angelborroy: Just use v1 ReST API

2017-02-16 12:45:51 GMT <angelborroy> AFaust I’ll try :D

2017-02-16 12:45:57 GMT <AFaust> And it is not based on Swagger - only the API explorer uses that

2017-02-16 12:46:01 GMT <AFaust> AFAIK

2017-02-16 12:46:09 GMT <angelborroy> AFaust I know, yes you are right

2017-02-16 12:46:25 GMT <angelborroy> AFaust and what about JavaScript API? :)

2017-02-16 12:46:46 GMT <AFaust> And "Public ReST API" is a super-set which contains both the "v0 ReST API" and the new "v1 ReST API"

2017-02-16 12:47:32 GMT <AFaust> As far as I have seen in some of the recent documentations, they seem to have rebranded the "new JavaScript API" to "Alfresco Unified JavaScript API"

2017-02-16 12:48:24 GMT <angelborroy> nice

2017-02-16 12:48:36 GMT <AFaust> But this was not announced nor communicated anywhere, it just popped up on some screenshot AFAIK

2017-02-16 12:49:44 GMT <AFaust> The project is still just called alfresco-js-api

2017-02-16 13:08:39 GMT <qwebirc85437> HI

2017-02-16 13:08:54 GMT <qwebirc85437> We are not able to access alfresco and get the below error

2017-02-16 13:08:54 GMT <qwebirc85437> Your authentication details have not been recognized or Alfresco may not be available at this time.

2017-02-16 13:09:46 GMT <qwebirc85437> 2017-02-16 18:34:38,868 ERROR [org.springframework.web.context.ContextLoader] [localhost-startStop-1] Context initialization failed org.alfresco.error.AlfrescoRuntimeException: 01160001 Ensure that the 'dir.root' property 'D:\ALFRES~2\alf_data' is pointing to the correct data location. at org.alfresco.repo.admin.ConfigurationChecker.check(ConfigurationChecker.java:256) at org.alfresco.repo.admin.ConfigurationChecker.access$0

2017-02-16 13:14:30 GMT <angelborroy> qwebirc85437 it looks like your database and your alf_data folder are not synched

2017-02-16 13:14:47 GMT <angelborroy> qwebirc85437 are you migrating or so?

2017-02-16 13:20:30 GMT <DarkStar1> hello people

2017-02-16 13:20:41 GMT <qwebirc85437> No

2017-02-16 13:21:40 GMT <angelborroy> then seems that your database or filesystem is corrupted

2017-02-16 13:21:50 GMT <douglascrp> DarkStar1, hey man

2017-02-16 13:21:53 GMT <qwebirc85437> So how do we go about

2017-02-16 13:23:23 GMT <DarkStar1> Is there anywhere else the alfresco.port variable could be over-ridden?

2017-02-16 13:24:31 GMT <douglascrp> DarkStar1, have you seen this about LibreOffice?

2017-02-16 13:24:32 GMT <douglascrp> http://www.linuxhint.com/install-libreoffice-on-linux-mint-debian-ubuntu-fedora/

2017-02-16 13:24:33 GMT <alfbot> Title: LibreOffice 5.3 Offers Browser-based Version- Install on Ubuntu, CentOS (at www.linuxhint.com)

2017-02-16 13:25:02 GMT <DarkStar1> douglascrp: nope

2017-02-16 13:25:31 GMT <hi-ko> <DarkStar1

2017-02-16 13:25:47 GMT <DarkStar1> howdy hi-ko. Happy New Year :)

2017-02-16 13:25:54 GMT <hi-ko> DarkStar1: and it's already integrated into nextcloud ;-)

2017-02-16 13:26:23 GMT <qwebirc85437> angelborroy, Can you please suggest... what can be done

2017-02-16 13:26:27 GMT <hi-ko> DarkStar1: yeah! also nice Spring!

2017-02-16 13:26:42 GMT <angelborroy> qwebirc85437 restore a backup

2017-02-16 13:28:38 GMT <DarkStar1> hi-ko: and soon integrated with alfresco :)

2017-02-16 13:29:12 GMT <hi-ko> douglascrp, DarkStar1: sounds much, much better than the google grap!

2017-02-16 13:30:30 GMT <hi-ko> unfortunately we have only one single customer using libreoffice on the client side and from our own experience one should never mix MS and LO

2017-02-16 13:43:00 GMT <rootinshell> comment diable ! on peut compiler une dashlet !! j'arrive pas ...

2017-02-16 13:43:23 GMT <rootinshell> quelqu'un aurait une minute ?

2017-02-16 13:43:55 GMT <rootinshell> mon JDK est ok, variables d'environnement Ok, windows 7 x64

2017-02-16 13:43:59 GMT <rootinshell> ant ok aussi

2017-02-16 13:44:17 GMT <AFaust> rootinshell: Ce canal utilise principalement l'anglais pour la communication

2017-02-16 13:44:40 GMT <rootinshell> ah sorry :/

2017-02-16 13:44:41 GMT <AFaust> rootinshell: So if you are able to use English more people can actually help

2017-02-16 13:45:13 GMT <AFaust> Since we have people from all over the world here it would otherwise be a chaotic mix of languages...

2017-02-16 13:45:17 GMT <rootinshell> AFaust, yes i do thanks :)

2017-02-16 13:45:54 GMT <rootinshell> it just my irc client who showed my the channel discription in french so things went wrong. i will translate my question

2017-02-16 13:46:16 GMT <rootinshell> so Hi everyone,

2017-02-16 13:47:41 GMT <rootinshell> i was asking if anyone could tell me how the hell we can compile a dashlet, i've been trying to do it 10 hours ago no success. my JDK seems ok, my environnement varible are ok, my ant is ok also.

2017-02-16 13:48:04 GMT <rootinshell> i'm using windows 7 64x

2017-02-16 13:48:44 GMT <AFaust> Are you using the Alfresco SDK? If so, what version of the SDK are you using and what version of Alfresco are you trying to work with? Also, are you trying to create a YUI dashlet, an Aikau dahslet or any other kind of dashlet (custom)?

2017-02-16 13:50:41 GMT <rootinshell> AFaust, it's a share-extra dashlet a got from github, i adjusted my css files and i'm trying to compile the jar file.

2017-02-16 13:52:19 GMT <AFaust> Which dashlet specifically?

2017-02-16 13:52:20 GMT <rootinshell> i'm runing alfresco community 5, i've downloaded the alfresco SDK 4 ( the dashlet is using SDK 4 )

2017-02-16 13:52:35 GMT <rootinshell> Gallery Plus Dashlet

2017-02-16 13:53:03 GMT <AFaust> And what is / are the error(s) you are getting?

2017-02-16 13:58:17 GMT <rootinshell> AFaust, https://codepaste.net/e1in9k

2017-02-16 13:58:18 GMT <alfbot> Title: CodePaste.NET - trying (at codepaste.net)

2017-02-16 13:59:43 GMT <rootinshell> for information my alfresco community is not running on this machine ..got it on another dev server

2017-02-16 14:02:15 GMT <AFaust> Hmm - isn't Gallery Plus dashlet a FME dashlet, not a Share Extras one?

2017-02-16 14:02:24 GMT <AFaust> i.e. https://github.com/fmaul/fme-alfresco-extensions/tree/master/Gallery%20Plus%20Dashlet

2017-02-16 14:02:25 GMT <alfbot> Title: fme-alfresco-extensions/Gallery Plus Dashlet at master · fmaul/fme-alfresco-extensions · GitHub (at github.com)

2017-02-16 14:03:11 GMT <rootinshell> yes it is

2017-02-16 14:03:29 GMT <rootinshell> isorry if i got confused

2017-02-16 14:04:30 GMT <AFaust> You need to set alfresco.sdk.dir as a property in in your user home build.properties file

2017-02-16 14:04:40 GMT <AFaust> That needs to be the path to the exploded SDK ZIP

2017-02-16 14:05:21 GMT <AFaust> If you don't have such a file you should create it

2017-02-16 14:11:38 GMT <douglascrp> does anyone here have an alfresco instance running on 16.04, and with the preview working? I mean, the libreoffice

2017-02-16 14:11:53 GMT <douglascrp> there is no way I can make it work here

2017-02-16 14:12:39 GMT <douglascrp> the process is always killed

2017-02-16 14:14:06 GMT <IanW1> douglascrp: I have platform running on 16.04.1 and libreoffice working nicely

2017-02-16 14:14:31 GMT <yreg> douglascrp, ping <grin>

2017-02-16 14:15:35 GMT <AFaust> douglascrp: I had such an instance when I recently did a training in Belgium...

2017-02-16 14:17:13 GMT <IanW1> douglascrp: but it didn't to start with - I found running libreoffice/scripts/libreoffice_ctl.sh start and status helped

2017-02-16 14:17:13 GMT <yreg> douglascrp, we are actually thinking about opensourcing a docker image for a JODconverter server

2017-02-16 14:17:33 GMT <yreg> + a custom transformer to use that remote jodconverter

2017-02-16 14:18:02 GMT <yreg> will let you know as soon as a decision is made

2017-02-16 14:18:03 GMT <IanW1> douglascrp: I think the magic was apt-get install libglu1-mesa

2017-02-16 14:19:53 GMT <AFaust> douglascrp: One important question: Do you have that problem when using the default installer? Or did you do a proper / clean install of libreoffice via apt-get?

2017-02-16 14:21:36 GMT <angelborroy> I bet he is using loftux installer ;-)

2017-02-16 14:21:46 GMT <AFaust> Different question: Is anyone aware of a truely open source addon that adds a simple "link via secondary child association"-type action in documentlibrary?

2017-02-16 14:22:08 GMT <AFaust> i.e. not like the "Parashift Open Source" model where you still need to buy a subscription...

2017-02-16 14:27:13 GMT <IanW1> I only raised ALF-21848 because resplin asked me to and now he's marked it as Won't Fix....

2017-02-16 14:28:29 GMT <IanW1> In fairness it would be a lot of work to sort out authentication properly for no significant functional gain

2017-02-16 14:29:17 GMT <IanW1> Back to trying to find some time to make CAS work sensibly again with 5.2

2017-02-16 14:31:50 GMT <rootinshell> AFaust, thanks !! compiled successfully , i'll try on alfresco now :)))

2017-02-16 14:40:34 GMT <douglascrp> IanW1 yreg AFaust tks for the answers

2017-02-16 14:40:55 GMT <douglascrp> AFaust, this was installed using apt-get

2017-02-16 14:41:04 GMT <douglascrp> and also by hand, using the deb files

2017-02-16 14:41:10 GMT <douglascrp> angelborroy, yes, I am

2017-02-16 14:41:23 GMT <angelborroy> we have a winner! :)

2017-02-16 14:43:02 GMT <AFaust> IanW1: I actually considered making a bet with you with regards to the chance of that ticket to be dealt with...

2017-02-16 14:43:31 GMT <IanW1> AFaust: You wouldn't have got a taker....

2017-02-16 14:56:26 GMT <resplin> IanW1: I didn't know that the triage labels were public. That's good to be aware of.

2017-02-16 14:56:41 GMT <resplin> It isn't a final decision, but it is where the conversation went today.

2017-02-16 14:57:06 GMT <resplin> Next time I'll know to put a comment in when I make that change to explain.

2017-02-16 14:57:42 GMT <resplin> We are glad you took the time to report it, as it raised an important conversation. We still might do it, but we didn't assign anyone today.

2017-02-16 14:59:52 GMT <resplin> IanW1: I appreciate the time you took to report it, because I wanted to raise the question of improving the use of web fragments, and needed the specfic example. I will be pointing to the issue again before we move on.

2017-02-16 15:05:17 GMT <IanW1> resplin: Thanks - (with lots of caveats I'm not far from Maidenhead and happy to share my experience with this)

2017-02-16 15:09:06 GMT <resplin> IanW1: The key take-away from today's conversation is that it will take some time to get to a final decision. So it's out of the Triage: To Do queue. It's going to be a long term thing.

2017-02-16 15:20:21 GMT <IanW1> resplin: Didn't really expect anything else unless you had other reasons for going there e.g. new API or just decided it's all too fragile at the moment... - Thanks again

2017-02-16 15:21:22 GMT <douglascrp> IanW1, the libglu1-mesa package is already installed here

2017-02-16 15:23:11 GMT <douglascrp> I am trying now with LibreOffice 5.3

2017-02-16 15:23:14 GMT <douglascrp> so far, no luck

2017-02-16 15:23:15 GMT <IanW1> douglascrp: Looking at my history I think running the command /opt/alfresco-community/libreoffice/program/soffice.bin --nofirststartwizard --nologo --headless '--accept=socket,host=localhost,port=8100\;urp\;StarOffice.ServiceManager' gave me a clue i.e. directly not from script

2017-02-16 15:23:34 GMT <douglascrp> yes, I tried that too, with 5.2

2017-02-16 15:23:37 GMT <douglascrp> let me try now with 5.3

2017-02-16 15:24:28 GMT <IanW1> douglascrp: I have 5.1.4 directly from the ubuntu repo (I think - I didn't do that part of the install)

2017-02-16 16:03:27 GMT <EmrisM> aloha, i'm having some issues with the alfresco community webpage.. what version comes after 5.0.d ?

2017-02-16 16:07:26 GMT <angelborroy> EmrisM 5.1.g aka 201605

2017-02-16 16:07:53 GMT <angelborroy> EmrisM https://community.alfresco.com/docs/DOC-6296-community-file-list-201605-ga

2017-02-16 16:07:55 GMT <alfbot> Title: Community file list 201605-GA | Alfresco Community (at community.alfresco.com)

2017-02-16 16:08:28 GMT <angelborroy> EmrisM also available Alfresco “5.2” as 201701

2017-02-16 16:08:29 GMT <angelborroy> https://community.alfresco.com/docs/DOC-6593-alfresco-community-edition-file-list-201701

2017-02-16 16:08:31 GMT <alfbot> Title: Alfresco Community Edition file list 201701 | Alfresco Community (at community.alfresco.com)

2017-02-16 16:08:37 GMT <iwkse> douglascrp: heya..are you trying LooL?

2017-02-16 16:08:47 GMT <douglascrp> iwkse, no, just the normal libreoffice for preview

2017-02-16 16:08:52 GMT <douglascrp> nothing different here

2017-02-16 16:08:53 GMT <iwkse> ah ok

2017-02-16 16:08:56 GMT <iwkse> but 5.3

2017-02-16 16:10:14 GMT <EmrisM> thnx, that helps :)

2017-02-16 16:12:34 GMT <EmrisM> also having problems with moodle alfresco plugin with my 5.0.d version... is it even possible with 5.0.d ?

2017-02-16 16:13:20 GMT <angelborroy> EmrisM which moodel alfresco plugin?

2017-02-16 16:14:03 GMT <EmrisM> moodle 2.7.9

2017-02-16 16:15:12 GMT <angelborroy> EmrisM it looks like Alfresco repository plugin does not work for Alfresco 5.0.c or later

2017-02-16 16:15:13 GMT <angelborroy> https://docs.moodle.org/32/en/Upgrading

2017-02-16 16:15:14 GMT <alfbot> Title: Upgrading - MoodleDocs (at docs.moodle.org)

2017-02-16 16:17:02 GMT <EmrisM> thats what i was afraid of :/

2017-02-16 16:17:14 GMT <douglascrp> IanW1, it didn't work

2017-02-16 16:17:50 GMT <douglascrp> this is weird... the process is started, is kept there for some time, including the ones marked as <defunct>, and then suddenly, everything is gone

2017-02-16 16:17:53 GMT <douglascrp> I see no errors here

2017-02-16 16:18:01 GMT <douglascrp> this is the second server I am facing this kind of problems

2017-02-16 16:18:02 GMT <angelborroy> EmrisM it looks like it is a SOAP approach, so it will not work from Alfresco 5.0.c

2017-02-16 16:18:17 GMT <angelborroy> EmrisM This SOAP API was discontinued from that Alfresco version

2017-02-16 16:18:28 GMT <douglascrp> angelborroy, interesting project that one... I got to know it some days ago while searching for other things

2017-02-16 16:18:34 GMT <douglascrp> and you are right... it was dependent on SOAP

2017-02-16 16:18:43 GMT <douglascrp> this is why it is out of the moodle's core now

2017-02-16 16:18:53 GMT <angelborroy> EmrisM Try this one: https://github.com/scara/moodle-repository_cmis

2017-02-16 16:18:54 GMT <alfbot> Title: GitHub - scara/moodle-repository_cmis: CMIS repository plugin for Moodle (at github.com)

2017-02-16 16:19:08 GMT <angelborroy> EmrisM Is using CMIS, which is a standard protocol

2017-02-16 16:23:35 GMT <EmrisM> my problem is that moodle is the backend, if you can call it that, of a product called Totara.. no easy update from that side, at the moment

2017-02-16 16:23:53 GMT <angelborroy> then, yes

2017-02-16 16:24:01 GMT <angelborroy> EmrisM your latests version is 5.0.c

2017-02-16 16:24:34 GMT <EmrisM> i guess i'll have to research more what combination between the two will work

2017-02-16 16:24:43 GMT <EmrisM> my version is 5.0.d

2017-02-16 16:26:07 GMT <angelborroy> maybe because you have an external module

2017-02-16 16:26:20 GMT <angelborroy> but there is no SOAP version from 5.1

2017-02-16 16:27:23 GMT <EmrisM> so i can't use that plugin anyway, at least from version 5.0.c and up

2017-02-16 16:27:56 GMT <angelborroy> right

2017-02-16 16:38:50 GMT <douglascrp> weird, I got 2 different libreoffice versions on this server

2017-02-16 16:38:55 GMT <douglascrp> ok, I'm starting again

2017-02-16 23:15:58 GMT <resplin> ~last seen mpatoyila

2017-02-16 23:15:58 GMT <alfbot> resplin: (last [--{from,in,on,with,without,regexp} <value>] [--nolimit]) -- Returns the last message matching the given criteria. --from requires a nick from whom the message came; --in requires a channel the message was sent to; --on requires a network the message was sent on; --with requires some string that had to be in the message; --regexp requires a regular expression the message must match; --nolimit returns all (1 more message)

2017-02-16 23:16:06 GMT <resplin> ~seen mpatoyila

2017-02-16 23:16:06 GMT <alfbot> resplin: I have not seen mpatoyila.

2017-02-16 23:16:32 GMT <resplin> ~seen mittal

2017-02-16 23:16:32 GMT <alfbot> resplin: I have not seen mittal.

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco