Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-02-21 01:05:15 GMT <grendal_prime> ok so basically im setting up my data store to be located on an nfs mounted dir (that lands on our filer) However im setting the solr4 indexing to /opt/alfresco-5.0.d/alf_data/keystore

2017-02-21 01:05:51 GMT <grendal_prime> which by the way is a virtualized system. ( like to complicate things i guess)

2017-02-21 01:06:54 GMT <grendal_prime> actually the issue is company policy all servers are virtualized and then they can be backed up on a scheduled automatic image copy.

2017-02-21 01:09:11 GMT <grendal_prime> config changes have been made, gonna kick off the indexing...but first going to restart and see if my tags and categories are working correctly

2017-02-21 01:36:18 GMT <grendal_prime> ya that does not seem to do anything different

2017-02-21 01:36:23 GMT <grendal_prime> hmm this is getting frustrating

2017-02-21 01:42:45 GMT <grendal_prime> what would cause some documents to be able to be taged and categorised but others not ?

2017-02-21 01:45:21 GMT <grendal_prime> and yes i have already enabled classifiable and taggable in the aspects of the document.

2017-02-21 01:48:34 GMT <grendal_prime> when i look at the documents properties, it shows they are part of the categories i have selected, however when i pull up that category from the menu in myfiles.

2017-02-21 01:50:30 GMT <grendal_prime> that category shows nothing

2017-02-21 05:16:49 GMT <grendal_prime> ok figured out i have to be looking at the categories in the Repository section. Aparently the categories in the my files only shows "my files" ie (files my user has created) and are associated with the variouse categories.

2017-02-21 05:17:21 GMT <grendal_prime> i guess from a security standpoint that makes sence.

2017-02-21 07:38:08 GMT <twen> 'morning

2017-02-21 07:45:24 GMT <bhagyas> Good morning :)

2017-02-21 07:50:43 GMT <yreg> Morninig

2017-02-21 07:50:43 GMT <alfbot> yreg: Sent 10 hours and 12 minutes ago: <digcat> yeah i noticed that marsbard was having issues with the infra but i need to catch up with him to find out how its going

2017-02-21 08:01:49 GMT <bhagyas> Good morning yreg

2017-02-21 08:02:49 GMT <yreg> Hey Bhagya

2017-02-21 08:07:54 GMT <bhagyas> Hey :)

2017-02-21 08:33:21 GMT <Dirk23> angelborroy: good morning and thnx again for your help

2017-02-21 08:33:36 GMT <angelborroy> Dirk23 morning, you’re welcome

2017-02-21 08:34:01 GMT <Dirk23> it seems like no document has a preview in alfresco now. Any idea, angelborroy?

2017-02-21 08:34:24 GMT <angelborroy> have you check that LibreOffice process is running?

2017-02-21 08:34:53 GMT <Dirk23> well.... no :/

2017-02-21 08:35:38 GMT <Dirk23> can you give me a hint how?

2017-02-21 08:37:25 GMT <Loftux> Dirk23: If you are running on linux you can use this script https://github.com/loftuxab/alfresco-ubuntu-install/blob/master/scripts/libreoffice.sh (adjust fot the libreoffice version you are using)

2017-02-21 08:37:26 GMT <alfbot> Title: alfresco-ubuntu-install/libreoffice.sh at master · loftuxab/alfresco-ubuntu-install · GitHub (at github.com)

2017-02-21 08:37:48 GMT <Dirk23> Loftux: Ubuntu 16.04

2017-02-21 08:38:07 GMT <Dirk23> Loftux: use this script for what?

2017-02-21 08:38:19 GMT <Dirk23> start libreoffice?

2017-02-21 08:38:40 GMT <Loftux> Check if it is runing, start, stop, restart

2017-02-21 08:40:05 GMT <Dirk23> Alfresco LibreOffice service NOT started

2017-02-21 08:40:15 GMT <Dirk23> so, i can start it with that script?

2017-02-21 08:40:36 GMT <Loftux> Dirk23: Yes, just use start as parameter

2017-02-21 08:40:45 GMT <Loftux> then check status againb

2017-02-21 08:41:11 GMT <Dirk23> albert@WIS-FD-Alfresco:/opt/alfresco-community$ ./libreoffice.sh start

2017-02-21 08:41:11 GMT <Dirk23> No passwd entry for user 'alfresco'

2017-02-21 08:41:11 GMT <Dirk23> Alfresco Open Office starting

2017-02-21 08:41:11 GMT <Dirk23> albert@WIS-FD-Alfresco:/opt/alfresco-community$ ./libreoffice.sh status

2017-02-21 08:41:11 GMT <Dirk23> Alfresco LibreOffice service NOT started

2017-02-21 08:41:44 GMT <Loftux> Dirk23: sudo

2017-02-21 08:43:08 GMT <Dirk23> Loftux: same

2017-02-21 08:43:22 GMT <Dirk23> do i need to change someting in that script

2017-02-21 08:43:33 GMT *** angelborroy_ is now known as angelborroy

2017-02-21 08:44:16 GMT <Loftux> Yes, as I said when linking, adjust for version of LibreOffice you are using, so that the path is correct.

2017-02-21 08:45:02 GMT <Loftux> I assume you are using Alfresco bundled version so somewhere in /opt/alfresco-community path

2017-02-21 08:46:00 GMT <Dirk23> yes

2017-02-21 08:46:38 GMT <Dirk23> Loftux: i changed ALF_HOME= to /opt/alfresco-community

2017-02-21 08:47:53 GMT <Loftux> Dirk23: Line 34 from /opt/libreoffice5.2/program/soffice.bin to the actual path to your soffice

2017-02-21 08:57:59 GMT <Dirk23> Loftux: changed it

2017-02-21 08:58:46 GMT <Dirk23> /bin/su -s /bin/bash $USER -c "/opt/alfresco-community/libreoffice/program/soffice.bin \"--accept=socket,host=localhost,port=8100;urp;StarOffice.Serve.ServiceManager\" \"-env:UserInstallation=file:///opt/alfresco/alf_data/oouser\" --nologo --headless --nofirststartwizard --norestore --nodefault &" >/dev/null

2017-02-21 08:58:52 GMT <Dirk23> but still not running

2017-02-21 08:59:43 GMT <Dirk23> ok, changed file:///opt/alfresco to /opt/alfresco-community

2017-02-21 08:59:58 GMT <Dirk23> but service still not running. Maybe i have to go back to Ubuntu 14.04?

2017-02-21 09:00:25 GMT <Loftux> Some older version of libreoffice take the arguments in differents formats. Check the version history of that file.

2017-02-21 09:00:47 GMT <Dirk23> but how daes Libreoffice start without that script?

2017-02-21 09:01:11 GMT <Loftux> Alfresco starts it, you can just restart alfresco.

2017-02-21 09:01:30 GMT <Loftux> This script is so that you can manage libreoffice without a restart

2017-02-21 09:01:36 GMT <Dirk23> ok

2017-02-21 09:03:10 GMT <Loftux> Sometimes the process is fed a corrupt document and crashes permantly, or libreoffice just consuments to much memory. I schedule a restart once per day, and a check if it is actually running every 10 minutes, if not start. You can find sample of that on the main page for the link I sent earlier.

2017-02-21 09:03:10 GMT <Dirk23> Loftux:

2017-02-21 09:03:12 GMT <Dirk23> albert@WIS-FD-Alfresco:/opt/alfresco-community$ sudo ./libreoffice.sh start

2017-02-21 09:03:12 GMT <Dirk23> No passwd entry for user 'alfresco'

2017-02-21 09:03:12 GMT <Dirk23> Alfresco Open Office starting

2017-02-21 09:03:12 GMT <Dirk23> albert@WIS-FD-Alfresco:/opt/alfresco-community$ sudo ./libreoffice.sh status

2017-02-21 09:03:13 GMT <Dirk23> Alfresco LibreOffice service NOT started

2017-02-21 09:03:44 GMT <Dirk23> whats that: No passwd entry for user 'alfresco'

2017-02-21 09:05:12 GMT <Loftux> You are not running Alfresco as user alfresco, the default installer runs as root (BAD!). Try changing the entry to root for which user to run as, or create a local linux user 'alfresco'

2017-02-21 09:06:24 GMT <IanW1> Dirk23: Try your command to start libreoffice without the > /dev/null so you can see the output

2017-02-21 09:06:44 GMT <IanW1> I have libreoffice running on 16.04

2017-02-21 09:06:50 GMT <Loftux> In the Alfresco Community pom.xml there is an property entry for dependency.alfresco-authorised-users.version (at version 5.2.0.4) What is this for? Cannot see it used anywhere.

2017-02-21 09:08:31 GMT <Dirk23> Loftux: wich entry? in ypur script?

2017-02-21 09:08:43 GMT <Dirk23> btw: restart of alfresco didnt start libreoffice

2017-02-21 09:09:04 GMT <Loftux> Dirk23: No that was another question unrelated to yours ;

2017-02-21 09:09:25 GMT <Dirk23> Loftux> You are not running Alfresco as user alfresco, the default installer runs as root (BAD!). Try changing the entry to root for which user to run as, or create a local linux user 'alfresco'

2017-02-21 09:09:53 GMT <Loftux> Dirk23: do what IanW1 siad

2017-02-21 09:12:04 GMT <Dirk23> Loftux: there is no output after changeing to not pipe it to /dev/null

2017-02-21 09:14:35 GMT <Loftux> Dirk23: Keep trying, just run the stuff on that line without su and so on. Sorry can't help you more than that

2017-02-21 09:15:17 GMT <Dirk23> i will go back to 14.04. No time to debug that

2017-02-21 09:18:04 GMT <Dirk23> on 14.04 its running. strange

2017-02-21 09:19:56 GMT <IanW1> ps gives me: /opt/alfresco-community/libreoffice/program/.soffice.bin --accept=socket,host=127.0.0.1,port=8100;urp;StarOffice.ServiceManager -env:UserInstallation=file:///opt/alfresco-community/alf_data/oouser --headless --nocrashreport --nofirststartwizard --nologo --norestore

2017-02-21 09:24:12 GMT <IanW1> I think douglascrp was having similar problems

2017-02-21 09:39:31 GMT <Loftux> IanW1: He filed this issue https://github.com/loftuxab/alfresco-ubuntu-install/issues/93 I just commented on that. I think the code to check libreoffice version is very unreliable.

2017-02-21 09:39:32 GMT <alfbot> Title: LibreOffice failing to start on Ubuntu 16.04 · Issue #93 · loftuxab/alfresco-ubuntu-install · GitHub (at github.com)

2017-02-21 10:07:22 GMT <yreg> My first case with alfresco support and I am already disappointed !

2017-02-21 10:08:04 GMT * yreg regrets going to alfresco support in the first place !

2017-02-21 10:11:32 GMT <angelborroy> yreg did you send your dump? :D

2017-02-21 10:11:40 GMT <bhagyas> yreg: xD

2017-02-21 10:11:46 GMT <Loftux> yreg: Don't feel sad, we are here to help you feel good again :)

2017-02-21 10:12:09 GMT <angelborroy> It’s 1 year now since they said my issue will be included in Alfresco release…

2017-02-21 10:12:27 GMT <bhagyas> yreg: I've had a good dose of it when I was working with Enterprise edition and customers :D

2017-02-21 10:12:27 GMT <angelborroy> Enterprise, of course

2017-02-21 10:13:07 GMT <angelborroy> yreg my approach (if it helps to you)

2017-02-21 10:13:17 GMT <angelborroy> yreg diagnose the issue and provide a patch to the customer

2017-02-21 10:13:22 GMT <bhagyas> happier with CE and LX since ;)

2017-02-21 10:13:44 GMT <IanW1> yreg: I suspect we've all been there...

2017-02-21 10:14:07 GMT <angelborroy> yreg then you can also provide your patch to Alfresco, but if you don’t have a 1st class support contract there is nothing to do

2017-02-21 10:14:16 GMT <yreg> angelborroy, bhagyas, Loftux : this is related to the issue I identefied for smartfolders'children (which are actually virtual nodes resolving to the actual nodes stored elsewhere on the system) having duplicate associations

2017-02-21 10:14:53 GMT <angelborroy> yreg are you able to fix that?

2017-02-21 10:15:09 GMT <bhagyas> yreg: Patch it, contribute to LX and then provide LX to customers

2017-02-21 10:15:09 GMT <bhagyas> ;)

2017-02-21 10:15:12 GMT <yreg> I told them that if I fetch the "actual node" there is no duplicate associations, only virtual nodes do have that !

2017-02-21 10:16:36 GMT <yreg> and the awsser was, Yes We can confirm that we can reproduce this and it is probably a bug... but you can fetch the actual node from the virtual node and continue processing

2017-02-21 10:16:58 GMT <bhagyas> yreg: I think that's an acceptable answer though...

2017-02-21 10:17:10 GMT <bhagyas> IF it happens within a code that is within your control

2017-02-21 10:17:28 GMT <angelborroy> it’s a better answer than expected

2017-02-21 10:17:43 GMT <angelborroy> how many time did you wait to receive that answoer?

2017-02-21 10:17:51 GMT <yreg> Yes, but still, the bug is there ! and I already implemented that as a temporary fix

2017-02-21 10:18:01 GMT <yreg> and was looking for a real fix

2017-02-21 10:18:17 GMT <angelborroy> this is not how it works

2017-02-21 10:18:18 GMT <bhagyas> yreg: Send us your patch

2017-02-21 10:18:25 GMT <angelborroy> they are not fixing every issue

2017-02-21 10:18:32 GMT <angelborroy> just the critical ones

2017-02-21 10:18:43 GMT <angelborroy> and just the one for the customers with 1st class support contract

2017-02-21 10:19:30 GMT <bhagyas> angelborroy: +1

2017-02-21 10:20:08 GMT <angelborroy> yreg which makes sense, but at least your issue is registered, right?

2017-02-21 10:20:24 GMT <yreg> What does registered mean ?

2017-02-21 10:20:31 GMT <angelborroy> issues.alfresco.com

2017-02-21 10:20:34 GMT <yreg> yes

2017-02-21 10:20:35 GMT <angelborroy> filed as issue

2017-02-21 10:20:35 GMT <bhagyas> yreg: JIRA

2017-02-21 10:20:48 GMT <angelborroy> sorry: as “Bug"

2017-02-21 10:20:49 GMT <yreg> wait, I did not check

2017-02-21 10:21:14 GMT <bhagyas> yreg: You need to follow other steps, like posting the JIRA link on Twitter and contacting Head of Support etc

2017-02-21 10:21:15 GMT <yreg> but will definitely file it on jira if it is not there yet

2017-02-21 10:21:24 GMT <bhagyas> :P

2017-02-21 10:21:31 GMT <yreg> bhagyas, hehe

2017-02-21 10:21:58 GMT <bhagyas> Also talk to the account manager if there is one - and threaten to migrate the code away :p

2017-02-21 10:22:11 GMT <yreg> What is irritating is that it took them a week or so to come back and suggest the temporary fix I told them about as a permanent fix

2017-02-21 10:23:05 GMT <yreg> I would love to see how much time has been logged on my support case !

2017-02-21 10:23:26 GMT <bhagyas> yreg: Did you talk to the account manager?

2017-02-21 10:23:40 GMT <bhagyas> Usually if it comes through the Account Manager, it gets assigned a higher priority

2017-02-21 10:24:07 GMT <yreg> Not really, no need to escalate, but it is just annoying and irritating

2017-02-21 10:24:10 GMT <bhagyas> Otherwise, they'll resort to Shaggy defence (Wasn't me)

2017-02-21 10:24:37 GMT <bhagyas> It's not only within just Alfresco though

2017-02-21 10:24:44 GMT <bhagyas> quite common among many vendors

2017-02-21 10:28:58 GMT <angelborroy> yreg IMO smart folders are not a prioritary development line

2017-02-21 10:29:09 GMT <angelborroy> yreg so your issue will be probably discarded

2017-02-21 10:30:12 GMT <Loftux> What version of LibreOffice does Alfresco come with when installed with the installer? Looking into the version detection code mentioned earlier, it seems to have a bug since long.

2017-02-21 10:30:25 GMT <IanW1> yreg: Out of interest why is it a problem?

2017-02-21 10:33:10 GMT <yreg> IanW1, the issue with smartfolder you mean?

2017-02-21 10:33:25 GMT <IanW1> yreg: yes

2017-02-21 10:34:36 GMT <yreg> This customer is using them massively for filtering documents on multiple criterias (originator, status, ..)

2017-02-21 10:35:34 GMT <yreg> there is some reporting jobs/doclib actions listing the whole structure under all/one smart folder

2017-02-21 10:35:48 GMT <yreg> duplicate enteries is obviously a problem

2017-02-21 10:36:57 GMT <yreg> and having to fetch the actual node out of the virtual node may not be that much of an overhead, but it just does not seem right, especially since all metadata I need is already there on the virtual node

2017-02-21 10:37:31 GMT <yreg> the associations as well

2017-02-21 10:37:43 GMT <yreg> but those are there twice

2017-02-21 10:40:47 GMT <yreg> fcorti, QQ about AAAR

2017-02-21 10:41:15 GMT <yreg> How is it handling audit enteries for documents that have been deleted and then recreated ?

2017-02-21 10:41:41 GMT <yreg> they should have the same path, but different noderefs

2017-02-21 10:42:37 GMT <yreg> and extracting auditing information about those is failing now because of multiple nodes being found for the same path

2017-02-21 10:44:31 GMT <yreg> I tweaked the SQL query to fetch newest node, but it does not seem right, as I am not sure which node it is

2017-02-21 10:50:46 GMT <Vasquez> hi guys i have just added new amp that contains new dashlet and i want to enable this dashlet to all users (via JS if possible)

2017-02-21 11:13:16 GMT <fcorti> yreg from a theroetical point of view the audit star schema is separated from the repository start schema

2017-02-21 11:13:31 GMT <fcorti> I don't remeber I met this case and could interesting to test it more

2017-02-21 11:13:49 GMT <fcorti> considering the fact the two star schemas are separated

2017-02-21 11:14:13 GMT <fcorti> the possible issue could be only in the link between the two

2017-02-21 11:15:10 GMT <yreg> fcorti, I am thinking about including the information about creation date in the view audit extraction is relying on

2017-02-21 11:15:44 GMT <yreg> then take the node with the nearest creation date before the action

2017-02-21 11:17:12 GMT <fcorti> so, the issue is not on the auit start schema but the issue is when the etl tries to link the path to the document/folder into the repository star schema

2017-02-21 11:17:16 GMT <fcorti> is it correct?

2017-02-21 11:17:51 GMT <yreg> yes

2017-02-21 11:18:12 GMT <fcorti> ok

2017-02-21 11:18:20 GMT <fcorti> so...

2017-02-21 11:18:36 GMT <yreg> it's one extra thing to reconsider for Alflytics

2017-02-21 11:18:46 GMT <fcorti> yes, definitely

2017-02-21 11:19:35 GMT <yreg> but I guess my client won't mind having those audit enteries linked to the "possibly" wrong node

2017-02-21 11:26:08 GMT <fcorti> we can refine this

2017-02-21 11:26:15 GMT <fcorti> it is not a huge challenge

2017-02-21 11:44:23 GMT <alfbot> douglascrp: Sent 12 hours and 48 minutes ago: <digcat> thats a good idea, also this one might be worth collaborating with https://github.com/apropia/alfresco-s3-adapter

2017-02-21 11:44:38 GMT <douglascrp> good morning

2017-02-21 11:44:52 GMT <douglascrp> ~later tell digcat thank you for the link

2017-02-21 11:44:52 GMT <alfbot> douglascrp: The operation succeeded.

2017-02-21 11:45:39 GMT <douglascrp> ~later tell digcat this new one is a fork of the other we talked yesterday

2017-02-21 11:45:39 GMT <alfbot> douglascrp: The operation succeeded.

2017-02-21 11:55:33 GMT <DarkStar1> ~later tell douglascrp Oh hai there :)

2017-02-21 11:55:33 GMT <alfbot> DarkStar1: The operation succeeded.

2017-02-21 11:55:42 GMT <douglascrp> DarkStar1, hey man

2017-02-21 11:55:42 GMT <alfbot> douglascrp: Sent just now: <DarkStar1> Oh hai there :)

2017-02-21 12:01:53 GMT <DarkStar1> douglascrp: Hey

2017-02-21 12:38:50 GMT <yreg> fcorti, also if it is not too late

2017-02-21 12:39:27 GMT <yreg> I would like to suggest the merge of document and folder dimensions inside one single node dimension

2017-02-21 12:39:54 GMT <yreg> we will still be able to differentiate using node_type

2017-02-21 12:40:32 GMT <yreg> and we will be able to correctly extract primary parent associations between documents

2017-02-21 12:40:55 GMT <fcorti> mmmm.... this is relevant from a design point of view

2017-02-21 12:41:08 GMT <yreg> after all they are all nodes

2017-02-21 12:41:27 GMT <yreg> and document can have children technically speaking

2017-02-21 12:42:20 GMT <yreg> I had to tweak my extraction scripts in order to be able to extract that relation, and had to remove the foreign key constraint too

2017-02-21 13:00:39 GMT <Vasquez> have just added new amp that contains new dashlet and i want to enable this dashlet to all users whats the painless way?

2017-02-21 13:14:25 GMT <Loftux> Vasquez: There is no painless way. You can possibly delete all users dashboard and reset to default (the ootb support tool can do that), and have the new default dashboard include your dashlet. But then users will loos their custom config.

2017-02-21 13:15:39 GMT <Vasquez> i have found that solution http://blog.itdhq.com/post/109396428145/2015-01-28-dropping-alfresco-user-dashboard-configuratio

2017-02-21 13:15:40 GMT <alfbot> Title: ITD Systems company blog — Dropping Alfresco user dashboard configuration (at blog.itdhq.com)

2017-02-21 13:15:56 GMT <Vasquez> but wanted to ask you if there is any better way

2017-02-21 13:17:04 GMT <Vasquez> another thing that is bothering me, i cant manage to override presets.xml located at WEB-INF/classes/alfresco/site-data/presets

2017-02-21 13:17:37 GMT <Vasquez> but instead my presets.xml is being deployed at WEB-INF/classes/alfresco/web-extension/site-data/presets

2017-02-21 13:18:35 GMT <Vasquez> i am using SDK and my presets.xml is in ../amp/config/alfresco/web-extension/site-data/presets/

2017-02-21 13:18:50 GMT <Loftux> Vasquez: Just move it upp in your src folder to alfresco/site-date/presets, doesn't have to be in web-extension.

2017-02-21 13:21:02 GMT <Vasquez> tnx

2017-02-21 13:43:49 GMT <alfbot> digcat: Sent 1 hour and 58 minutes ago: <douglascrp> thank you for the link

2017-02-21 13:43:50 GMT <alfbot> digcat: Sent 1 hour and 58 minutes ago: <douglascrp> this new one is a fork of the other we talked yesterday

2017-02-21 13:48:56 GMT <yreg> QQ: is there a ways to check the content of all fields for a specific entry in Solr ?

2017-02-21 13:49:33 GMT <yreg> (I have no access to FS, just access to web ui)

2017-02-21 14:58:23 GMT <qwebirc36768> hi guy

2017-02-21 14:58:26 GMT <qwebirc36768> hi guys

2017-02-21 14:59:31 GMT <yreg> fcorti, is it really possible to hook multiple alfrescos with a single AAAR ?

2017-02-21 15:00:14 GMT <yreg> I am trying to set up both Acceptance and Prod on the same AAAR

2017-02-21 15:00:28 GMT <yreg> and I am hitting a SQL Error during the extraction

2017-02-21 15:00:36 GMT <qwebirc36768> How do i remove alfresco community logo on the faceted search page

2017-02-21 15:00:46 GMT <fcorti> the dashboard have hardcoded the 1st instance

2017-02-21 15:00:55 GMT <fcorti> the ETL should work... bugs apart

2017-02-21 15:01:23 GMT <yreg> in transformation "update dm_dim_folders" saying that we are trying to change the ID of the unknown folder for the second alfresco to -1

2017-02-21 15:01:32 GMT <yreg> and that would violate the PK constraint

2017-02-21 15:02:46 GMT <yreg> fcorti, I think the unknown ID is also hardcoded pretty much every where

2017-02-21 15:03:24 GMT <fcorti> the unknown value is a different topic form the multinstance

2017-02-21 15:03:49 GMT <fcorti> unknown value is correct id hardcoded

2017-02-21 15:03:55 GMT <fcorti> if hadcoded

2017-02-21 15:04:03 GMT <fcorti> ouch... the keyboard

2017-02-21 15:04:23 GMT <yreg> if unknown is hardcoded, not when the ID -1 is hardcoded

2017-02-21 15:04:43 GMT <fcorti> ok, but ID = -1 is not related to the multiinstance

2017-02-21 15:04:58 GMT <fcorti> multiinstance is alfresco_id

2017-02-21 15:04:58 GMT <yreg> because we have an unknown folder by instance

2017-02-21 15:05:10 GMT <yreg> not all of them can have ID -1

2017-02-21 15:05:15 GMT <fcorti> ops...

2017-02-21 15:05:20 GMT <fcorti> yes, you are right

2017-02-21 15:05:23 GMT <fcorti> mmmm....

2017-02-21 15:05:31 GMT <fcorti> let me think how did it

2017-02-21 15:08:22 GMT <yreg> Hey jpotts !

2017-02-21 15:08:31 GMT <jpotts> Hi Younes!

2017-02-21 15:08:51 GMT <yreg> I remember hearing you talking about webdav scalability during last beecon

2017-02-21 15:09:03 GMT <yreg> or was it CIFS ?

2017-02-21 15:09:27 GMT <jpotts> It was probably CIFS

2017-02-21 15:10:07 GMT <yreg> any way, I wanted to confirm with you that webdav is expected to show performance degradation as soon as multiple users (few dozens) are using it concurrently

2017-02-21 15:11:05 GMT <jpotts> I don't think I can confirm that with certainty. In fact, I would assume that not to be the case as it uses HTTP. I would think it would scale similarly to normal HTTP users.

2017-02-21 15:11:47 GMT <jpotts> And you should be able to load-balance it if you are running a cluster with enterprise

2017-02-21 15:12:54 GMT <yreg> hmmm, we have this new client who has been using it for a while now, and operations seem to take longer on webdav than on share (ie: for the same file, upload in share in less than a minute, takes 10+ minutes on webdav)

2017-02-21 15:13:38 GMT <jpotts> Hmm, I find that strange.

2017-02-21 15:14:36 GMT <yreg> Ok, thanks for your input, I guess we will need to investigate this further before making any conclusions anyway !

2017-02-21 15:14:56 GMT <jpotts> But I am not familiar with the underlying internals of how webDAV is mapped to the node service and so on, so I may not be the best judge

2017-02-21 15:15:33 GMT <jpotts> I am interested to hear what you find out

2017-02-21 15:41:50 GMT <yreg> fcorti, for the record, I can think of a solution like replacing all reference to -1 as a parent ID by a select clause restricting by alfresco_id and src_id but it seems too much work for something that got superseded

2017-02-21 15:42:08 GMT <yreg> will probably simply setu 2 pentahos :-P

2017-02-21 15:44:34 GMT <yreg> ~later tell AFaust ping me when you are around

2017-02-21 15:44:34 GMT <alfbot> yreg: The operation succeeded.

2017-02-21 15:46:58 GMT <Loftux> douglascrp: Did you see the code that checks the version of Libreoffice https://github.com/loftuxab/alfresco-community-loftux/blob/loftux/projects/repository/source/java/org/alfresco/util/OpenOfficeVariant.java#L118

2017-02-21 15:46:59 GMT <alfbot> Title: alfresco-community-loftux/OpenOfficeVariant.java at loftux · loftuxab/alfresco-community-loftux · GitHub (at github.com)

2017-02-21 15:47:51 GMT <Loftux> I'm just thinking this could be scrapped entirely, since most installs will use a version 4.x or higher

2017-02-21 15:48:44 GMT <bhagyas> Is anyone aware of a way to invalidate the parentAssocRef caches using standard libraries?

2017-02-21 16:03:12 GMT <fcorti> yreg sorry was in call

2017-02-21 16:03:36 GMT <fcorti> probably now it's faster... let's discuss it in the next future

2017-02-21 16:03:49 GMT <fcorti> Of course I'm itnerested to make it grow and more reliable

2017-02-21 16:25:11 GMT <jpotts> Does anyone know what, if any, work has been done to integrate Flowable with Alfresco CE in the same way that the Share Connector integrates Alfresco Activiti and Alfresco Share Enterprise?

2017-02-21 16:26:28 GMT <jpotts> (I'll ask the Flowable guys too, I just thought maybe some folks in this chat might also know).

2017-02-21 16:48:07 GMT <alfbot> AFaust: Sent 1 hour and 3 minutes ago: <yreg> ping me when you are around

2017-02-21 16:49:50 GMT <AFaust> yreg: ping (since I forgot if /ping actually presents you with a notice)

2017-02-21 16:55:47 GMT <yreg> it does, but I am a bit caught up in a production issue

2017-02-21 16:55:51 GMT <yreg> sorry

2017-02-21 16:55:56 GMT <yreg> will get back ASAP

2017-02-21 17:22:36 GMT <AFaust> yreg: Ok - I may be back at home then (now leaving the customer)

2017-02-21 17:32:13 GMT <douglascrp> ~later tell Loftux yes, I saw that one, and I agree with you on that

2017-02-21 17:32:13 GMT <alfbot> douglascrp: The operation succeeded.

2017-02-21 18:00:27 GMT <alfbot> Loftux: Sent 28 minutes ago: <douglascrp> yes, I saw that one, and I agree with you on that

2017-02-21 18:08:38 GMT <mckeithyb> Afternoon guys - i'm trying to get the PdfJs plugin for AlfDocumentPreview to maximize by default... I'm new to aikau, so i've probably messed up somewhere.

2017-02-21 18:09:31 GMT <mckeithyb> Basically I am trying to do a widgetUtils.findObject, and finding alfresco/preview/AlfDocumentPreview by name

2017-02-21 18:10:47 GMT <mckeithyb> Then, push widgetsForPluginsOverrides : [ { "id" : "PdfJs", "maximized" : "true" } ]

2017-02-21 18:11:37 GMT <mckeithyb> I've no idea if i've got the id 'PdfJs' correct - or even if this is the right way of doing this.

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco