Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-07-31 01:28:47 GMT *** mmccarthy1 is now known as mmccarthy

2017-07-31 01:33:35 GMT *** mmccarthy1 is now known as mmccarthy

2017-07-31 05:07:39 GMT <DarkStar1> Morning

2017-07-31 07:25:27 GMT <yreg> Morning everyone !

2017-07-31 09:22:59 GMT <yreg> QQ: Is there a logic in OOTB alfresco preventing behaviours from creating an infinite loop of recursive invocation ?

2017-07-31 09:25:01 GMT <mrks_js> nope

2017-07-31 09:28:44 GMT <yreg> thanks Markus

2017-07-31 09:29:13 GMT <yreg> for con,firming my suspicions

2017-07-31 09:30:44 GMT <marsjk> yreg: you can disable behaviours inside your policy using the BehaviourFilter if this is what you mean

2017-07-31 09:34:40 GMT <yreg> I know I can do it manually

2017-07-31 09:35:51 GMT <yreg> but I was having some doubts that this could done automatically for behaviours of the same type, when I was reading some other developer code

2017-07-31 09:36:59 GMT <yreg> as in BehaviourX can not be invoked when the the thread stack does contain an other instance of BehaviourX

2017-07-31 09:37:33 GMT <yreg> So it is a bug in the code in front of me, not a feature in Alfresco

2017-07-31 10:19:35 GMT <oussama> Does anyone know why the WorkflowModelBuilder isn't spring managed?

2017-07-31 10:19:54 GMT <oussama> why is it instantiated with new ...

2017-07-31 12:04:24 GMT <chandu> Hello All

2017-07-31 12:05:45 GMT <chandu> Can you please look into this error is while generating AAAR reports in alfresco.

2017-07-31 12:05:51 GMT <chandu> "Error connecting to database [AAAR_Kettle] : org.pentaho.di.core.exception.KettleDatabaseException: Error occurred while trying to connect to the database The authentication type 5 is not supported. Check that you have configured the pg_hba.conf file to include the clients IP address or Subnet, and that it is using an authentication scheme supported by the driver. org.pentaho.di.core.exception.KettleDatabaseException: Error occ

2017-07-31 12:08:20 GMT <chandu> sorry clicked something :)

2017-07-31 12:09:52 GMT <fcorti> Hi chandu, seems to be an issue connecteD to PostgreSQL configuration

2017-07-31 12:10:23 GMT <fcorti> did you setup pg_hba.conf to accept connection without restrictions?

2017-07-31 12:10:32 GMT <fcorti> (and restart PostgreSql then)

2017-07-31 12:20:16 GMT <yreg> fcorti, "without restrictions" sounds risky

2017-07-31 12:20:37 GMT <yreg> I would suggest to setup postgresql security correctly

2017-07-31 12:20:48 GMT <yreg> not without restrictions

2017-07-31 12:37:37 GMT <kgastaldo> Hi All - The community is down for some unscheduled maintenance this morning. Keep you posted on its return.

2017-07-31 12:40:31 GMT <douglascrp> good morning

2017-07-31 12:43:02 GMT <fcorti> yes yreg, of course you are right but I assume he/she wants to make it work and then setup correctly ;-)

2017-07-31 13:07:15 GMT <kgastaldo> Looks like the community is back. Sorry for the inconvenience and lack of warning!

2017-07-31 13:12:24 GMT <douglascrp> guys, how is the support of "document library actions" inside the aikau based search result page?

2017-07-31 13:12:51 GMT <douglascrp> by looking at the release notes for several aikau versions, it seems the support was never added

2017-07-31 13:12:55 GMT <douglascrp> is that right?

2017-07-31 13:13:18 GMT <douglascrp> is this still the only way to add an existing document library there? https://www.parashift.com.au/2016/06/28/adding-custom-action-shares-faceted-search/

2017-07-31 13:13:20 GMT <alfbot> Title: Adding a Custom Action to Share’s Faceted Search - Parashift (at www.parashift.com.au)

2017-07-31 13:16:41 GMT <douglascrp> yreg, hey dude

2017-07-31 13:16:55 GMT <douglascrp> do you remember the problem I was facing on the last Friday?

2017-07-31 13:17:03 GMT <douglascrp> it was not a share proxy thing at all

2017-07-31 13:17:27 GMT <douglascrp> it was the server configuration that was wrong... I got the wrong alfresco.host set there

2017-07-31 13:17:48 GMT <yreg> douglascrp, hey dude

2017-07-31 13:17:52 GMT <yreg> makes sence

2017-07-31 13:17:56 GMT <douglascrp> once I fixed that, it worked

2017-07-31 13:18:07 GMT <yreg> regarding that thing with doclib actions in faceted search page

2017-07-31 13:18:08 GMT <douglascrp> sorry for wasting your time

2017-07-31 13:18:20 GMT <yreg> I think jpotts was asking about it a while back

2017-07-31 13:18:22 GMT <douglascrp> the idea to remote debug it made it clear

2017-07-31 13:18:35 GMT <yreg> and there is no clean way to do it

2017-07-31 13:18:46 GMT <yreg> np

2017-07-31 13:18:47 GMT <douglascrp> today?

2017-07-31 13:18:55 GMT <yreg> a week or two ago

2017-07-31 13:19:01 GMT <douglascrp> ah, ok

2017-07-31 13:19:06 GMT <yreg> definitely still is in chat logs though

2017-07-31 13:30:10 GMT <fcorti> hi all, the community portal is up and running again!

2017-07-31 13:59:03 GMT <Tichodroma> Do you know which classes parse and execute SF templates (https://docs.alfresco.com/5.1/concepts/sf-ref-template-guidance.html)? I am especially looking for the code that takes and executes the query.

2017-07-31 13:59:04 GMT <alfbot> Title: Smart Folder Template syntax | Alfresco Documentation (at docs.alfresco.com)

2017-07-31 14:13:31 GMT <Tichodroma> got it: https://github.com/ecm4u/alfresco-ce-repository/blob/master/root/projects/repository/source/java/org/alfresco/repo/virtual/template/VirtualQueryImpl.java#L146

2017-07-31 14:13:32 GMT <alfbot> Title: alfresco-ce-repository/VirtualQueryImpl.java at master · ecm4u/alfresco-ce-repository · GitHub (at github.com)

2017-07-31 14:19:55 GMT <Tichodroma> VirtualQueryImpl.java has deprecated methods that say: "will be replaced by {@link VirtualQueryConstraint}s once complex constrains are implemented". But this interface has no implementations as of 5.2.g.

2017-07-31 14:20:06 GMT <Tichodroma> Does anybody know if there is still work done on this?

2017-07-31 14:28:16 GMT <fwu> hello all!

2017-07-31 14:28:34 GMT <fwu> ppl, anyone using Alfresco 5.2?

2017-07-31 14:29:04 GMT <douglascrp> fwu, yes, I am

2017-07-31 14:29:08 GMT <fwu> im getting aproblem here when uploading files to the repo. The button doesn works and I get a 404 getting a js file.

2017-07-31 14:29:17 GMT <fwu> douglascrp!

2017-07-31 14:29:19 GMT <fwu> nice

2017-07-31 14:29:32 GMT <fwu> my standard upload button deoesnt work

2017-07-31 14:29:48 GMT <fwu> and because Im grttin a 404 js file, maybe is due to this

2017-07-31 14:29:57 GMT <fwu> im with the july version

2017-07-31 14:31:51 GMT <fwu> the file with 404 error: share/res/components/preview/StrobeMediaPlayback.js

2017-07-31 14:33:30 GMT <fwu> do you have this file?

2017-07-31 14:33:32 GMT <angelborroy> fwu

2017-07-31 14:33:36 GMT <angelborroy> no error on my part

2017-07-31 14:33:40 GMT <angelborroy> using also 201707

2017-07-31 14:33:44 GMT <fwu> hmm

2017-07-31 14:33:53 GMT <fwu> i got this using fiddler

2017-07-31 14:34:06 GMT <fwu> ig i go to the repo and try to upload files

2017-07-31 14:34:21 GMT <fwu> the upload button doesnt makes nothing. It seems a javascript error

2017-07-31 14:34:30 GMT <angelborroy> any customisation?

2017-07-31 14:34:42 GMT <fwu> but can you find this file in your installation?

2017-07-31 14:34:53 GMT <fwu> many cuastomizations... I may unistall them

2017-07-31 14:35:22 GMT <angelborroy> yes I have that file on that path

2017-07-31 14:35:38 GMT <angelborroy> it looks like some of your customisations is interfering with that

2017-07-31 14:36:40 GMT <fwu> but i dont have

2017-07-31 14:36:46 GMT <fwu> and i didnt deleted nothing

2017-07-31 14:36:56 GMT <fwu> can you send me the file olease?

2017-07-31 14:36:58 GMT <fwu> please

2017-07-31 14:37:30 GMT <fwu> im just deploying jar files, so that file cant be deleted

2017-07-31 14:37:45 GMT <angelborroy> https://github.com/Alfresco/share/blob/master/share/src/main/webapp/components/preview/StrobeMediaPlayback.js

2017-07-31 14:37:46 GMT <alfbot> Title: share/StrobeMediaPlayback.js at master · Alfresco/share · GitHub (at github.com)

2017-07-31 14:37:56 GMT <fwu> angelborroy, thank you!´

2017-07-31 14:38:24 GMT <fwu> i wil test.thnak you douglascrp and angelborroy

2017-07-31 14:38:41 GMT <fwu> if that file doesnt solve my problem, that I will undeploy my customizations

2017-07-31 14:38:47 GMT <fwu> that = then

2017-07-31 14:38:48 GMT <fwu> :)

2017-07-31 14:39:53 GMT <douglascrp> fwu, I also have the file in that path

2017-07-31 14:40:01 GMT <fwu> strangr

2017-07-31 14:40:05 GMT <fwu> strange

2017-07-31 14:40:11 GMT <fwu> i dont have any of the strobe files

2017-07-31 14:40:46 GMT <douglascrp> qq before I start investing time on this

2017-07-31 14:40:57 GMT <douglascrp> I believe it is possible to add tags normaly to datalists items

2017-07-31 14:41:00 GMT <douglascrp> am I right?

2017-07-31 14:41:07 GMT <douglascrp> has anyone tried it before?

2017-07-31 14:41:30 GMT <douglascrp> I can not see any reason for that not to work

2017-07-31 14:41:36 GMT <angelborroy> it should be possible but I haven’t tried

2017-07-31 14:41:55 GMT <angelborroy> in the end is and association...

2017-07-31 14:42:00 GMT <douglascrp> angelborroy, yes, exactly

2017-07-31 14:42:04 GMT <douglascrp> that is what I thought

2017-07-31 14:42:21 GMT <angelborroy> but let me see which kind of objets accepts

2017-07-31 14:42:25 GMT <douglascrp> some of the ootb datalists already include the attachable association, so I can not believe tags won't work

2017-07-31 14:42:49 GMT <douglascrp> angelborroy, ah, the target type, right?

2017-07-31 14:42:53 GMT <angelborroy> right

2017-07-31 14:42:59 GMT <douglascrp> good catch

2017-07-31 14:44:13 GMT <angelborroy> https://github.com/Alfresco/community-edition-old/blob/master/projects/repository/config/alfresco/model/contentModel.xml#L1128

2017-07-31 14:44:14 GMT <alfbot> Title: community-edition-old/contentModel.xml at master · Alfresco/community-edition-old · GitHub (at github.com)

2017-07-31 14:44:29 GMT <angelborroy> it looks like it is not an association

2017-07-31 14:44:40 GMT <angelborroy> just and aspect with a property of type Category

2017-07-31 14:45:13 GMT <angelborroy> definitively it works

2017-07-31 14:45:21 GMT <douglascrp> yes, cool

2017-07-31 14:45:24 GMT <douglascrp> thank you for the idea

2017-07-31 14:45:28 GMT <douglascrp> simple to validate :D

2017-07-31 14:45:33 GMT <angelborroy> ;-)

2017-07-31 14:45:36 GMT <douglascrp> I think I am going to need this for a future project

2017-07-31 14:49:43 GMT <fwu> douglascrp, are you translating the aikau menu in 5.2?

2017-07-31 14:49:53 GMT <douglascrp> fwu, no, why?

2017-07-31 14:50:05 GMT <douglascrp> alfresco offers it in brazilian portuguese already

2017-07-31 14:50:17 GMT <fwu> ok, because I tried to do that in 5.2 and I was only able to translate part of the menu...

2017-07-31 14:50:59 GMT <fwu> douglascrpt, strange.. the language is selected automatically by the browser right?

2017-07-31 14:51:16 GMT <douglascrp> yes

2017-07-31 15:01:19 GMT <fwu> where are the translated packages? I add one custom that use to work in 4.2.f

2017-07-31 15:32:40 GMT <fwu> douglascrp, to translate, did you have to download/install any language pack file?

2017-07-31 17:45:06 GMT <yreg> Guys I am experiencing a wierd behaviour

2017-07-31 17:45:38 GMT <yreg> it sounds like a nested transaction does not have the same context as parent transaction

2017-07-31 17:46:11 GMT <yreg> as in I create a new in a transaction, and I try to access it in a nested transaction but the second operation fails !

2017-07-31 17:51:09 GMT <douglascrp> yreg, I got some weird behaviours too, but it was because of something lik "context not initialized"

2017-07-31 17:51:13 GMT <douglascrp> something like that

2017-07-31 17:51:34 GMT <douglascrp> in that case, I had to get some info for the main transaction and replicate it internally

2017-07-31 17:51:42 GMT <douglascrp> I can't remember why and where though :D

2017-07-31 17:52:04 GMT <douglascrp> "context not set", I can't remember the exact message

2017-07-31 17:52:25 GMT <douglascrp> yreg, any error message?

2017-07-31 17:52:34 GMT <yreg> Not looking about that kind of context

2017-07-31 17:53:11 GMT <yreg> but I was expecting to have anything from parent transaction (even though commit did not happen yet) inside nested transaction!

2017-07-31 17:53:17 GMT <yreg> which is not the case

2017-07-31 17:54:08 GMT <douglascrp> Axel participated an interesting discussion on that in the community some weeks ago

2017-07-31 17:54:14 GMT <yreg> ~later tell AFaust is it normal in Alfresco not to have changes from a parent transaction visible inside a child transaction ?

2017-07-31 17:54:14 GMT <alfbot> yreg: The operation succeeded.

2017-07-31 17:54:17 GMT <douglascrp> I don't know if that could help

2017-07-31 17:54:27 GMT <yreg> will look it up thanks

2017-07-31 17:54:33 GMT <douglascrp> it was a long discussion btw

2017-07-31 17:54:50 GMT <douglascrp> do you want me to find it to you?

2017-07-31 17:55:18 GMT <yreg> if you can, that can be of great help

2017-07-31 17:55:34 GMT <douglascrp> ok, give me some minutes, and I will see if I can find it

2017-07-31 17:58:08 GMT <douglascrp> yreg, https://community.alfresco.com/message/815487-re-thread-safe-action-rules-for-massive-concurrency-mysql

2017-07-31 17:58:10 GMT <alfbot> Title: Thread/Transaction-safe action rules for massiv... | Alfresco Community (at community.alfresco.com)

2017-07-31 17:58:27 GMT <douglascrp> not sure if it is related with the problem you are facing

2017-07-31 17:59:10 GMT <douglascrp> this guy was facing problems trying to identify if a folder existed, but the node was created inside a second transaction, if I am not mistaken

2017-07-31 18:03:50 GMT <yreg> douglascrp, very instructive, thanks

2017-07-31 18:06:28 GMT <douglascrp> np

2017-07-31 18:06:50 GMT <douglascrp> one can write a book by collecting the information axel shares :D

2017-07-31 18:15:13 GMT <yreg> true

2017-07-31 18:15:20 GMT <yreg> well not really

2017-07-31 18:15:30 GMT <yreg> not just one book at least :P

2017-07-31 18:15:38 GMT <douglascrp> :D

2017-07-31 18:15:40 GMT <douglascrp> yes

2017-07-31 18:16:12 GMT <douglascrp> too much content to be understood

2017-07-31 18:24:23 GMT <douglascrp> ah, nice

2017-07-31 18:25:02 GMT <douglascrp> I was reading some docs, trying to understand how to let the user use my custom action, which is a custom "copy to" action, based on the document library's one

2017-07-31 18:25:15 GMT <douglascrp> through the search result actions button

2017-07-31 18:25:44 GMT <douglascrp> but I have just seem that the "copy to" action inside the search result is a brand new action, much probably created using aikau

2017-07-31 18:26:05 GMT <douglascrp> so, now, instead of "adding" my custom action, I will have to customize the aikau version too

2017-07-31 18:26:10 GMT <douglascrp> :(

2017-07-31 18:26:14 GMT <douglascrp> double work

2017-07-31 18:27:27 GMT <douglascrp> this is worst than I thought

2017-07-31 18:29:02 GMT <mmerlone> Hi, help! Trying to run alfresco under SSL on a ubuntu server, almost there, but I have this error: "Exception calling (GET) http://localhost/alfresco/s/api/admin/restrictions?guest=true"

2017-07-31 18:29:15 GMT <mmerlone> Following log: [ajp-apr-8009-exec-1] Error status 503 alfresco.a1.ind.bralfresco

2017-07-31 18:30:21 GMT <mmerlone> it obviously is missing a slash, should be alfresco.a1.ind.br/alfresco, but I cant find where should I correct this, can any kind soul help me?

2017-07-31 18:31:36 GMT <mmerlone> I already get the login screen under https, but auth fails related to this problem. It occurs even before any login atempt.

2017-07-31 18:52:08 GMT <douglascrp> if you are using apache, you will find lots of good docs

2017-07-31 18:52:16 GMT <douglascrp> http://www.keensoft.es/en/configuring-alfresco-ssl-by-using-lets-encrypt/

2017-07-31 18:52:17 GMT <alfbot> Title: Configuring Alfresco SSL by using Let's Encrypt - keensoft (at www.keensoft.es)

2017-07-31 18:52:29 GMT <douglascrp> https://www.appnovation.com/blog/running-alfresco-under-https-apache-2x

2017-07-31 18:52:30 GMT <alfbot> Title: Running Alfresco Under HTTPS (via Apache 2.x) | Appnovation (at www.appnovation.com)

2017-07-31 18:52:39 GMT <douglascrp> http://formtektips.blogspot.com.br/2017/05/alfresco-ssl-with-apache-proxy-server.html

2017-07-31 18:52:40 GMT <alfbot> Title: Technical Tips & Tricks: Alfresco SSL with Apache Proxy Server (at formtektips.blogspot.com.br)

2017-07-31 18:55:18 GMT <douglascrp> mmerlone, ^

2017-07-31 18:56:59 GMT <mmerlone> hi douglascrp, thanks for the links.

2017-07-31 18:58:00 GMT <mmerlone> Sorry to appear lazy, I was in hope one could pinpoint what conf file rules this URL assembly

2017-07-31 18:58:16 GMT <mmerlone> will RTFM the above docs meanwhile, tks a lot

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco