Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-08-24 06:36:39 GMT <twen> 'moring

2017-08-24 07:57:43 GMT <DarkStar1> Good morning a tous :)

2017-08-24 08:01:48 GMT <bmejias> hi DarkStar1

2017-08-24 08:02:18 GMT <yreg> Hoi everyone !

2017-08-24 08:10:13 GMT <yreg> Guys QQ: when are the metadata extractors called ? through behaviours ? transaction listeners ? direct calls from NodeService ?

2017-08-24 08:20:33 GMT <AFaust> yreg: An action that needs to be explicitly triggered

2017-08-24 08:20:45 GMT <AFaust> The upload web script that Share calls does this

2017-08-24 08:20:56 GMT <yreg> AFaust, thanks

2017-08-24 10:44:35 GMT <Loftux> https://loftux.com/en/blog/introducing-symbolic-linking-for-lxcommunity-ecm

2017-08-24 10:44:37 GMT <alfbot> Title: Introducing Symbolic Linking for LXCommunity ECM | Loftux (at loftux.com)

2017-08-24 10:47:08 GMT <angelborroy> Loftux from which release is available? 201702?

2017-08-24 10:47:26 GMT <Loftux> From our release LX100

2017-08-24 10:47:31 GMT <angelborroy> yep

2017-08-24 10:47:32 GMT <angelborroy> I know

2017-08-24 10:47:40 GMT <Loftux> But the source is in github

2017-08-24 10:48:09 GMT <angelborroy> but it can be installed on 201702?

2017-08-24 10:48:31 GMT <angelborroy> or 201707?

2017-08-24 10:48:45 GMT <angelborroy> just to tell my customers which are not using LX distribution

2017-08-24 10:50:21 GMT <Loftux> I guess you can backport. We did some changes to doclist.lib.js, item.lib.ftl, +more backend files to get this working.

2017-08-24 10:50:58 GMT <angelborroy> ok, so some tweak is required to port this addon to 5.2 line

2017-08-24 10:50:59 GMT <angelborroy> thanks

2017-08-24 10:52:06 GMT <Loftux> So it was just as easy to maintain as part of the LXCommunity ECM build rather than a separate amp, If I remember correctly it was a discussion here the other day on how to extend backend webscripts.

2017-08-24 10:52:36 GMT <Loftux> Yes it should run just fine, don't think you have to tweak much

2017-08-24 12:10:43 GMT <monica_> hello everyone.. can sombody help me with the uploader plus add-on's issue. I have three sites, uploader plus is working fine for two of them and for the third one, throws an exception and error pop up says "operation failure". uploader plus is working fine for the individual folders. but issue comes when we are applying this to the documentLibrary folder of a particular website.

2017-08-24 12:24:30 GMT <MTielemans> monica_, have you checked the Alfresco logs?

2017-08-24 12:25:50 GMT <monica_> YES.. I can show you the exception

2017-08-24 12:26:40 GMT <MTielemans> maybe you can upload it to pastebin or something similar

2017-08-24 12:28:40 GMT <monica_> yes.. I have posted there. but no result found

2017-08-24 12:29:50 GMT <MTielemans> link

2017-08-24 12:29:51 GMT <MTielemans> ?

2017-08-24 12:30:24 GMT <monica_> https://github.com/softwareloop/uploader-plus/issues/122

2017-08-24 12:30:25 GMT <alfbot> Title: uploading issue - operation failure popup. · Issue #122 · softwareloop/uploader-plus · GitHub (at github.com)

2017-08-24 12:34:14 GMT <yreg> MTielemans, in case you like to follow up on tyhat one, I am suspecting that for some reason, either the noderef is being changed by some aspect or there is a permission issue making the nodeservice security interceptor return null

2017-08-24 12:35:12 GMT <yreg> monica_, I doubt if anyone can help you without debugging on your server to know what's wrong

2017-08-24 12:36:00 GMT <yreg> I already tried to point some obvious possibilities but could not go further with my analysis, sorry !

2017-08-24 12:37:18 GMT <yreg> fcorti, could you point me to share source code ?

2017-08-24 12:37:56 GMT <yreg> would this be it https://svn.alfresco.com/repos/alfresco-open-mirror/web-apps/Share/trunk/

2017-08-24 12:37:58 GMT <alfbot> Title: alfresco-open-mirror - Revision 138046: /web-apps/Share/trunk (at svn.alfresco.com)

2017-08-24 12:38:11 GMT <yreg> I mean up to date

2017-08-24 12:40:18 GMT <DarkStar1> monica_: https://github.com/softwareloop/uploader-plus/issues/122#issuecomment-324609271 according to that reply there's something wrong with the node properties of that node. Have you inspected and compared the node's properties against a working node to try and identify what could be wrong?

2017-08-24 12:40:19 GMT <alfbot> Title: uploading issue - operation failure popup. · Issue #122 · softwareloop/uploader-plus · GitHub (at github.com)

2017-08-24 12:40:38 GMT <DarkStar1> Using the node browser in alfresco of course

2017-08-24 12:40:57 GMT <fcorti> yreg: this is the correct link

2017-08-24 12:41:09 GMT <yreg> thanks

2017-08-24 12:41:15 GMT <fcorti> no prob

2017-08-24 12:50:38 GMT <douglascrp> morning everyone

2017-08-24 13:00:11 GMT <monica_> DarkStarl, how to do it ?

2017-08-24 13:00:51 GMT <MTielemans> monica_, you could try just editting the node's name and saving it, see if that fixes it. Just a thought.

2017-08-24 13:01:04 GMT <MTielemans> It might correct any problematic state the node is currently in

2017-08-24 13:01:54 GMT <monica_> MTielemans, does it mean that I have to change the node name, which was default ?

2017-08-24 13:02:13 GMT <DarkSta__> Morning douglascrp

2017-08-24 13:02:45 GMT <MTielemans> yeah it's something you can try to see if that corrects the situation

2017-08-24 13:03:14 GMT <DarkSta__> monica_: https://duckduckgo.com/?q=using+alfresco+nodebrowser&atb=v63-1__&iax=1&ia=videos&iai=_H9K5pdDM7A

2017-08-24 13:03:15 GMT <alfbot> Title: using alfresco nodebrowser at DuckDuckGo (at duckduckgo.com)

2017-08-24 13:03:28 GMT <monica_> okay, I am trying this.. thank you.. hope it work

2017-08-24 13:04:27 GMT *** DarkSta__ is now known as DarkStar1

2017-08-24 13:05:25 GMT <fcorti> Ehi guys, it's only me having problems on reaching community.alfresco.com or others in the chat are experiencing delays or denial of services.

2017-08-24 13:05:39 GMT <fcorti> For Kristen in the US everything works fine

2017-08-24 13:05:53 GMT <fcorti> For me... simply it doesn't work.

2017-08-24 13:06:17 GMT <DarkStar1> monica_: It won't fix anything. I'm asking you to use it to compare the node properties between the node that you have a problem with, and one (or two) nodes that are fine.

2017-08-24 13:06:17 GMT <fcorti> Trump isolated Italy only or all the Europe? (joke)

2017-08-24 13:07:00 GMT <DarkStar1> monica_: Perhaps it might help you identify the problem and we can then help you resolve it thereafter

2017-08-24 13:08:07 GMT <DarkStar1> fcorti: Looks like it's only italy :)

2017-08-24 13:08:38 GMT <fcorti> DarkStar1, ok, better than all the Europe. :-)

2017-08-24 13:10:08 GMT <DarkStar1> fcorti: You're welcomed. You could try VPN if it's urgent.

2017-08-24 13:10:56 GMT <fcorti> no urgency, thank you, just curious to understand why and measure how big (or small) is the problem

2017-08-24 13:14:53 GMT <douglascrp> fcorti, it is ok in Brazil too

2017-08-24 13:15:19 GMT <fcorti> I like the world wide check! :-)

2017-08-24 13:16:20 GMT <tfdsimoes> fcorti: spain is ok

2017-08-24 13:16:44 GMT <fcorti> thaks tfdsimoes!

2017-08-24 13:16:51 GMT <monica_> the node on which I am trying to apply the uploader plus is a document libraray node

2017-08-24 13:16:59 GMT <monica_> of a site test

2017-08-24 13:17:06 GMT <monica_> which is created by alfresco

2017-08-24 13:17:36 GMT <monica_> and there is no change done to that node

2017-08-24 13:18:19 GMT <douglascrp> monica_, have you tried to remove the uploader-plus configuration for that folder and then tried to put it back?

2017-08-24 13:18:32 GMT <monica_> yes

2017-08-24 13:18:37 GMT <monica_> many times :)

2017-08-24 17:16:17 GMT <mbui> Can you OOTB add tags to workflow tasks, i.e. in "My Tasks" you can add tags to your tasks and filter on tags. Like in the doc library.

2017-08-24 17:54:04 GMT <resplin> mbui: Not out of the box

2017-08-24 17:57:11 GMT <mbui> resplin: Would one have to implement the entire tagging system for workflow tasks to get that working?

2017-08-24 18:17:21 GMT <resplin> I'm not sure. But it isn't in the UI.

2017-08-24 18:17:42 GMT <resplin> I don't think the repo has the concept of a workflow that has a tag.

2017-08-24 20:56:38 GMT <fwu> hi!

2017-08-24 20:57:50 GMT <fwu> ppl, im strugling with a new wf deployed into Alfresco 5.2. Althought the wf was created in 4.2.f, I rebuild it ans still it doesnt work. I get the message that the workflow cant strat, but nothing is writen in the log!

2017-08-24 20:58:04 GMT <fwu> is there any strange issue with workflows in 5.2?

2017-08-24 20:58:51 GMT <fwu> im deleting object by object. I only have now a start object, an user task and an end object. Still, it doesnt works!

2017-08-24 23:19:21 GMT <fwu> strange, it seems the problem is with this: task.setVariableLocal

2017-08-24 23:19:32 GMT <fwu> I never see it, but it seems it works in 4.2.f

2017-08-24 23:19:37 GMT <fwu> but not in 5.2

2017-08-24 23:20:20 GMT <fwu> worst than that, I get a cannot start workflow and an error 500 in fiddler without further description.

2017-08-24 23:24:36 GMT <fwu> the workflow will not start even if I call this method in any task different than the start event. So I believe all the inline javascript code is parsed when the workdlow tries to start. Is this true?

2017-08-24 23:36:54 GMT <fwu> it seems there are other script problems throwing the same error... so any error I will get in my workflows will throw me a generic erros like this?

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco