Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2017-12-05 01:35:40 GMT <asd> hello

2017-12-05 01:35:57 GMT <asd> activiti?

2017-12-05 07:16:27 GMT <rusin> hi all

2017-12-05 07:16:57 GMT <rusin> how can i get full url link through javascript

2017-12-05 07:17:52 GMT <rusin> like http://xx.x.x.xx:8080/share/page/edit-metadata?nodeRef=workspace://SpacesStore/d6f33d29-bd2d-4669-b1e0-aa98d9f97de9

2017-12-05 07:48:38 GMT <twen> hello

2017-12-05 07:57:56 GMT <Tichodroma> rusin: which part of this URL do you have problems with when you try to build it?

2017-12-05 07:58:51 GMT <yreg> Morning

2017-12-05 08:21:11 GMT <rusin> <Tichodroma> I'm trying to get full path of download the document

2017-12-05 08:22:53 GMT <rusin> but document.url is gives "/d/d/workspace/SpacesStore/d6f33d29-bd2d-4669-b1e0-aa98d9f97de9/VVHTML5ReleaseNotes%204.8.pdf"

2017-12-05 08:39:30 GMT <Tichodroma> rusin: where do you use document.url? In a repository JavaScript?

2017-12-05 08:41:28 GMT <rusin> I am using this in webscript like search.findNode

2017-12-05 10:14:41 GMT <AFaust> ~later tell resplin: It is so funny that now you are starting to use my old email address when it has been going so well for the year before when I already had left the old employer...

2017-12-05 10:14:41 GMT <alfbot> AFaust: The operation succeeded.

2017-12-05 10:32:29 GMT <CptLuxx> did.. someone read my problem? :3

2017-12-05 10:36:04 GMT <angelborroy> CptLuxx you can always upgrade to 4.2.d

2017-12-05 10:36:22 GMT <CptLuxx> right

2017-12-05 10:36:24 GMT <CptLuxx> but...

2017-12-05 10:36:39 GMT <CptLuxx> the dude before me made hundred of modification :/

2017-12-05 10:36:45 GMT <CptLuxx> s

2017-12-05 10:37:04 GMT <angelborroy> then I bet that this problem is produced due to that modifications…

2017-12-05 10:37:09 GMT <CptLuxx> there are so many files changed... would take me days to reproduce it

2017-12-05 10:37:38 GMT <CptLuxx> there is even a self made freemind integration

2017-12-05 10:38:51 GMT <angelborroy> There are no more alternatives

2017-12-05 10:39:06 GMT <angelborroy> You have to apply the patch or to identify which is the real problem

2017-12-05 10:39:56 GMT <CptLuxx> yeah sucks

2017-12-05 10:40:10 GMT <CptLuxx> i even test a migration to 5.2 that works but the modifications are pita..

2017-12-05 11:13:07 GMT <Atg_> Hello

2017-12-05 11:14:32 GMT <Atg_> I have set-up a custom model w/ 1 type and some aspect, of which i have added some properties. I've configured search facets to show these properties, however while some display correctly some others display "undefinedxxx" instead of the possible values

2017-12-05 11:14:48 GMT <Atg_> where xxxx is a property value cut short

2017-12-05 11:14:58 GMT <Atg_> is anyone familiar with this problem/bug?

2017-12-05 11:15:07 GMT <Atg_> i'm guessing it is solr-related

2017-12-05 11:18:53 GMT <angelborroy> Atg_ I haven’t heard before about that

2017-12-05 11:19:04 GMT <angelborroy> But you can try declaring your property as facetable

2017-12-05 11:19:05 GMT <angelborroy> https://docs.alfresco.com/community/concepts/search-fts-config.html

2017-12-05 11:19:06 GMT <alfbot> Title: Full text search configuration properties for Solr index | Alfresco Documentation (at docs.alfresco.com)

2017-12-05 11:19:16 GMT <angelborroy> It shall require re-indexing

2017-12-05 11:21:13 GMT <Atg_> Do i just delete all indexes and reboot?

2017-12-05 11:21:37 GMT <angelborroy> yep

2017-12-05 11:23:53 GMT <Atg_> Thanks a bunch

2017-12-05 11:31:27 GMT <Atg_> Full reindex solved the problem :)

2017-12-05 12:24:23 GMT <Loftux1> https://www.youtube.com/watch?v=pweywYeP8ZA&t=229s

2017-12-05 12:25:39 GMT <Loftux1> Shows some of the latest features of ShareBox, and Symbolic Linkning (publicly available in our Alfresco Custom build)

2017-12-05 12:26:42 GMT <Loftux1> Was a time stamp in the link new link https://www.youtube.com/watch?v=pweywYeP8ZA

2017-12-05 12:49:44 GMT <MorganP> Sounds interesting

2017-12-05 12:49:55 GMT <MorganP> How would you do that without Share? ^^

2017-12-05 12:50:37 GMT <MorganP> just kidding, that will be a discussion for the devcon

2017-12-05 15:28:09 GMT <angelborroy> I have a problem with iOS Mobile web app

2017-12-05 15:28:20 GMT <angelborroy> Not connecting to an SSL Casified server

2017-12-05 15:28:36 GMT <angelborroy> It fails “testing connection to server"

2017-12-05 15:28:45 GMT <angelborroy> But I don’t know how to debug it

2017-12-05 15:29:08 GMT <yreg> angelborroy, a client of mine complained about iOS app not being able to connect again after an update

2017-12-05 15:29:08 GMT <angelborroy> I guess that the problem is an Apache redirecting from “server/“ to “server/share”

2017-12-05 15:29:20 GMT <yreg> but they don't have any SSO

2017-12-05 15:29:20 GMT <angelborroy> really

2017-12-05 15:29:31 GMT <angelborroy> Yep, probably it’s not related with SSO

2017-12-05 15:29:40 GMT <angelborroy> I’m going to test it from Android

2017-12-05 15:30:02 GMT <yreg> FYI my client experienced this on their IPad

2017-12-05 15:30:12 GMT <angelborroy> I’m using an iPhone

2017-12-05 15:30:17 GMT <angelborroy> But the code is the same

2017-12-05 15:30:42 GMT <angelborroy> I’m trying to configure the project in XCode

2017-12-05 15:30:47 GMT <angelborroy> but it’s too hard for me :D

2017-12-05 15:33:27 GMT <angelborroy> Probably some “dummy instructions” will be required for GitHub iOS project

2017-12-05 15:33:40 GMT <angelborroy> Or probably for someone with experience in XCode is trivial

2017-12-05 15:39:42 GMT <bhagyas> angelborroy: You can use the Xcode debugger to debug

2017-12-05 15:40:02 GMT <angelborroy> Thanks bhagyas but there are some “profiles” that I don’t have

2017-12-05 15:40:25 GMT <angelborroy> So I cannot start that option (I guess)

2017-12-05 15:40:35 GMT <angelborroy> I just want to know with URL is failing

2017-12-05 15:40:48 GMT <bhagyas> angelborroy: I submitted a script that does all this setups automatically for anyone getting started, but they rejected the pull request. since then I stopped giving a duck about Alfresco iOS contributions

2017-12-05 15:41:01 GMT <bhagyas> :)

2017-12-05 15:41:09 GMT <angelborroy> and is it public?

2017-12-05 15:41:16 GMT <bhagyas> you would have to have cocoapods installed

2017-12-05 15:41:28 GMT <bhagyas> and run 'pod install' to install the dependencies, its like maven deps

2017-12-05 15:41:32 GMT <bhagyas> It might be

2017-12-05 15:41:59 GMT <angelborroy> interesting

2017-12-05 15:41:59 GMT <angelborroy> I’m going to try

2017-12-05 15:43:02 GMT <bhagyas> Found it

2017-12-05 15:43:02 GMT <bhagyas> https://github.com/loftuxab/alfresco-ios-app/commit/67897e1e02ab7415cdfc234e7d6b5c6efe10281a

2017-12-05 15:43:04 GMT <alfbot> Title: Adding a project setup bash script. · loftuxab/alfresco-ios-app@67897e1 · GitHub (at github.com)

2017-12-05 15:43:09 GMT <bhagyas> Just send them a middle finger when you can

2017-12-05 15:43:54 GMT <bhagyas> it seems they don't care about anyone trying to compile it by themselves

2017-12-05 15:44:18 GMT <angelborroy> Yep, I saw that

2017-12-05 15:44:28 GMT <angelborroy> Ok, installing “pods”

2017-12-05 15:45:36 GMT <IanW1> angelborroy: I think I debugged this by looking at the Apache logs, assuming behind a proxy, IIRC I had to add various endpoints not in the documented apache config

2017-12-05 15:45:51 GMT <angelborroy> I tested your CAS repo addon without luck

2017-12-05 15:46:11 GMT <angelborroy> but you are referring also Apache HTTPd endpoints, right?

2017-12-05 15:46:31 GMT <bhagyas> angelborroy: We sorted that issue long time ago, Loftux knows more in detail

2017-12-05 15:46:50 GMT <angelborroy> so everyone knows about it but me?

2017-12-05 15:46:52 GMT <angelborroy> :)

2017-12-05 15:47:02 GMT <yreg> angelborroy, where do you get stuck when you try connection diagnostic

2017-12-05 15:47:03 GMT <yreg> ?

2017-12-05 15:47:07 GMT <angelborroy> yep

2017-12-05 15:47:08 GMT <Loftux1> in web.xml

2017-12-05 15:47:09 GMT <Loftux1> <!-- Loftux -Comment out to enable ios app ALF-21521

2017-12-05 15:47:10 GMT <Loftux1> <filter-mapping>

2017-12-05 15:47:10 GMT <Loftux1> <filter-name>Global Authentication Filter</filter-name>

2017-12-05 15:47:10 GMT <Loftux1> <url-pattern>/api/*</url-pattern>

2017-12-05 15:47:10 GMT <Loftux1> </filter-mapping>

2017-12-05 15:47:11 GMT <Loftux1> -->

2017-12-05 15:47:20 GMT <angelborroy> I tried also that Lofutx1

2017-12-05 15:47:57 GMT <angelborroy> In fact: https://github.com/keensoft/alf-21757-repo

2017-12-05 15:47:58 GMT <alfbot> Title: GitHub - keensoft/alf-21757-repo: Patch to ALF-21757 and ALF-21521 (at github.com)

2017-12-05 15:48:59 GMT <angelborroy> IanW1 are you referring to that “header unset” configuration?

2017-12-05 15:49:08 GMT <angelborroy> IanW1 I haven’t tested this yet

2017-12-05 15:50:39 GMT <IanW1> angelborroy: No, although that's quite important!, I think it was trying to use endpoints that weren't documented - it showed up pretty easily - it's a good way to see what's going on

2017-12-05 15:55:33 GMT <angelborroy> bhagyas you are my hero

2017-12-05 15:55:52 GMT <angelborroy> iOs App up & running

2017-12-05 15:58:45 GMT <yreg> angelborroy, I checked with our system team

2017-12-05 15:59:03 GMT <yreg> and they say that there is some parameter missing in server.xml or something

2017-12-05 15:59:16 GMT <angelborroy> probably the “proxyName”?

2017-12-05 16:00:12 GMT <angelborroy> let me try

2017-12-05 16:00:21 GMT <yreg> angelborroy, yes along with scheme and proxyPort

2017-12-05 16:00:28 GMT <angelborroy> yep, I knew that

2017-12-05 16:00:34 GMT <angelborroy> let me check if it’s configured

2017-12-05 16:01:27 GMT <yreg> angelborroy, also check if alf-global is configured correctly for alfresco.hot/alfresco.port/alfresco.protol

2017-12-05 16:10:27 GMT <angelborroy> yreg also no luck

2017-12-05 16:11:46 GMT <angelborroy> iOS is trying to access GET https://server:443/alfresco/service/api/server

2017-12-05 16:12:18 GMT <angelborroy> I can access that URL from browser, but iOS APP complains about it

2017-12-05 16:13:03 GMT <yreg> that URL should not even require login

2017-12-05 16:13:27 GMT <angelborroy> yep

2017-12-05 16:13:32 GMT <angelborroy> it does not require login

2017-12-05 16:13:49 GMT <angelborroy> nw_proxy_resolver_create_parsed_array PAC evaluation error: NSURLErrorDomain: -1003

2017-12-05 16:14:53 GMT <MorganP> with IP?

2017-12-05 16:15:01 GMT <angelborroy> let me try

2017-12-05 16:15:14 GMT <MorganP> Some month ago, I had an issue with the dns name

2017-12-05 16:15:25 GMT <MorganP> it was working with the IP but it got resolved afterwards

2017-12-05 16:16:18 GMT <angelborroy> hehe

2017-12-05 16:16:26 GMT <angelborroy> “The certificate for this server is invalid"

2017-12-05 16:16:44 GMT <angelborroy> Apple is incredible

2017-12-05 16:17:05 GMT <angelborroy> You might be connecting to a server that is pretending to be “NN.NN.NN.NN” which could put your confidential information at risk.

2017-12-05 16:17:21 GMT <angelborroy> They are like my father, but I have to pay them

2017-12-05 16:17:38 GMT <yreg> ah yes , itdoes not work with self signed / invalid certificates

2017-12-05 16:18:12 GMT <angelborroy> this is trusted

2017-12-05 16:18:29 GMT <angelborroy> but if I try to use the IP, then it’s not

2017-12-05 16:18:42 GMT <angelborroy> as it’s issued for a different name

2017-12-05 16:22:17 GMT <angelborroy> Probably I’m wrong but

2017-12-05 16:22:18 GMT <angelborroy> NSURLErrorDomain: -1003

2017-12-05 16:22:30 GMT <angelborroy> Means that the program cannot find the server

2017-12-05 16:25:34 GMT <yreg> angelborroy, try setting the hostname in /etc/hosts and use that insead of the IP

2017-12-05 16:25:53 GMT <angelborroy> why?

2017-12-05 16:26:26 GMT <angelborroy> I’m resolving the hostname from browser in the Simulator and in my Mac

2017-12-05 16:30:07 GMT <angelborroy> if I skip the Apache I can authenticate and even connect

2017-12-05 16:30:27 GMT <angelborroy> but Root folder retrieval failed

2017-12-05 16:30:50 GMT <angelborroy> So I have two different problems

2017-12-05 16:31:43 GMT <angelborroy> interesting

2017-12-05 16:31:56 GMT <angelborroy> it’s using CMIS ATOM 1.0 with the “public” URL

2017-12-05 16:32:47 GMT <angelborroy> And again the browser is solving the URL but not the app

2017-12-05 16:38:27 GMT <angelborroy> My conclusion: is something related with mod_jk configuration

2017-12-05 16:38:33 GMT <angelborroy> Which is out of my scope (by now)

2017-12-05 16:42:27 GMT <angelborroy> thanks all for your information

2017-12-05 20:02:30 GMT <CptLuxx> okay another question.. i checked my test 5.2 migration

2017-12-05 20:02:37 GMT <CptLuxx> how can i remove the following thing from all users?

2017-12-05 20:08:24 GMT <CptLuxx> https://www.dropbox.com/s/nqnzmprst1dd79q/TeamViewer_2017-12-05_21-07-15.png?dl=0

2017-12-05 20:08:25 GMT <alfbot> Title: Dropbox - TeamViewer_2017-12-05_21-07-15.png (at www.dropbox.com)

2017-12-05 20:08:31 GMT <CptLuxx> im to stupid to find something on the alfresco website :3

2017-12-05 20:30:09 GMT <CptLuxx> nvm

2017-12-05 20:30:19 GMT <CptLuxx> found the orginal customization

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco