Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2018-07-02 06:11:59 GMT <alfresco-discord> <twen> 'morning

2018-07-02 06:41:14 GMT <sumit> Hi All, NodeServicePolicies.OnCreateNodePolicy triggers on uploading a new version also of the doc? What policy to use after first time upload of any noderef?

2018-07-02 06:42:07 GMT <sumit> Not on upload new version

2018-07-02 06:43:25 GMT <sumit> There is no anything like AfterCreateNodePolicy...

2018-07-02 09:41:50 GMT <Mark______> Hello, I've set up a replication job to replicate Sites from server A to B, this all looks successful but the sites don't seem to be available in server B though they are in the Repository, is there something I'm missing or is this expected behavior?

2018-07-02 11:03:09 GMT *** john_ is now known as Guest70591

2018-07-02 11:05:43 GMT <Guest70591> hi i created workflow alfresco procees service i have access that workflow with ADF it working fine.In APS Audit log option is there but not there in ADF how can create Audit Log in ADF

2018-07-02 12:29:51 GMT <AFaust> Mark______ Replicating the nodes of a Site alone is not sufficient to make it accessible on another Alfresco server. You only need to deal with the associated site groups and the Surf config XML persisted in the Repository. Those latter two are hard to achieve via the Replication feature as it would require selecting nodes from global contexts based on semantic naming conventions

2018-07-02 12:31:20 GMT <AFaust> So replicating entire sites is not supported at all, only sub-structures of individual sites. This is i.e. what Alfresco had done for the Alfresco Summit conferences where parts of the site (the published presentations) where replicated to the location where the actual web page would pick it up...

2018-07-02 15:41:58 GMT <alfresco-discord> <THpubs> @DenysVuika I just tried to upload a file using the rest api

2018-07-02 15:42:05 GMT <alfresco-discord> <THpubs> But it gives me a 404 error

2018-07-02 15:42:18 GMT <alfresco-discord> <THpubs> Here's the code I used: https://gist.github.com/THPubs/301f17b03c333370e7c48b3646084f6e

2018-07-02 15:42:19 GMT <alfbot> Title:alfresco-upload ยท GitHub (at gist.github.com)

2018-07-02 15:42:25 GMT <alfresco-discord> <THpubs> Any idea what's happening?

2018-07-02 15:44:26 GMT <alfresco-discord> <DenysVuika> Maybe incomplete address? the api is located under: /alfresco/api/-default-/public/alfresco/versions/1

2018-07-02 15:45:45 GMT <alfresco-discord> <DenysVuika> There's an example request in the api docs, curl -utest:test -X POST host:port/alfresco/api/-default-/public/alfresco/versions/1/nodes/-my-/children -F filedata=@test.txt

2018-07-02 15:46:43 GMT <alfresco-discord> <THpubs> Ah that's the problem!

2018-07-02 15:46:56 GMT <alfresco-discord> <THpubs> but now it gives a 400 error

2018-07-02 15:47:14 GMT <alfresco-discord> <THpubs> I use the login ticket to login the user

2018-07-02 15:47:40 GMT <alfresco-discord> <THpubs> login the user in the front end, pass the ticket to the back end and use that... is that the problem?

2018-07-02 15:49:14 GMT <alfresco-discord> <THpubs> curls gives me 401

2018-07-02 15:49:15 GMT <alfresco-discord> <THpubs> Authentication failed for Web Script org/alfresco/api/ResourceWebScript.post

2018-07-02 15:49:30 GMT <alfresco-discord> <THpubs> without the login ticket

2018-07-02 15:49:32 GMT <alfresco-discord> <THpubs> wait...

2018-07-02 15:51:35 GMT *** DragiBus_ is now known as DragiBus

2018-07-02 15:52:21 GMT <alfresco-discord> <THpubs> curl works with the login ticket.....

2018-07-02 15:52:27 GMT <alfresco-discord> <THpubs> axios fails.... hmmm

2018-07-02 15:56:41 GMT <alfresco-discord> <THpubs> axios gives 400....

2018-07-02 15:56:49 GMT <alfresco-discord> <THpubs> any idea why?

2018-07-02 16:03:03 GMT <alfresco-discord> <THpubs> just updated the gist ๐Ÿ˜ƒ

2018-07-02 16:22:14 GMT <alfresco-discord> <binduwavell> @Francesco Corti thanks for the invite

2018-07-02 16:22:35 GMT <alfresco-discord> <Francesco Corti> Welcome @binduwavell ๐Ÿ˜ƒ

2018-07-02 18:27:56 GMT <alfresco-discord> <DenysVuika> @THpubs try with the native auth params at first maybe https://github.com/axios/axios#request-config

2018-07-02 18:27:57 GMT <alfbot> Title:GitHub - axios/axios: Promise based HTTP client for the browser and node.js (at github.com)

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco