Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2019-03-22 05:21:41 GMT <alfresco-discord> <sumit> Hi AFaust, As you had mentioned "https://github.com/Acosix/alfresco-audit#incremental-cleanup-of-alf_prop_-tables" to clenup alf_prop* tables. So this can cleanup unnecessary rows from "alf_prop_link" table and reduce my huge table size 72 GB. any other impacts of this module if i run this directly on prod instance of having large contentstore?

2019-03-22 05:21:42 GMT <alfbot> Title:GitHub - Acosix/alfresco-audit: Addon to add audit-related utilities and/or common definitions (at github.com)

2019-03-22 05:23:40 GMT <alfresco-discord> <sumit> In my case as I need to reduce the "alf_prop_link" table size, Can I move to use this?

2019-03-22 09:00:12 GMT <AFaust> sumit: Of course you should test that addon / module first in your test environment before putting it into production.

2019-03-22 09:00:35 GMT <AFaust> But I have been running the same functionality at an Enterprise customer in production for the last ~2 years already.

2019-03-22 09:00:44 GMT <AFaust> So I don't expect any issues...

2019-03-22 09:53:24 GMT <alfresco-discord> <sumit> Ok AFaust. I have installed "de.acosix.alfresco.utility.repo" and "de.acosix.alfresco.audit.repo" for this. On alfresco restart I am getting below error:

2019-03-22 09:54:31 GMT <alfresco-discord> <sumit> Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'acosix-audit-ConsolidateActiveUsersAuditJobTrigger' defined in class path resource [alfresco/module/acosix-audit/context/job-context.xml]: Invocation of init method failed; nested exception is java.text.ParseException: Support for specifying both a day-of-week AND a day-of-month

2019-03-22 09:54:31 GMT <alfresco-discord> parameter is not implemented.

2019-03-22 09:55:02 GMT <alfresco-discord> <sumit> ----------

2019-03-22 09:55:34 GMT <alfresco-discord> <sumit> Caused by: java.text.ParseException: Support for specifying both a day-of-week AND a day-of-month parameter is not implemented

2019-03-22 10:34:17 GMT <alfresco-discord> <sumit> Can you plz help me on this?

2019-03-22 11:00:48 GMT <alfresco-discord> <Thijs> I guess your cronjob expression wrong

2019-03-22 11:18:32 GMT <fwu2018> hello all

2019-03-22 11:25:40 GMT <fwu2018> afaust, did you haver connected office 365 client with Alfresco using webdav? I have webdav using 2013 and 2016. But with office 365 I get 401 in a author.dll url in an unlimited way... office hangs do to this.

2019-03-22 11:26:00 GMT <fwu2018> sorry... ever

2019-03-22 11:43:40 GMT <fwu2018> hmm.. the difference is that word 2013 and 2016 gets a 401 in the same url and then on the next call the authentication is sent. In word 365 word gets a 401 and continues making calls without authentication... in unlimited calls

2019-03-22 12:04:50 GMT <alfresco-discord> <digcat> hi @fwu2018 we just tried that against 6.0.7-ga, are you using any special authentication? we seeing it work as expected ?

2019-03-22 12:06:40 GMT <alfresco-discord> <digcat> have you got the aos setting in alfresco-global.properties ? aos.baseUrlOverwrite=

2019-03-22 12:07:52 GMT <alfresco-discord> <digcat> were mounting the webdav volume using webdrive, rather than the OS native, not sure if any other differences

2019-03-22 12:12:10 GMT <fwu2018> digcat webdav is working for office 2013 and 2016

2019-03-22 12:12:21 GMT <fwu2018> so Alfresco is well configured

2019-03-22 12:12:50 GMT <alfresco-discord> <digcat> yes, i believe you, im just saying we just test word 365, and its working for us

2019-03-22 12:12:52 GMT <fwu2018> this really seems a problem with Office 365/Windows 10

2019-03-22 12:13:01 GMT <alfresco-discord> <digcat> yes

2019-03-22 12:13:09 GMT <alfresco-discord> <digcat> webdrive is the difference in our setup

2019-03-22 12:13:10 GMT <fwu2018> well that is a good feedback

2019-03-22 12:13:23 GMT <alfresco-discord> <digcat> https://webdrive.com/

2019-03-22 12:13:24 GMT <alfbot> Title:WebDrive WebDAV Client that Maps Network Drives to S3, OneDrive, SFTP (at webdrive.com)

2019-03-22 12:13:26 GMT <fwu2018> not only... maybe there is some additional addins or configuration

2019-03-22 12:13:35 GMT <alfresco-discord> <digcat> yes, perhaps

2019-03-22 12:14:12 GMT <fwu2018> we are using office connected to the cloud, maybe it has some restrictions... the strange is that it doesnt work exactly when trying to get a dll

2019-03-22 12:14:25 GMT <fwu2018> from _vti

2019-03-22 12:14:37 GMT *** onu_ is now known as onu

2019-03-22 12:17:37 GMT <fwu2018> why are you using webdrive? for securityreasons?

2019-03-22 12:19:19 GMT <AFaust> Ok... after a very long web / remote setup session this morning, I can finally check the messages people sent me here...

2019-03-22 12:21:00 GMT <AFaust> Office is always crap and basically a gamble if it works or not. I have two customers with Office 365, and it "generally" works, but some users / clients have intermittent issues, including some 401 on author.dll because the stupid Office client "forgets" to send the already established session ID

2019-03-22 12:21:43 GMT <alfresco-discord> <digcat> we use webdrive performance/reliability

2019-03-22 12:22:03 GMT <AFaust> sumit: Well, one option for help is to create an issue in that GitHub project and include your log files.

2019-03-22 12:23:13 GMT <AFaust> My addon does not have a cron which tries to set both day-of-week and day-of-month, so I bet you have made some configurations / customisations of your own...

2019-03-22 13:42:35 GMT <xkahn> Hey all. We've noticed that scheduled actions that call web scripts have 60 seconds to complete before they are killed.

2019-03-22 13:43:09 GMT <xkahn> Is there a way to extend that? We have some actions that might end up sending out 1,000 custom emails after doing a bunch of housekeeping.

2019-03-22 14:49:03 GMT <fwu2018> afaust, that problem with some office 365 customers with 401 error maybe the same I have. How did you solved it?

2019-03-22 14:49:23 GMT <fwu2018> I realize word never send authentication... so it is not only sometimes

2019-03-22 14:49:37 GMT <AFaust> In some cases we didn't solve it because the fault is with Office and there is no way to fix it on the Alfresco side.

2019-03-22 14:49:40 GMT <fwu2018> at least based on my domain of tests

2019-03-22 14:50:04 GMT <AFaust> Once customer is trying to encourage more of their users to switch to LibreOffice instead.

2019-03-22 14:50:17 GMT <fwu2018> and in that case you also got an inifinit loop of 401?

2019-03-22 14:50:59 GMT <fwu2018> because not sending authnetication is not good; but trying in an infiinit loop is another problem.

2019-03-22 14:51:08 GMT <fwu2018> I have both

2019-03-22 14:51:36 GMT <fwu2018> and if some office 365 clients work, then this a configuration issue somewhere

2019-03-22 14:51:56 GMT <fwu2018> maybe I will try to raise an issue at Microsoft

2019-03-22 15:33:53 GMT <alfresco-discord> <sumit> Thanks Thijs and AFaust. Yes, I have customized the cron expressions. I will work on that. Thank you.

2019-03-22 21:38:34 GMT <alfresco-discord> <BuRn> We're using alfresco docker-compose, and I'm trying to support another developer's stuff, as he's about to go on leave. He's got some AMPs that generate alfresco content (very large amounts of it). He's not using any libreoffice features, but as the load goes on the alfresco container finally exits with this error, resulting in the load stopping... 22-Mar-2019 02:01:59.721 SEVERE

2019-03-22 21:38:35 GMT <alfresco-discord> [OfficeProcessThread-0] org.artofsolving.jodconverter.office.ManagedOfficeProcess$5.run could not restart process org.artofsolving.jodconverter.office.OfficeException: could not establish connection at org.artofsolving.jodconverter.office.ManagedOfficeProcess.doStartProcessAndConnect(ManagedOfficeProcess.java:141) at

2019-03-22 21:38:35 GMT <alfresco-discord> org.artofsolving.jodconverter.office.ManagedOfficeProcess.access$000(ManagedOfficeProcess.java:29) at org.artofsolving.jodconverter.office.ManagedOfficeProcess$5.run(ManagedOfficeProcess.java:108) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at

2019-03-22 21:38:36 GMT <alfresco-discord> java.base/java.lang.Thread.run(Thread.java:834) Caused by: org.artofsolving.jodconverter.office.OfficeException: office process died with exit code 137 at org.artofsolving.jodconverter.office.ManagedOfficeProcess$6.attempt(ManagedOfficeProcess.java:135) at org.artofsolving.jodconverter.office.Retryable.execute(Retryable.java:34) at

2019-03-22 21:38:36 GMT <alfresco-discord> org.artofsolving.jodconverter.office.Retryable.execute(Retryable.java:24) at org.artofsolving.jodconverter.office.ManagedOfficeProcess.doStartProcessAndConnect(ManagedOfficeProcess.java:139) ... 5 more Any ideas on where to start with this?

2019-03-22 21:39:49 GMT <alfresco-discord> <BuRn> Is it normal for a bot to tell me not to post the same stuff over and over again when I post something for the first time?

2019-03-22 21:40:58 GMT <alfresco-discord> <BuRn> Oh, I think I get it, it's an IRC bot, and it just saw my post as a multi-line post. I viewed IRC after posting in discord, and yeah, multi-line.

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco