Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2019-04-12 00:17:05 GMT <alfresco-discord> <douglascrp> ok... thank you

2019-04-12 07:09:08 GMT <alfresco-discord> <Nyddhog> Hi everybody. Anyone knows if there is an association (peer2peer? parentchild?) between the email and the attachments from that email? For emails uploaded into Alfresco from Outlook or email inbound or ...

2019-04-12 07:30:19 GMT <alfresco-discord> <Nyddhog> I guess it depends how emails are managed, if attachments are extracted or not, aso...

2019-04-12 08:57:53 GMT <alfresco-discord> <IanW> There's an imap:attachment association, I did something different in alfresco-discussions, so depends on how the mail is getting into Alfresco

2019-04-12 13:15:05 GMT <alfresco-discord> <douglascrp> good morning everyone

2019-04-12 13:15:23 GMT <alfresco-discord> <douglascrp> @angel.borroy I was able to "fix" the timeout issue

2019-04-12 13:15:31 GMT <alfresco-discord> <douglascrp> one more problem assotiated with this https://community.alfresco.com/thread/240991-endeless-starting-of-messaging-subsystem#comment-842582

2019-04-12 13:15:34 GMT <alfbot> Title:Endeless starting of Messaging subsystem | Alfresco Community (at community.alfresco.com)

2019-04-12 13:15:34 GMT <angelborroy> nice!

2019-04-12 13:15:50 GMT <alfresco-discord> <douglascrp> this message subsystem is the one to blame

2019-04-12 13:15:53 GMT <angelborroy> wow

2019-04-12 13:15:58 GMT <alfresco-discord> <douglascrp> as soon as I disabled it, it worked

2019-04-12 13:16:16 GMT <alfresco-discord> <douglascrp> the problem is that there were no errors anywhere

2019-04-12 13:16:22 GMT <angelborroy> probably, we should provide better documentation for installation using components

2019-04-12 13:16:27 GMT <angelborroy> let me check it

2019-04-12 13:16:31 GMT <alfresco-discord> <douglascrp> that is for sure

2019-04-12 13:16:34 GMT <alfresco-discord> <douglascrp> it is not good at all

2019-04-12 13:17:03 GMT <alfresco-discord> <douglascrp> the way I discovered was when I tried to stop the service, and I saw lots of erros during the shutdown

2019-04-12 13:17:07 GMT <angelborroy> http://docs.alfresco.com/community/concepts/install-zip-overview.html

2019-04-12 13:17:08 GMT <alfbot> Title:Installing overview | Alfresco Documentation (at docs.alfresco.com)

2019-04-12 13:17:27 GMT <angelborroy> Yes, it looks like it’s required

2019-04-12 13:17:36 GMT <alfresco-discord> <douglascrp> te: ActiveMQ is required when manually installing Alfresco Community Edition 201901 GA onwards. For more information on installing and configuring ActiveMQ, see Configuring ActiveMQ.

2019-04-12 13:17:42 GMT <alfresco-discord> <douglascrp> not if you disable the subsystem

2019-04-12 13:17:47 GMT <alfresco-discord> <douglascrp> so it is not required, but optional

2019-04-12 13:17:48 GMT <angelborroy> I know

2019-04-12 13:17:53 GMT <angelborroy> Currently it’s only used for DesktopSync and the new Transformer

2019-04-12 13:18:03 GMT <angelborroy> But it should be required in the near future

2019-04-12 13:18:07 GMT <alfresco-discord> <douglascrp> not available for community, so it is wrong

2019-04-12 13:18:13 GMT <angelborroy> Probably you can switch to Docker Compose

2019-04-12 13:18:14 GMT <alfresco-discord> <douglascrp> right now, I mean

2019-04-12 13:18:24 GMT <angelborroy> Yep, right now is useless for Community

2019-04-12 13:18:26 GMT <alfresco-discord> <douglascrp> in future that might be different though

2019-04-12 13:18:35 GMT <alfresco-discord> <douglascrp> that took me 4 days of work

2019-04-12 13:18:55 GMT <angelborroy> Probably you can include a post at Community or so?

2019-04-12 13:19:05 GMT <alfresco-discord> <douglascrp> I guess

2019-04-12 13:19:18 GMT <alfresco-discord> <douglascrp> but the weird part is that nobody complained about that yet

2019-04-12 13:19:29 GMT <angelborroy> Because no one is using 6.1?

2019-04-12 13:19:31 GMT <angelborroy> :)

2019-04-12 13:19:44 GMT <alfresco-discord> <douglascrp> if you can, please, try Loftux's script without the ActiveMQ

2019-04-12 13:19:53 GMT <alfresco-discord> <douglascrp> yes, I think I am the first one 😄

2019-04-12 13:20:03 GMT <angelborroy> It’s included by default with Docker Compose

2019-04-12 13:20:03 GMT <angelborroy> https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.yml#L74

2019-04-12 13:20:04 GMT <alfbot> Title:acs-community-deployment/docker-compose.yml at master · Alfresco/acs-community-deployment · GitHub (at github.com)

2019-04-12 13:20:19 GMT <angelborroy> Probably the best approach is to take a look at Docker Compose in the future

2019-04-12 13:20:33 GMT <alfresco-discord> <douglascrp> yes, and use it as reference

2019-04-12 13:20:40 GMT <angelborroy> Currently I’m starting to index contents in SOLR by using ActiveMQ

2019-04-12 13:20:46 GMT <angelborroy> So, it’s a non stop way

2019-04-12 13:21:14 GMT <angelborroy> Repository is providing JMS messages by using Behaviours

2019-04-12 13:21:24 GMT <alfresco-discord> <douglascrp> I see

2019-04-12 13:21:36 GMT <angelborroy> And all the rest of the services are being adapted to listen to these events

2019-04-12 13:22:07 GMT <angelborroy> So, I’ll be thinking on configuring activeMQ by default

2019-04-12 13:22:14 GMT <angelborroy> Or moving to Docker Compose (it’s simpler)

2019-04-12 13:36:11 GMT <alfresco-discord> <Loftux> @douglascrp Noticed your issue report in the ubuntu install script about ActiveMQ. Is it just new version that fails? Seems like a bug in Alfresco if there is a dependency there, either all actions should fail or the new version upload should work even when ActiveMQ is not present.

2019-04-12 13:36:26 GMT <alfresco-discord> <douglascrp> @Loftux hey

2019-04-12 13:36:32 GMT <alfresco-discord> <douglascrp> I have just included more information there

2019-04-12 13:36:54 GMT <alfresco-discord> <douglascrp> so, the quick workaround was to disable the subsystem

2019-04-12 13:36:58 GMT <alfresco-discord> <douglascrp> it is working fine

2019-04-12 13:37:43 GMT <alfresco-discord> <douglascrp> and I guess that option is good enough, as @angel.borroy confirmed, it is not really a requirement, as the components using it are not available for community, YET

2019-04-12 13:37:46 GMT <alfresco-discord> <digcat> hey @douglascrp thats strange that its working using a docker-compose, with the subsystem running,

2019-04-12 13:38:10 GMT <alfresco-discord> <douglascrp> @digcat it works because ActiveMQ is there

2019-04-12 13:38:19 GMT <alfresco-discord> <digcat> ahh sorry yes,

2019-04-12 13:38:20 GMT <alfresco-discord> <douglascrp> I mean, it is included by default

2019-04-12 13:38:31 GMT <alfresco-discord> <douglascrp> but it has no real benefit

2019-04-12 13:38:48 GMT <alfresco-discord> <douglascrp> it is just one more service that can be disabled without causing any problem for the system

2019-04-12 13:39:04 GMT <alfresco-discord> <douglascrp> but that may change in the future

2019-04-12 13:39:15 GMT <alfresco-discord> <digcat> with 6.1.2-ga things are appearing in activemq, such as a rendition queue, but then the messages i guess are being dumped

2019-04-12 13:39:27 GMT <alfresco-discord> <douglascrp> exactly

2019-04-12 13:39:30 GMT <alfresco-discord> <digcat> yep

2019-04-12 13:39:37 GMT <alfresco-discord> <douglascrp> wasting resources for nothing

2019-04-12 13:39:47 GMT <angelborroy> There are messages for DesktopSync and Transformer Service

2019-04-12 13:39:50 GMT <alfresco-discord> <digcat> nothing more concrete as yet to what the plan is regarding this stuff

2019-04-12 13:40:00 GMT <alfresco-discord> <Loftux> I guess it has a long timeout by default, one way would be to set a short timeout. For the installer, probably just best to disable subsystem for now if it doesn't have any benefit.

2019-04-12 13:40:03 GMT <angelborroy> But no one is consuming the events in Community

2019-04-12 13:40:24 GMT <alfresco-discord> <douglascrp> @Loftux I vote for disabling it

2019-04-12 13:40:31 GMT <angelborroy> +1

2019-04-12 13:41:28 GMT <alfresco-discord> <digcat> perhaps kafka is a better way anyway

2019-04-12 13:41:42 GMT <angelborroy> No Kafka here

2019-04-12 13:41:48 GMT <angelborroy> Camel or ActiveMQ

2019-04-12 13:42:03 GMT <alfresco-discord> <digcat> alfresco-kafka from jeffs example

2019-04-12 13:42:21 GMT <angelborroy> This is why I said “here” :D

2019-04-12 13:50:45 GMT <alfresco-discord> <digcat> i already use activemq, so I personally would prefer that as a gateway for integration if possible, but still no clearer on the plan for what alfresco will provide in community so were not reinventing the wheel, the kafka approach does have the restoring state problem if it goes down, and of course another layer of complexity

2019-04-12 14:04:36 GMT <alfresco-discord> <Nyddhog> So on Community for 6.1.x, ActiveMQ subsystem can be disabled but for Enterprise 6.1, ActiveMQ can be disabled or it is mandatory to be installed?

2019-04-12 14:04:57 GMT <alfresco-discord> <Nyddhog> It is mandatory for the Transformer no?

2019-04-12 14:05:13 GMT <angelborroy> Yes, mandatory for Enterprise

2019-04-12 15:08:33 GMT <AFaust> Nyddhog, douglascrp, angelborroy, Loftux: The messaging subsystem is not "useless" in ACS CE 6.1. It is meant for the out-of-process extensions via event queue. It is just too bad that there are no doc articles about how to use / consume this events queue, which causes everyone to think it should not be used in Community.

2019-04-12 15:10:02 GMT <AFaust> But since the "out-of-process extensions via event queue" stuff is only relevant if anyone really wants to use it, the ActiveMQ stuff should be optional and the subsystem be able to gracefully deal with it not being available, instead of an infinite blocking wait.

2019-04-12 15:11:22 GMT <AFaust> angelborroy: I also doubt that ActiveMQ is "technically" mandatory for Enterprise. Again, only if you plan to use some specific functionalities would you need to use it. Since the whole legacy transformers code is still part of Alfresco core even in Enterprise, I would assume / expect you can set up Enterprise without ActiveMQ.

2019-04-12 15:13:01 GMT <AFaust> Loftux: The timeout is definitely set to "infinite". I actually had a Docker-based local system stuck in startup waiting for ActiveMQ for about 1.5 days because I forgot to stop the Docker image again...

2019-04-12 15:16:12 GMT <AFaust> douglascrp: In addition to the "messaging" subsystem you should also disable the "events" subsystem. Keep in mind, with the setting I provided in https://community.alfresco.com/thread/240991-endeless-starting-of-messaging-subsystem#comment-842582 you are only disabling the automatic start. So if any component tries to dynamically access it at runtime, it may get started on-demand. By disabling the "events" subsystem autoStart you are

2019-04-12 15:16:13 GMT <AFaust> disabling such a component...

2019-04-12 15:16:15 GMT <alfbot> Title:Endeless starting of Messaging subsystem | Alfresco Community (at community.alfresco.com)

2019-04-12 15:28:45 GMT <alfresco-discord> <douglascrp> Thanks you so much@Afaust

2019-04-12 16:30:33 GMT <alfresco-discord> <douglascrp> it seems this issue describes the issue I was facing with https://issues.alfresco.com/jira/browse/ACE-3300

2019-04-12 18:03:05 GMT <alfresco-discord> <dgradecak> AMQ is not mandatory for Enterprise, I disabled it on an Ent install for now

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco