Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2019-05-10 02:41:42 GMT <alfresco-discord> <Brian_SeedIM> Does anyone know what the difference is between an aws ecs versus eks clusters?

2019-05-10 02:53:19 GMT <alfresco-discord> <Brian_SeedIM> Bucketing down in Melbourne Roy, how are things up in Sydney

2019-05-10 03:02:23 GMT <alfresco-discord> <Roy> bit grey and cold up here .. winter is coming!

2019-05-10 04:00:22 GMT <alfresco-discord> <Brian_SeedIM> Nice bowl of soup down here while aws created our first eks cluster for us. Yah!!

2019-05-10 04:17:14 GMT <alfresco-discord> <Roy> nice one!

2019-05-10 04:48:51 GMT <alfresco-discord> <Roy> I have to log off to do school pick up .. I've managed to get authenticated and retieve node information from a path within R .. next is grabbing the content!

2019-05-10 06:07:24 GMT <alfresco-discord> <Brian_SeedIM> Cool..

2019-05-10 06:08:05 GMT <alfresco-discord> <Brian_SeedIM> We are stuck on the ACS nginx ingress values. No clue on how to link them to the cluster we just created.

2019-05-10 08:12:26 GMT <alfresco-discord> <Brian_SeedIM> Going offline now. We got a cluster set up in AWS but are getting errors when we try to the acs helm charts on aws. Troubleshooting for next week if we get some time. A good learning exercise but a bit to go yet. Have fun with your projects guys.

2019-05-10 08:21:28 GMT <alfresco-discord> <AFaust> Anxious to start working on an actual hack-a-thon project this morning - currently still doing early morning admin, meetings and mail...

2019-05-10 08:40:55 GMT <bmejias> Hi all

2019-05-10 08:41:04 GMT <bmejias> How is the hackathon going?

2019-05-10 08:41:27 GMT <alfresco-discord> <Thijs> Why don't you come and look?

2019-05-10 08:42:58 GMT <bmejias> I'm planning to join in the second half of the afternoon and carry on until late, very late.

2019-05-10 08:43:06 GMT <bmejias> any hacker room this year?

2019-05-10 08:43:35 GMT <bmejias> And by the way, Hi Thijs :D how are you doing? Ready for PgDay Belgium?

2019-05-10 08:43:44 GMT <bmejias> Glad to see you will be presenting.

2019-05-10 08:44:26 GMT <alfresco-discord> <ohej> @bmejias !

2019-05-10 08:44:29 GMT <alfresco-discord> <Thijs> I'm doing fine Boris. Still have a lot to prepare for PgDay

2019-05-10 08:44:58 GMT <alfresco-discord> <ohej> @bmejias We have some good hackerrooms going.. couple in London, Spain, Italy

2019-05-10 08:45:22 GMT <bmejias> Hi ohej! Ready for Sunday? I guess is mother's day in Denmark too, and that kid can't make drawings on his own yet.... so you'll have to give him a hand

2019-05-10 08:45:39 GMT <bmejias> nice to know that hackers rooms are active!

2019-05-10 08:45:39 GMT <alfresco-discord> <Thijs> @bmejias Welcome at Xenit ofcourse

2019-05-10 08:46:18 GMT <bmejias> Thanks a lot, but I have some duties in the home office as well

2019-05-10 08:46:46 GMT <bmejias> is Cristina Martin still around? today is her birthday

2019-05-10 08:59:44 GMT <alfresco-discord> <AFaust> I haven't seen Cristina around in ages (online at least)

2019-05-10 09:00:26 GMT <alfresco-discord> <AFaust> Ahh, finally (hopefully) done with all admin / mails this morning and I can start to think about what I will work on today, from the many ideas I have listed...

2019-05-10 09:08:41 GMT <bmejias> Hi AFaust! Success with your project.... I will be joining much much later

2019-05-10 12:18:43 GMT <alfresco-discord> <mbui> A noticed a customer had 150GB in their <tomcat-home>/temp folder. (Their server has a total of 280GB).. Is there any repercussions of cleaning this folder?

2019-05-10 12:19:21 GMT <alfresco-discord> <yreg> I would say you can safely clean old files

2019-05-10 12:19:42 GMT <alfresco-discord> <yreg> probably anything created more than a day ago should be safe to delete

2019-05-10 12:34:11 GMT <alfresco-discord> <AFaust> @mbui + @yreg : It always depends on what folder in /temp has the large files. /Alfresco should "generally" be safe to delete (old files, or all files during downtime)

2019-05-10 12:35:29 GMT <alfresco-discord> <AFaust> Other foldes should probably only be touched during downtime. E.g. I have written some performance-oriented code in the past which used temp folder as a cache, and might access any of the (old) files at any time...

2019-05-10 13:03:56 GMT <alfresco-discord> <yreg> @AFaust I thought system was supposed to free up space by deleting any unused temp file from /tmp/*

2019-05-10 13:04:29 GMT <alfresco-discord> <AFaust> Well... it will under /Alfresco

2019-05-10 13:04:44 GMT <alfresco-discord> <AFaust> though it may take up to 2 hours for short-term temp files, longer for long-term ones...

2019-05-10 13:05:01 GMT <alfresco-discord> <AFaust> But you can use the TempFileProvider to get other temp directories for other uses...

2019-05-10 13:05:30 GMT <alfresco-discord> <AFaust> And it is not about "unused".... it will delete ANY files that are old enough.

2019-05-10 13:05:49 GMT <alfresco-discord> <AFaust> So you can even get a problem when it deletes a file that is still used, just because it is older than the cutoff

2019-05-10 13:06:32 GMT <alfresco-discord> <AFaust> I once had a customer issue with an extremely long-running operation (huge export > 60 minutes) , where the temp files for the export got deleted while the operation was still running...

2019-05-10 13:06:57 GMT <alfresco-discord> <MariusGrunenberg> Hi everyone, even though Hackathon is right now main concern of most people, I hope I can get an answer to following question ;). So I am still facing some issues using APS 1.9 and the CORS configuration. We noticed yesterday, APS has it's own CORS mechanism and always returns "Allow-Origin: http://requesting.url.com", no matter which URL. This is of course weird, because we have our own

2019-05-10 13:06:58 GMT <alfresco-discord> Reverse Proxy Server for handling CORS request and this leads to issues, where both systems interfere with each other. One thing we noticed is the REST Endpoint "activiti-app/api/enterprise/tasks/{taskId}/action/unclaim" doesn't return an Allow-Origin header. It's just weird because we disabled CORS on APS, but it's still sending the headers, but not every one. Best case for use would be, CORS is disabled on APS

2019-05-10 13:06:58 GMT <alfresco-discord> and our Reverse Proxy handles the incoming requests.

2019-05-10 13:10:51 GMT <alfresco-discord> <AFaust> My experience with the CORS feature in APS: It is broken and we had to disable it, otherwise we would get spurious issues in some browsers where the process editor would not save changes...

2019-05-10 13:12:01 GMT <alfresco-discord> <AFaust> But I believe we also (already) had a couple of patches in place to improve consistency between web UI and ReST authentication, and may have also aligned CORS disablement that way.

2019-05-10 13:12:17 GMT <alfresco-discord> <AFaust> We = Team at the only customer of mine crazy enough to use APS

2019-05-10 13:14:12 GMT <alfresco-discord> <Hiten> Hi Guys I have created an ftl that hides the fields in the form on basis of a property value

2019-05-10 13:14:18 GMT <alfresco-discord> <Hiten> https://pastebin.com/9dMNbCdZ

2019-05-10 13:14:19 GMT <alfbot> Title:textfield-controller.ftl - Pastebin.com (at pastebin.com)

2019-05-10 13:14:49 GMT <alfresco-discord> <Hiten> I got the inspiration from this blog

2019-05-10 13:14:51 GMT <alfresco-discord> <Hiten> https://angelborroy.wordpress.com/2018/12/21/alfresco-share-form-field-visibility-depending-on-other-field-value/

2019-05-10 13:14:52 GMT <alfbot> Title:Alfresco Share form field visibility depending on other field value | Programming and So (at angelborroy.wordpress.com)

2019-05-10 13:15:16 GMT <alfresco-discord> <Hiten> but I can't seem to hide in document details page

2019-05-10 13:17:07 GMT <alfresco-discord> <Hiten> Any quick thoughts where should I start looking for changes to reflect in document details page

2019-05-10 13:24:20 GMT <alfresco-discord> <Hiten> FYI - I tried removing the field using Form Porcessor Filters registering my Filter with nodeFilterRegistry regsitry but FormData field is null in beforeGenerate() method and from documentation it seems that I can only add fields in this method

2019-05-10 13:42:42 GMT <alfresco-discord> <AFaust> @Hiten I don't know if you have realised, but in "view" mode, none of the HTML elements have an ID, so you cannot access / hide them based on ID

2019-05-10 13:47:10 GMT <alfresco-discord> <Hiten> Yes, they don't have but I am trying to hide the whole div

2019-05-10 13:47:42 GMT <alfresco-discord> <Hiten> The field that I am trying to hide have a custom-texfield.ftl form controller

2019-05-10 13:48:15 GMT <alfresco-discord> <Hiten> which is a exact copy of OOTB textfield.ftl except that I have provided an id to it

2019-05-10 13:49:01 GMT <alfresco-discord> <Hiten> id="${fieldHtmlId}-control-div" so that I catch this id and work on it

2019-05-10 13:50:24 GMT <alfresco-discord> <AFaust> But YAHOO.util.Dom.get("${fieldHtmlId}").value will not work, because there is no element with that ID from which you can get a value in "view" mode.

2019-05-10 14:24:25 GMT <alfresco-discord> <mbui> @AFaust whats so bad with APS? I have a customer that I'm implementing APS for right now together with the share connector (big yikes).

2019-05-10 14:26:02 GMT <angelborroy> With that Share Connector that has been discontinued?

2019-05-10 14:26:23 GMT <alfresco-discord> <mbui> It's supported on 5.2 :D

2019-05-10 14:26:50 GMT <angelborroy> APS 1.5/1.6?

2019-05-10 14:27:19 GMT <alfresco-discord> <mbui> 1.9

2019-05-10 14:34:20 GMT <alfresco-discord> <AFaust> We are also using the Share Connector.... it has not been discontinued, just deprecated.

2019-05-10 14:34:41 GMT <alfresco-discord> <AFaust> And since Alfresco does not provide any usable alternative to that, we simply have to continue using it.

2019-05-10 14:35:38 GMT <alfresco-discord> <AFaust> prepares for the inevitable yet somewhat naiive onslaught of "But you could build your own client using ADF..."

2019-05-10 14:36:31 GMT <alfresco-discord> <AFaust> @mbui Shall I make a collection of my most rantiest tweets about bugs / quality in APS?

2019-05-10 14:37:05 GMT <alfresco-discord> <AFaust> Don't get me wrong, I have no problem with the fact that it produces way too much work for me for which I can bill my customer...

2019-05-10 14:37:27 GMT <alfresco-discord> <AFaust> It's just that it does not help with my mental health in the long run...

2019-05-10 14:41:57 GMT <alfresco-discord> <Hiten> Thanks @AFaust

2019-05-10 14:42:27 GMT <alfresco-discord> <Hiten> I made the necessary changes in the ftl and now it is working

2019-05-10 14:42:32 GMT <alfresco-discord> <Hiten> https://github.com/rastoh/value-based-form-fields

2019-05-10 14:42:33 GMT <alfbot> Title:GitHub - rastoh/value-based-form-fields: Show and hide fields on the basis of value on a particular field (at github.com)

2019-05-10 14:52:40 GMT <alfresco-discord> <mbui> @AFaust My body is ready for that list

2019-05-10 16:18:17 GMT <xkahn> Are there any real limits to how many rows you can have in a data list?

2019-05-10 16:18:53 GMT <xkahn> Like.... say I wanted to store each time someone viewed or downloaded a document in a data list

2019-05-10 16:19:11 GMT <xkahn> So a million rows wouldn't be crazy.

2019-05-10 16:19:14 GMT <xkahn> Is that ... bad?

2019-05-10 16:28:17 GMT <alfresco-discord> <plus-> anyone doing aikau familiar with the ContainerPicker? it's supposed to default to singleItemMode true in v1.0.101.10 but is not in my experience, and I can't force it to true using configForPickedItems

2019-05-10 16:29:38 GMT <alfresco-discord> <mbui> Xkahn: Not really, possibly loading in all elements can be slow. Should be solved with pagination though. However, it sounds like you wanna use an audit application or similar for that purpose.

2019-05-10 16:30:10 GMT <xkahn> mbui: okay. Thanks!

2019-05-10 17:15:35 GMT <alfresco-discord> <AFaust> @plus- : I have used Aikau quite extensively in some projects, but as far as I remember, have always built a custom picker rather than use the default container picker, due to its various issues / limitations

2019-05-10 17:36:11 GMT <alfresco-discord> <plus-> Cheers.

2019-05-10 17:56:36 GMT <gdeverlant> greetings

2019-05-10 17:56:42 GMT <gdeverlant> can someone help me ?

2019-05-10 17:58:22 GMT <xkahn> gdeverlant: Don't ask to ask, just ask.

2019-05-10 17:58:31 GMT <gdeverlant> is there a way to setup eclipse with Alfresco to run it in debug mode

2019-05-10 17:58:58 GMT <gdeverlant> and make breakpoints in the core ?

2019-05-10 17:59:30 GMT <gdeverlant> or is there a tutorial or a video or a step by step process to set things up?

2019-05-10 18:00:59 GMT <gdeverlant> what i would like to do is to debug this AMP within to understand its inner working

2019-05-10 18:01:15 GMT <gdeverlant> https://github.com/xenit-eu/dynamic-extensions-for-alfresco

2019-05-10 18:01:16 GMT <alfbot> Title:GitHub - xenit-eu/dynamic-extensions-for-alfresco: Rapid development of Alfresco repository extensions in Java. Deploy your code in seconds, not minutes. Life is too short for endless server restarts. (at github.com)

2019-05-10 18:51:57 GMT <AxelFaust> gdeverlant: See https://www.dev2qa.com/tomcat-remote-debugging-eclipse/

2019-05-10 18:52:38 GMT <gdeverlant> well this I know but each CMS has its own development IDE setup

2019-05-10 18:52:39 GMT <AxelFaust> In order to be able to set proper breakpoints, you need to include the source code or JAR of the module you want to debug on the classpath of a Java project within Eclipse

2019-05-10 18:52:52 GMT <gdeverlant> I wish someone had already used eclipese

2019-05-10 18:52:55 GMT <AxelFaust> Alfresco does not have its own development IDE setup.

2019-05-10 18:53:28 GMT <AxelFaust> And regardless of what other (Java) CMSes may have, the basics are all the same for everyone based on Java...

2019-05-10 18:53:50 GMT <gdeverlant> ok the question is how do I debug the internals of alfresco

2019-05-10 18:54:07 GMT <AxelFaust> I have been using Eclipse with Alfresco since 2010, and the default Java remote debugging is all I have ever needed

2019-05-10 18:54:14 GMT <gdeverlant> if I'm running the 5.2 version installed from the Windows Installer

2019-05-10 18:54:24 GMT <AxelFaust> The same way. Make sure Alfresco libraries are on a project classpath and remote debug.

2019-05-10 18:55:27 GMT <gdeverlant> how do I run Alfresco in debug mode via the App Launcher ?

2019-05-10 18:55:43 GMT <AxelFaust> Simplest option is always to just setup a (dummy) extension project where you depend on the Alfresco version you want to debug and also add the 3rd-party modules you included...

2019-05-10 18:56:19 GMT <AxelFaust> You use the Tomcat service configuration tool to change its start parameters and include the Java parameters required for remote debugging.

2019-05-10 18:56:33 GMT <AxelFaust> https://tomcat.apache.org/tomcat-8.0-doc/windows-service-howto.html

2019-05-10 18:56:34 GMT <alfbot> Title:Apache Tomcat 8 (8.0.53) - Windows service HOW-TO (at tomcat.apache.org)

2019-05-10 18:57:08 GMT <gdeverlant> wait a minute

2019-05-10 18:57:42 GMT <alfresco-discord> <MariusGrunenberg> Hi guys, sorry a bit late to the party, much to do at work today. Are there any ADF projects still ongoing and maybe need some help? Otherwise I would try to play around a bit with some stuff

2019-05-10 18:57:49 GMT <AxelFaust> Oh wait - sorry. You meant to root Alfresco launcher, not the Windows service tool thingy.

2019-05-10 18:57:55 GMT <gdeverlant> this is my https://download.alfresco.com/release/community/201707-build-00028/alfresco-community-installer-201707-win-x64.exe

2019-05-10 18:58:03 GMT <gdeverlant> installation file i started with

2019-05-10 18:58:15 GMT <gdeverlant> I could not setup the 6.0 version

2019-05-10 18:58:21 GMT <AxelFaust> I despise the Alfresco installers because they create very crappy installs (good thing they are dead in 6.0+)

2019-05-10 18:58:29 GMT <gdeverlant> cause It is unclear what are the problems it doesnt work as expected

2019-05-10 18:58:41 GMT <AxelFaust> So I have not used them since my first days with Alfresco...

2019-05-10 18:58:58 GMT <gdeverlant> I tried to install Alfresco directly in tomcat

2019-05-10 18:59:24 GMT <gdeverlant> with version 6.0 but it doesnt work

2019-05-10 18:59:27 GMT <gdeverlant> the tutorial is poor

2019-05-10 18:59:39 GMT <alfresco-discord> <AFaust> @MariusGrunenberg I believe all the ADF projects have already finished for the day.

2019-05-10 18:59:52 GMT <alfresco-discord> <AFaust> The last ones to head into the evening where the guys from CASTGroup

2019-05-10 19:01:01 GMT <gdeverlant> Axel I would try to redo this http://docs.alfresco.com/community/tasks/alf-tomcat-install.html

2019-05-10 19:01:02 GMT <alfbot> Title:Installing Alfresco Community Edition on Tomcat | Alfresco Documentation (at docs.alfresco.com)

2019-05-10 19:01:10 GMT <gdeverlant> a 3rd time

2019-05-10 19:01:18 GMT <gdeverlant> could you tell me why it doesn't work ?

2019-05-10 19:02:34 GMT <AxelFaust> Without having any details on the specific errors (e.g. log output) it will be difficult...

2019-05-10 19:02:55 GMT <AxelFaust> So if you can provide any specifics...

2019-05-10 19:03:04 GMT <gdeverlant> yes

2019-05-10 19:03:11 GMT <gdeverlant> so im starting with a naked tomcat 8.5

2019-05-10 19:07:21 GMT <gdeverlant> first part finished

2019-05-10 19:07:21 GMT <gdeverlant> http://docs.alfresco.com/community/tasks/configfiles-change-path.html

2019-05-10 19:07:22 GMT <alfbot> Title:Installing the Tomcat application server | Alfresco Documentation (at docs.alfresco.com)

2019-05-10 19:37:31 GMT <gdeverlant> do I need to install solr

2019-05-10 19:37:43 GMT <gdeverlant> or can I skip it?

2019-05-10 19:37:52 GMT <gdeverlant> http://docs.alfresco.com/community/tasks/alf-war-install.html

2019-05-10 19:37:53 GMT <alfbot> Title:Installing the Alfresco WARs | Alfresco Documentation (at docs.alfresco.com)

2019-05-10 19:38:00 GMT <gdeverlant> I'm at step 6

2019-05-10 19:40:31 GMT <AxelFaust> SOLR is necessary if you want to do any kind of fuzzy metadata or even path-based searches. It is not strictly required for the operation of Alfresco, but some functionalities are not available / limited without it

2019-05-10 19:43:42 GMT <gdeverlant> is solr package with 6.0?

2019-05-10 19:44:16 GMT <alfresco-discord> <AFaust> SOLR is available separately as Alfresco Search Services

2019-05-10 19:45:36 GMT <gdeverlant> can we say that im ok with step 8 from http://docs.alfresco.com/community/tasks/alf-war-install.html

2019-05-10 19:45:37 GMT <alfbot> Title:Installing the Alfresco WARs | Alfresco Documentation (at docs.alfresco.com)

2019-05-10 19:46:40 GMT <gdeverlant> this is my setup

2019-05-10 19:46:41 GMT <gdeverlant> https://pastebin.com/e99npjdi

2019-05-10 19:46:42 GMT <alfbot> Title:[Properties] ############################### ## Common Alfresco Properties # ############## - Pastebin.com (at pastebin.com)

2019-05-10 19:49:06 GMT <AxelFaust> Just use forward slashes instead of backslashes in paths - no need to specially encode these...

2019-05-10 19:51:15 GMT <gdeverlant> ok so how do I run the server now?

2019-05-10 19:51:25 GMT <gdeverlant> startup.bat ?

2019-05-10 19:51:52 GMT <gdeverlant> wait let me add it to eclipse

2019-05-10 19:54:28 GMT <gdeverlant> https://pastebin.com/mAPcNc4T

2019-05-10 19:54:29 GMT <alfbot> Title:[Apache Log] May 10, 2019 9:53:30 PM org.apache.catalina.startup.VersionLoggerListener log I - Pastebin.com (at pastebin.com)

2019-05-10 20:00:34 GMT <AxelFaust> So you need to create some folders for the paths configured in the default files..

2019-05-10 20:01:08 GMT <gdeverlant> do i need to put tomcat in its own folder inside of alfresco-6.0?

2019-05-10 20:01:20 GMT <gdeverlant> like the 5.2 folder structure ?

2019-05-10 20:01:40 GMT <gdeverlant> cause im getting this Caused by: java.lang.IllegalArgumentException: The directory specified by base and internal path [G:\servers\alfresco-6.0/../modules/platform]\[] does not exist.

2019-05-10 20:01:44 GMT <alfresco-discord> <AFaust> Tomcat can be wherever you want it to be, as long as the configured paths are all consistent...

2019-05-10 20:01:45 GMT <gdeverlant> i created the folders

2019-05-10 20:02:01 GMT <gdeverlant> but at the root of tomcat

2019-05-10 20:02:12 GMT <AxelFaust> Ahh... I always mix up the tools to use when responding this late...

2019-05-10 20:02:17 GMT <gdeverlant> because there is /../

2019-05-10 20:02:44 GMT <gdeverlant> so it looks one level higher

2019-05-10 20:02:55 GMT <AxelFaust> Ideally, configure the path to be an absolute one. It is very likely that the ../ is relative to the working directory from which you trigger the startup.bat

2019-05-10 20:03:01 GMT <gdeverlant> i will change it to absolute

2019-05-10 20:09:55 GMT <gdeverlant> https://pastebin.com/eTcaTL3U

2019-05-10 20:09:56 GMT <alfbot> Title:[Apache Log] May 10, 2019 10:07:08 PM org.apache.catalina.startup.VersionLoggerListener log - Pastebin.com (at pastebin.com)

2019-05-10 20:10:03 GMT <gdeverlant> it stopped at Messaging service

2019-05-10 20:11:15 GMT <gdeverlant> what is that?

2019-05-10 20:11:33 GMT <AxelFaust> That is one of the most annoying new things in Alfresco 6.1

2019-05-10 20:12:03 GMT <AxelFaust> https://community.alfresco.com/thread/240991-endeless-starting-of-messaging-subsystem

2019-05-10 20:12:05 GMT <alfbot> Title:Endeless starting of Messaging subsystem | Alfresco Community (at community.alfresco.com)

2019-05-10 20:13:43 GMT <AxelFaust> Unless you disable it, you also have to set up an ActiveMQ instance: https://docs.alfresco.com/community/concepts/activemq-overview.html

2019-05-10 20:13:44 GMT <alfbot> Title:Configuring ActiveMQ | Alfresco Documentation (at docs.alfresco.com)

2019-05-10 20:13:58 GMT <gdeverlant> yeah it is deactivated

2019-05-10 20:14:52 GMT <AxelFaust> Honestly, you won't need it for quite a while. The thing it is meant to be used for is currently not really usable in a meaningful way.

2019-05-10 20:14:58 GMT <gdeverlant> https://pastebin.com/Uf1CGD36

2019-05-10 20:14:59 GMT <alfbot> Title:[Apache Log] May 10, 2019 10:13:07 PM org.apache.catalina.startup.VersionLoggerListener log - Pastebin.com (at pastebin.com)

2019-05-10 20:15:34 GMT <AxelFaust> So far so good

2019-05-10 20:16:03 GMT <AxelFaust> Apart from the issues with ImageMagick and LibreOffice, it started...

2019-05-10 20:16:13 GMT <AxelFaust> Oh, and also issue with PDF renderer

2019-05-10 20:16:18 GMT <gdeverlant> the problem is the server is running but my ide eclipse still in starting mode

2019-05-10 20:16:32 GMT <gdeverlant> for the server

2019-05-10 20:17:45 GMT <gdeverlant> Community - 6.1.2 (r4fe1d0d0-b205)

2019-05-10 20:17:45 GMT <gdeverlant> Online Documentation

2019-05-10 20:17:45 GMT <gdeverlant> Alfresco WebDav

2019-05-10 20:17:45 GMT <gdeverlant> Alfresco WebScripts Home (admin only - INTERNAL)

2019-05-10 20:17:45 GMT <gdeverlant> Alfresco API Explorer

2019-05-10 20:17:46 GMT <gdeverlant> Alfresco Administration Console (admin only)

2019-05-10 20:17:47 GMT <gdeverlant> Alfresco Forums

2019-05-10 20:17:48 GMT <gdeverlant> Alfresco JIRA

2019-05-10 20:17:49 GMT <gdeverlant> CMIS 1.0 AtomPub Service Document

2019-05-10 20:17:50 GMT <gdeverlant> CMIS 1.0 Web Services WSDL Document

2019-05-10 20:17:51 GMT <gdeverlant> CMIS 1.1 AtomPub Service Document

2019-05-10 20:17:52 GMT <gdeverlant> CMIS 1.1 Browser Binding URL

2019-05-10 20:17:58 GMT <gdeverlant> which one I use for managing the server ?

2019-05-10 20:18:45 GMT <AxelFaust> "Managing"? You mean "working with", right? Neither of these - you should access the Alfresco Share UI via the /share URL on the server, not the /alfresco

2019-05-10 20:19:17 GMT <AxelFaust> The /alfresco is "just" the backend, which provides various APIs / services, and a simple Admin Console, but the real default UI is Share...

2019-05-10 20:19:38 GMT <gdeverlant> SEVERE: Servlet.service() for servlet [Spring Surf Dispatcher Servlet] in context with path [/share] threw exception [Possible CSRF attack noted when asserting referer header 'http://localhost:8080/share/page/'. Request: POST /share/page/dologin, FAILED TEST: Assert referer POST /share/page/dologin :: referer: 'http://localhost:8080/share/page/' vs server & context: https://localhost:8080/ (string) or (regexp)] with root cause

2019-05-10 20:19:39 GMT <gdeverlant> javax.servlet.ServletException: Possible CSRF attack noted when asserting referer header 'http://localhost:8080/share/page/'. Request: POST /share/page/dologin, FAILED TEST: Assert referer POST /share/page/dologin :: referer: 'http://localhost:8080/share/page/' vs server & context: https://localhost:8080/ (string) or (regexp)

2019-05-10 20:19:39 GMT <gdeverlant> at org.springframework.extensions.webscripts.servlet.CSRFFilter$AssertRefererAction.run(CSRFFilter.java:1072)

2019-05-10 20:20:18 GMT <gdeverlant> Something's wrong with this page...

2019-05-10 20:20:25 GMT <AxelFaust> Looks like there is a misconfiguration in Tomcat.

2019-05-10 20:20:29 GMT <gdeverlant> intense why is it not working out of the box

2019-05-10 20:20:34 GMT <AxelFaust> The protocols don't match up.

2019-05-10 20:20:42 GMT <AxelFaust> http vs https

2019-05-10 20:20:51 GMT <gdeverlant> ohhhh

2019-05-10 20:20:54 GMT <gdeverlant> server.xml

2019-05-10 20:21:01 GMT <gdeverlant> i will deactivate https

2019-05-10 20:22:00 GMT <gdeverlant> <Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" />

2019-05-10 20:24:32 GMT <gdeverlant> https://community.alfresco.com/thread/214854-possible-csrf-attack-noted-when-asserting-referer-header

2019-05-10 20:24:34 GMT <alfbot> Title:Possible CSRF attack noted when asserting refer... | Alfresco Community (at community.alfresco.com)

2019-05-10 20:24:51 GMT <gdeverlant> is this right ?

2019-05-10 20:25:43 GMT <AxelFaust> Hmm... maybe they have change the default. I always configure CSRF explicitly, so never run with the default.

2019-05-10 20:26:03 GMT <AxelFaust> That post in community.alfresco.com is only relevant when you run behind a proxy

2019-05-10 20:26:13 GMT <AxelFaust> But you can take the answer to simply disable CSRF...

2019-05-10 20:26:19 GMT <gdeverlant> what do I do now ?

2019-05-10 20:26:25 GMT <gdeverlant> it is disabled by default

2019-05-10 20:26:45 GMT <AxelFaust> It is not - I mean, you can see that it is active and blocking you...

2019-05-10 20:27:28 GMT <AxelFaust> Use the share-config-custom.xml file to configure it to disabled.

2019-05-10 20:27:49 GMT <gdeverlant> oh ok i just need to uncomment it

2019-05-10 20:33:09 GMT <gdeverlant> well the eclipse ide is not making the state of server started

2019-05-10 20:33:15 GMT <gdeverlant> althought it is running well

2019-05-10 20:36:20 GMT <gdeverlant> it stops it automatically

2019-05-10 20:40:28 GMT <gdeverlant> https://pastebin.com/XynwESAP

2019-05-10 20:40:29 GMT <alfbot> Title:[Apache Log] May 10, 2019 10:36:05 PM org.apache.catalina.startup.VersionLoggerListener log - Pastebin.com (at pastebin.com)

2019-05-10 20:43:28 GMT <AxelFaust> Are you starting Tomcat from within Eclipse?

2019-05-10 20:43:56 GMT <gdeverlant> yes

2019-05-10 20:44:04 GMT <AxelFaust> I have never used the Tomcat plugins for Eclipse, so am not familiar with any quirks they may have.

2019-05-10 20:44:21 GMT <AxelFaust> Again, I just use regular remote debugging to connect to a Tomcat that was started externally.

2019-05-10 20:48:02 GMT <gdeverlant> i will use tomcat 9

2019-05-10 20:48:10 GMT <gdeverlant> cause it can be tomcat 8.5

2019-05-10 20:48:51 GMT <AxelFaust> Not sure if Alfresco will run as expected on Tomcat 9 though...

2019-05-10 20:49:28 GMT <AxelFaust> (according to all tests I have done so far, it should, but have not run it in any real customer test / production environment yet)

2019-05-10 21:03:26 GMT <gdeverlant> ok

2019-05-10 21:03:28 GMT <gdeverlant> thanx for today

2019-05-10 21:03:32 GMT <gdeverlant> im so tired

2019-05-10 21:03:36 GMT <gdeverlant> i will conitnue tomorrow

2019-05-10 21:06:51 GMT <gdeverlant> at least it runs but not in eclipse ide debug mode

2019-05-10 21:07:06 GMT <gdeverlant> thanx for your help

2019-05-10 21:08:25 GMT <AxelFaust> gdeverlant: Good night / weekend...

2019-05-10 21:08:40 GMT <gdeverlant> thanx

2019-05-10 21:08:48 GMT <gdeverlant> what is the default username password

2019-05-10 21:08:50 GMT <gdeverlant> for share login

2019-05-10 21:22:52 GMT <AxelFaust> admin admin

2019-05-10 21:28:00 GMT <gdeverlant> lol it doesnt work the admin admin

2019-05-10 21:31:37 GMT <gdeverlant> started from empty alfresco6 db

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco