Daily Log for #alfresco IRC Channel

Alfresco discussion and collaboration. Stick around a few hours after asking a question.

Official support for Enterprise subscribers: support.alfresco.com.

Joining the Channel:

Join in the conversation by getting an IRC client and connecting to #alfresco at Freenode. Our you can use the IRC web chat.

More information about the channel is in the wiki.

Getting Help

More help is available in this list of resources.

Daily Log for #alfresco

2019-11-27 12:00:47 GMT <alfresco-discord> <sumit> Hi All, I am facing a problem that all admin pages are giving error "Something's wrong with this page..." on login. While other users pages are rendering successfully.

2019-11-27 12:02:10 GMT <alfresco-discord> <sumit> I am using Alfresco community 5.2 in linux environment and contentstore exists in AWS S3 bucket.

2019-11-27 12:03:24 GMT <alfresco-discord> <sumit> Get a person API : alfresco/api/-default-/public/alfresco/versions/1/people/admin/ gives below result for admin user:

2019-11-27 12:03:26 GMT <alfresco-discord> <sumit> {"error":{"errorKey":"framework.exception.ApiDefault","statusCode":500,"briefSummary":"Not Found (Service: Amazon S3; Status Code: 404; Error Code: 404 Not Found; Request ID: 101E5A6D3884576C; S3 Extended Request ID: 78HlvvUts3M8P692E+3dhfjIxGtBqa8ScL0+bKA6R9p9ZNkPfcnzVz7wSl7KVmRUQ9r+7/9iyfo=)","stackTrace":"For security reasons the stack trace is no longer displayed, but the property is kept for

2019-11-27 12:03:27 GMT <alfresco-discord> previous versions","descriptionURL":"https://api-explorer.alfresco.com","logId":"9c76da30-c67d-4d39-b73c-d2538409b0b0"}}

2019-11-27 12:03:30 GMT <alfbot> Title:Alfresco Content Services REST API Explorer (at api-explorer.alfresco.com)

2019-11-27 12:04:23 GMT <alfresco-discord> <sumit> While it is good for other users like:

2019-11-27 12:04:33 GMT <alfresco-discord> <sumit> {"entry":{"firstName":"Manish","lastName":"Joshi","quotaUsed":0,"quota":-1,"emailNotificationsEnabled":true,"company":{},"id":"manish.joshi","enabled":true,"email":"manishjoshi@xxx.com"}}

2019-11-27 12:04:46 GMT <alfresco-discord> <sumit> Can someone please help me?

2019-11-27 12:14:21 GMT <angelborroy> Are you using SOLR 6?

2019-11-27 12:19:04 GMT <alfresco-discord> <sumit> No, It is solr4 bundled with community version 5.2

2019-11-27 12:20:21 GMT <alfresco-discord> <sumit> Previously it was working good. But from past some days this is happening.

2019-11-27 12:25:05 GMT <alfresco-discord> <MorganP> the admin account has nothing to do with the contentstore

2019-11-27 12:25:24 GMT <alfresco-discord> <MorganP> where is the DB? where is Solr index?

2019-11-27 12:26:19 GMT <alfresco-discord> <MorganP> Why would a REST API request look into your S3? That's a little bit strange no?

2019-11-27 12:30:00 GMT <angelborroy> It looks like an indexing issue

2019-11-27 12:33:40 GMT <alfresco-discord> <sumit> @MorganP DB is the postgresql database installed on a separate linux server. Solr is the bundled comes with alfresco community 5.2 on same application server. contentstore we are storing in a aws s3 bucket.

2019-11-27 12:35:02 GMT <alfresco-discord> <sumit> @angel.borroy I am also working into the indexing for now. While other users pages are accessible.

2019-11-27 12:37:35 GMT <alfresco-discord> <sumit> I was trying to re-indexing. But it is creating a write.lock file in solr core dirs.

2019-11-27 13:06:47 GMT <alfresco-discord> <mange> hey. trying to run alfresco docker containers using docker-compose as described at https://docs.alfresco.com/6.0/tasks/deploy-docker-compose.html .. the containers all come up fine but when i browse to localhost:8080, I get 404 error from the webserver. When I look at the docker logs for the "share" container (which seem to be responsible for running the service at 8080), I don't see any error or

2019-11-27 13:06:47 GMT <alfresco-discord> anything that looks weird except this: "/usr/local/tomcat/shared/classes/alfresco/substituter.sh: line 19: [: !=: unary operator expected"

2019-11-27 13:06:48 GMT <alfbot> Title:Deploying using Docker Compose | Alfresco Documentation (at docs.alfresco.com)

2019-11-27 13:11:10 GMT <alfresco-discord> <mange> (The other containers seem to be online and works when i browse to them)

2019-11-27 14:52:38 GMT <alfresco-discord> <asg> @mange I think localhost:8080 comes from the acs container and not from share. share should be available at localhost:8180/share. But I never saw the error you're facing. Just saw something here which looks like the same: https://github.com/Alfresco/alfresco-sdk/issues/554

2019-11-27 14:52:40 GMT <alfbot> Title:SDK4.0-beta1: substituter.sh: line 19: [: !=: unary operator expected · Issue #554 · Alfresco/alfresco-sdk · GitHub (at github.com)

2019-11-27 14:55:31 GMT <alfresco-discord> <asg> Hi all, I'm trying to start alfresco 6.1 with docker-compose on our jenkins to execute the ITs against it. There occurs a really strange issue which I never saw before. Anybody faced this issue before?

2019-11-27 14:55:33 GMT <alfresco-discord> <asg> 2019-11-27 12:56:55,321 WARN org.springframework.web.context.support.XmlWebApplicationContext Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'actionTrackingServiceScript' defined in class path resource [alfresco/action-services-context.xml]: Cannot resolve reference to bean

2019-11-27 14:55:33 GMT <alfresco-discord> 'javaScriptProcessor' while setting bean property 'processor'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'javaScriptProcessor' defined in URL [jar:file:/usr/local/tomcat/webapps/alfresco/WEB-INF/lib/integration-tests-0.2-SNAPSHOT-tests.jar!/alfresco/extension/disable-webscript-caching-context.xml]: Invocation of init method failed; nested exception is

2019-11-27 14:55:34 GMT <alfresco-discord> org.mozilla.javascript.EvaluatorException: Cannot add a property to a sealed object. () 2019-11-27 12:56:55,682 ERROR org.springframework.web.context.ContextLoader Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'actionTrackingServiceScript' defined in class path resource [alfresco/action-services-context.xml]: Cannot resolve reference to bean

2019-11-27 14:55:34 GMT <alfresco-discord> 'javaScriptProcessor' while setting bean property 'processor'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'javaScriptProcessor' defined in URL [jar:file:/usr/local/tomcat/webapps/alfresco/WEB-INF/lib/integration-tests-0.2-SNAPSHOT-tests.jar!/alfresco/extension/disable-webscript-caching-context.xml]: Invocation of init method failed; nested exception is

2019-11-27 14:55:35 GMT <alfresco-discord> org.mozilla.javascript.EvaluatorException: Cannot add a property to a sealed object. () at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:378)

2019-11-27 15:03:13 GMT <phaleth> @asg: try removing volume mappings from the container that is throwing the error

2019-11-27 15:06:02 GMT <alfresco-discord> <asg> @phaleth you mean in the docker-compose file? Remove volumes: - swisscom-dm-acs-volume:/usr/local/tomcat/alf_data?

2019-11-27 15:06:11 GMT <phaleth> yup

2019-11-27 15:06:34 GMT <phaleth> i should say service, but you figured

2019-11-27 15:12:59 GMT <alfresco-discord> <asg> just tried it, still the same error 😦

2019-11-27 15:16:13 GMT <phaleth> @asg: ok, hard to tell without seeing the setup, try running this one https://github.com/phaleth/alfresco-dockerized-http

2019-11-27 15:16:14 GMT <alfbot> Title:GitHub - phaleth/alfresco-dockerized-http: Dockerized Alfresco ECM incl. OCR functionality, HTTP only (at github.com)

2019-11-27 15:20:16 GMT <alfresco-discord> <asg> You're right, it's really strange because it works everywhere except our managed jenkins docker instance. Will have a look at the github project now, thanks.

2019-11-27 15:24:16 GMT <phaleth> alfresco-discord: the error you posted mentions integration-tests-0.2-SNAPSHOT-tests.jar file, that sounds like some custom stuff

2019-11-27 15:24:26 GMT <phaleth> oops

2019-11-27 15:24:41 GMT <phaleth> @asg

2019-11-27 15:26:57 GMT <alfresco-discord> <asg> not really, we're just using the generated integration-tests module from the sdk.

2019-11-27 15:29:57 GMT <phaleth> ah, ok, I don't have any experience with that, sorry

End of Daily Log

The other logs are at http://esplins.org/hash_alfresco